Avatar of Gabriel Orozco
Gabriel OrozcoFlag for Mexico

asked on 

Frame Diverter: no divert_blk to free, ppp0 not ethernet

I'm used to compile modules on the kernel and also pppd for PoPToP VPN Server, since version 1.1.4

but more and more I am reading this kind of message and then I cannot connect to the vpn server.

it is not a problem on the poptop server configuration, as it works pretty well when the divert error does not appear

before it was all a matter of restart the server, and I was thinking about resources empty like in windows or things like that hoping it would simply dissapear with newer versions of the kernel and/or pppd and/or poptop

well, I have just compiled poptop version 1.2.0, with pppd 2.4.3 and kernel 2.6.9 with latest patches

and it does not work!!! the same error as always, but this time I'm tired of looking at google. maybe I do not ask well...

anyway, this is what appears on the /var/log/debug (I'm using Slackware 10.0) and really need help:

Dec  6 00:43:17 obelix kernel: divert: not allocating divert_blk for non-ethernet device ppp0
Dec  6 00:43:40 obelix kernel: divert: no divert_blk to free, ppp0 not ethernet
Linux Networking

Avatar of undefined
Last Comment
Avatar of bloemkool1980

strange because I have the same error but my pppoe connection works without a problem.
do you do ppp or pppoe ?
And if you make a dial attempt can you sniff the connection ?
Avatar of Gabriel Orozco


hello bloemkool1980

it happends on a lot of connection types, like pppoe.
you are not having big problems because you are using only one pppoe connection (or may you have ocassional errors), but the problem arises when you are using the resource a lot, like when pppd (In this time pptpd, which calls pppd)

all the connection handshaking it's logged in the debug log. when the client is already authenticated, and the system must launch pppd, is when the error happends.

if you find a fix, please let me know.

Avatar of bloemkool1980

Blurred text
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Avatar of Gabriel Orozco



I found the problem in openvpn.

(this is for the problem of no transmit) the frame diverter warning still continues, but I believe I must reward your help.

Thank you!

goodluck and thanks
Linux Networking
Linux Networking

The variety of Linux distributions creates myriad issues relating to configuration and operations when computers are networked, not the least of which is the use of various network management applications, some of which are included with specific distributions, while others are standalone applications.

Top Experts
Get a personalized solution from industry experts
Ask the experts
Read over 600 more reviews


IBM logoIntel logoMicrosoft logoUbisoft logoSAP logo
Qualcomm logoCitrix Systems logoWorkday logoErnst & Young logo
High performer badgeUsers love us badge
LinkedIn logoFacebook logoX logoInstagram logoTikTok logoYouTube logo