Link to home
Start Free TrialLog in
Avatar of AlMualla
AlMualla

asked on

D-Link Wireless ADSL Router & DHCP.

Hi there !


I have D-Link ADSL-G604T Wireless ADSL Router connected via Wi-Fi to a  laptop running under Windows XP Professional OS equipped with a 3Com Wireless 11g PC Card.

Problem is that I am not able to get any IP address from the router via DHCP; while I am able to get  an IP Address automatically when I am using my other laptop which is running under Windows 2000 Professional OS.

I have latest drivers and firmware, and DHCP is enabled on both Router and PCI card ... but some unknown reason I am not able to get an IP Address by the router. However, I supposed to get an IP Address like 192.168.1.X with subnet mask of 255.255.255.0 but I am getting 169.254.99.75 and subnet mask of 255.255.0.0 and I have tried to release and renew the IP but the same thing :/

I know that I could use a static IP Address, but I would prefer to work in DHCP.

Thanks in advanced.
Avatar of stevenlewis
stevenlewis

>> know that I could use a static IP Address, but I would prefer to work in DHCP
does it work with a static ip?
Avatar of AlMualla

ASKER

I have just tried it and I could not :/

Even with a static IP I cannot connect.
First: look for latest software/driver updates for your 3Com Wireless PC card;
Second: make sure you are not using one of D-Link´s proprietary features, like Turbo mode.

I do have a similar setup, but using DI-624 router and a DWL-G520 PCI card on a PC.
Occasionally I need to re-install drivers on my PC in order to have it working.

Celsmk
OK, since it can't connect, is the channel, ssid and (if used) wep/wpa set right?
celsmk,

I have installed the latest software and driver for 3Com and the same thing and regarding the properties of the D-Link feature such as Turbo mode I did not get you.


 stevenlewis

Actually I have check the channel, SSID and WEP several times and I have deleted the profile and recreate it and the same thing.

I really don't know where is the problem! Do you think that I have to reset the router as it was when I bought it from the manufacturer and do the whole configuration from the beginning?
If the other laptop is getting an addres OK, then that shouldn't be the problem, but you can try it
Yea, there is no problem with the other laptop. I am thinking if Windows XP causing this issue or not coz I have read the same issue somewhere else but with no help.
ASKER CERTIFIED SOLUTION
Avatar of stevenlewis
stevenlewis

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
stevenlewis,

Thank you, I have just noticed the zero wirless was stopped and I have started and works with me great.
Glad to help!
The only problem here is that zero wireless service does not start when I restart the laptop.

I think this is another issue :/
set it to automatic
already done, but everytime I restart my laptop I noticed it is not starting.
right click on it, choose properties, and check the dependensies
alkso check recovery
make them all restaart the service
you can also start it from a batch file
net start wzcsvc