Link to home
Start Free TrialLog in
Avatar of shapiro360
shapiro360

asked on

adding a new subnet to a layer 3 switch

I need to add another subnet to my Cisco 3550-emi switch. I have done this before on the core layer switches and i want to do it on this one which is on the access layer. I can't ping the new subnet on the 3550 that I am putting it on. It tells me that the interface I am putting this on is not connected. I have had this line fully tested and there is no problem in the line. Do you have any advice, thanks.



User Access Verification

Password:
net-mjcdispatch-sw06>ena
Password:
net-mjcdispatch-sw06#show run
Building configuration...

Current configuration : 3286 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime

!
hostname net-mjcdispatch-sw06
!
enable secret
!
ip subnet-zero
ip routing
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/2
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/4
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/5
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/6
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/7
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/8
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/9
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/10
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/11
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/12
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/13
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/14
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/15
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/16
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/17
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/18
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/19
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/20
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/21
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/22
 switchport mode dynamic desirable
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/23
 switchport mode dynamic desirable
 no ip address
!
interface FastEthernet0/24
 switchport mode dynamic desirable
 no ip address
!
interface GigabitEthernet0/1
 description **** to Animal Control****
 no switchport
 ip address 10.1.12.xx 255.255.255.0
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
 no ip address
!
interface Vlan1
 ip address 10.1.2.xx 255.255.255.0
!
router eigrp 21
 network 10.0.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip http server
!
!
snmp-server community
banner login ^C^C
!
line con 0
 password
 login
line vty 0 4
 password
 login
line vty 5 15
 password
 login
!
end

net-mjcdispatch-sw06#

di I need to create a seperate VLAN here or add a static route to get to the 10.1.12.0 subnet?
Avatar of cooledit
cooledit
Flag of Ireland image

Hi, there

You will need to create another VLAN
Set the ip address for the VLAN and for the port



switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan all

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008019e74e.shtml
ASKER CERTIFIED SOLUTION
Avatar of harbor235
harbor235
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial