"Error: \\pc name is not accessible. You might not have permission to use this network resource...Access is denied." When trying to access a share.

I have 2 PC's on a wireless network - a laptop with Win XP home and a desktop with Win XP pro. Both PC's can see each other on the network under "view workgroup computers". The Desktop can access the Laptop's shares but the laptop cannot access the desktops shares - I get the above error message.

Have tried:

- Both ping each other successfully
- Computer browser is running on both
- Only one transport protocol installed, namely TCP/IP
- NetBIOS over TCP/IP is enabled in WINS
- Uninstalled third party client software
- Repaired the IP stack
- Repaired the Winsock
- Checked all NetBIOS names for possible duplicates
- McAfee Firewall & Antivirus disabled (even tried uninstall)
- MS Firewalll disabled
- Both PC's have same users with no passwords
- Simple file sharing disabled on XP Pro (not poss on XP Home)

Any other suggestions??





Supernumbers123Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

stevenlewisCommented:
yees, log on to both amchines with identical usernames and passwords
or add the laptop user to the desktop (again exact username and password that they log onto the laptop with
or
0
stevenlewisCommented:
Run local security policy editor from control panel admin tools and set the local policy, Network Access: Let everyone permissions apply to anonymous users, to enabled and make sure guest account is enabled
not as secure
0
stevenlewisCommented:
set passwords for both (the same)
0
Webinar: Miercom Evaluates Wi-Fi Security

It's not just about Wi-Fi connectivity anymore. A wireless security breach can cost your business large amounts of time, trouble, and expense. Plus, hear first-hand from Miercom how WatchGuard's Wi-Fi security stacks up against the competition in our upcoming webinar!

Supernumbers123Author Commented:

Thanks for your response stevenlewis. I have tried each of the suggestions on both PC's and unfortunately still have the same problem. Any further thoughts?
0
MrArubaCommented:
install the 'file and printer sharing for microsoft networks' protocol !
0
Supernumbers123Author Commented:

Thanks MrAruba, but both PC's already have this installed.
0
MrArubaCommented:
In Windows XP home edition, you cannot access the share unless the guest account is enabled.

When you attempt to  map drives or access files on shares in a Microsoft Windows XP Home Edition-based organization, the action does not work and you may receive an "Access is denied" error message.

In Windows XP Home Edition, all network connections (logons) are mapped through the guest account. If the guest account is not enabled or if it does not have the appropriate share permissions, the connection does not work. If the guest account has sufficient share permissions, but has not been given NTFS permissions, you can connect to the network, but you cannot access  files or directories.

To resolve this issue, ensure that the guest account is enabled and has been granted appropriate access permissions on both the share and the NTFS levels. You can grant access to the guest account, or to the Everyone group.
0
Supernumbers123Author Commented:

Thanks.

Both PC's have the Guest a/c enabled.

Share level: For the required shared directory: under properties, sharing, permissions: "Everyone" is listed (on the PC that cannot be accessed).
NTFS level: For the required shared directory: under properties, security, permissions: "Everyone" is listed (on the PC that cannot be accessed).

Not sure if it is relevant but I can only add group or user names from the location of the Desktop PC. It does not list the laptop. i.e even though I have "everyone" set up, I am unable to add Guest(Laptop\Guest) - only Guest(Desktop\Guest) to the list of Group or user names.






0
MrArubaCommented:
does the xp home see the xp pro under network locations? did you try this command in run '\\xppromachine\c$'
I think your problem is actually in the fact that you are not able to create laptop\guest. Will think about it.

XP Home is not created for networking so did you consider upgrading to Pro?
0
Supernumbers123Author Commented:
Both PC's see each other under "view network computers", it is only the XP Home PC that cannot see the shares, the Pro can see all shares.

Tried the command suggested from both PC's - you may have hit on something -

From the XP pro - no problem
From the XP Home - error "Multiple connections to a server or shared resource by the same user using more than one user name are not allowed. Disconnect all previous connections to ther server or shared resource and try again." Not sure what to do about this??

Not keen to upgrade the laptop to pro if I can help it.

Thanks again for your help.





0
stevenlewisCommented:
In windows explorer, on the laptop, does it show any mapped drives to the desktop?
0
Supernumbers123Author Commented:

The only link on the laptop with XP Home to the Desktop with XP Pro is under "My Network Places, MS Network, MSHome, desktop name icon". There are no other links. There are no mapped drives directly under "My Computer" in explorer on either PC.



0
MohameditCommented:
the error saying that u cant log with pc name what about using \\ip it will be like that \\xxx.xxx.xxx.xxx is it work or not.
u can get computer ip from opening start - run - cmd- dos window will open now wright this command ipconfig u will have the ip address try to log with it.

pls inform me what happen.
0
Supernumbers123Author Commented:
Thanks Mohamedit.

I get the same error message that I had in my first posting.

0
stevenlewisCommented:
this mentions a domain,
http://www.windowsnetworking.com/articles_tutorials/wxpjoind.html

on both machine please go to a prompt and type
net view
and then
net share
post the results here
0
MrArubaCommented:
maybe something just went wrong creating the shares? Have you tried to unshare the XPpro drive and the create the share again?
0
Leon FesterSenior Solutions ArchitectCommented:
What is happening there is that your XP Home machine is trying to connect to the XP Pro machine with 2 different sets of credentials. I suspect that you've enabled the quick logon option, which caches network drive info aswell.

Try net use * /d to disconnect all network connections on the XP Home machine, even connecting via IPC$ uses a specific set of credentials, which could conflict with any other type of connection that you may be trying to connect with later.
0
Supernumbers123Author Commented:
Thanks Stevenlewis.

I followed the link you gave me carefully and when trying to enter the name of the Domain Server (MSHOME) on both PC's I got the following error: "A domain controller for the domain MSHOME could not be contacted. Ensure the domain name is typed correctly". I was unable to proceed past this.

Results of net view on both PC's (identical response) are:

Server Name            Remark
-------------------------------------------------------------------------------
\\SILVER
\\VAIO
The command completed successfully.

Results of net share on Desktop:

Share name   Resource                        Remark
-------------------------------------------------------------------------------
C$           C:\                             Default share
print$       C:\WINDOWS\system32\spool\drivers
                                             Printer Drivers
ADMIN$       C:\WINDOWS                      Remote Admin
IPC$                                         Remote IPC
SHARE        C:\SHARE
Shared Folder on Silver
             C:\Documents and Settings\Terry & Maren\My Documents\Terry's Stuff\
Shared Folder on Silver

SharedDocs   C:\Documents and Settings\All Users\Documents

Printer      LPT1:                  Spooled  EPSON Stylus Photo 890
The command completed successfully.

Results of Net share on Laptop:

Share name   Resource                        Remark
-------------------------------------------------------------------------------
D$           D:\                             Default share
C$           C:\                             Default share
ADMIN$       C:\WINDOWS                      Remote Admin
IPC$             C:\DOCUMENTS AND SETTINGS\ALL USERS|DOCUMENTS
Vaio's Shared Folder
                   C:\Documants and Settings\Terry\My Documents\Terry\My Documents\Terry's Stuff\Vaio's Shared Folder

The command completed successfully.





0
stevenlewisCommented:
try this troublshooting site
http://65.24.134.81/KipSolutions/P2PNetworks/TroubleshootingP2P.htm
special thanks to FE for the web site
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Supernumbers123Author Commented:
Thanks MrAruba.

I have tried creating a new share and still no luck.



0
Supernumbers123Author Commented:
Thanks dvt localboy

Tried net use * /d. Only one remote connection reported and cancelled. I still cannot access share.

Any other ideas?
0
Supernumbers123Author Commented:
stevenlewis

Problem solved - well done stevenlewis you are a star !

Here's what worked for the benefit of others with the same problem:

Followed your link: http://65.24.134.81/KipSolutions/P2PNetworks/TroubleshootingP2P.htm

I followed steps 1-9 without success until got to step no.10 "Try Using the same username and password", setting up a new identical user on both PC's (I set up a new administrator). The step states that you cannot change an existing user but must add a new one - this was the mistake I made before I only checked that both PC's had identical users and passwords.

Thanks to all other who assisted me.




0
stevenlewisCommented:
Glad it's working!
0
005Commented:
stevenlewis how do u get to where u said  can u tell me how to get there?


`Run local security policy editor from control panel admin tools and set the local policy, Network Access: Let everyone permissions apply to anonymous users, to enabled and make sure guest account is enabled
not as secure`
0
stevenlewisCommented:
005, this question is closed, you need to ask your own question here
http://www.experts-exchange.com/Networking/
and the experts will be happy to help :-)
0
damianreidCommented:
Install service advertising protocol and install microsoft tcp/ip version 6 from the LAN properties.
0
kemisCommented:
I realize this topic has long since been closed (with an appointed Accepted Answer rather than an actual one), but after pulling my hair out as the original poster of this question did (after all the generic "try this" responses were exhausted), I finally found a solution to this issue on another Web site.

This problem is caused when the "RestrictAnonymous" LSA registry value in XP gets changed from its default value of "0" (disabled) to "1" (enabled).  This registry value can be located by opening regedit and going to:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]

A more user friendly way of adjusting this same setting is to go to Control Panel --> Administrative Tools --> Local Security Policy --> Local Policies --> Security Options.  Make sure the following setting is set to "Disabled":
-- Network access: Do not allow anonymous enumeration of SAM accounts and shares

Do not confuse this setting with the setting that preceeds it not including the text "and shares" at the end of it.  That's an entirely different setting that should be "Enabled" by default!

The following text is what Eric on the internet had to say about the issue:
Source:  http://cert.uni-stuttgart.de/archive/focus-ms/2002/03/msg00088.html

"Null sessions can *always* be established to NT4, Windows 2000, and Windows
XP machines.  If the machine's server service is enabled, and ports 139 or
445 are available, then you can do a net use with anonymous credentials,
and the system will respond with "Command completed successfully".  This
has not changed from NT4 to Win2K to XP.

What has changed, however, is what you are able to do once you establish
the null session.  In NT4 and Win2K, by default, you could enumerate
information about users and shares.  Setting RestrictAnonymous=1 would help
prevent against this enumaration (though not fully).  RestrictAnonymous=2
(Win2K only) would fully prevent this enumeration.

On Windows XP, there are new registry keys:

RestrictAnonymousSam=1 is a default setting.  This prevents detailed
enumeration of user accounts.  This setting correlates with the
SecurityPolicy setting "Do not allow anonymous enumeration of SAM
accounts"  with a default setting 'Enabled" (meaning the default of XP will
prohibit anonymous enumeration (R.A.SAM=1).

RestrictAnonymous=0 is a default setting.  This correlates with the
SecurityPolicy Setting "Do not allow anonymous enumeration of SAM accounts
and shares".  Set this policy to 'Enabled' (RA=1) to prevent anonymous
enumeration of shares.

RestrictAnonymous=2 (on XP) is no longer a valid setting.

So, by default, on an XP system, you can anonymously connect and enumerate
shares by default, but you cannot enumerate detailed user information.

To disable anonymous connections altogether, block access to tcp139/445
(IPSec port filters or Internet Connection Firewall), or uncheck "File and
Print Sharing for Microsoft Networks" from the network interface in
question (via the properties tab of the network connection)."
--------------------------------------------
Hope this has helped anyone else having this problem and found no solution after all the "standard" troubleshooting.

-- Matt
0
dylanchauCommented:
Try: Start ---> Programs ---> Accessories ---> Communications ---> Network Setup Wizard
0
suzeshCommented:
Enable Guest account in both computer.
Make a same user in both computer
In Administrative tool, open local security policy.
Expand the local policy and click on user right assignment.
In Access this computer from the network -== add the guest, currently created user and everyone in both computer.
In Deny access this computer from network -== remove except support_388945a0
restart.
I think this will solve your computer.
If not...
Your computer may be infected with virus.
Install Windows XP again.

Regards
Suzesh
0
tarnowplCommented:
I had the same problem and all I did was uninstalled Norton Internet Security.  I have Norton Anti-virus installed on both and everything works fine.
0
darylpittsCommented:
After two days of searching and experimenting, I found that this was the answer I was looking for. Indeed Service Pack 2 really ups the security, so this was required to turn on anonymous sharing:

Local Security Policy --> Local Policies --> Security Options.  Make sure the following setting is set to "Disabled":

Thanks for the help KEMIS!!
0
sorted_orderCommented:
After installing Windows 2003 SP1 on a domain controller I received the same error message when trying to access both normal (\files, \c$) and system (\SYSVOL, \NETLOGON) shares on that machine. Since this is a server & DC the fix is different.

First, this article from MS restored access to the normal shares: http://support.microsoft.com/?kbid=839499 (Note: only this server had incorrect LanMan parameters, despite a Group Policy that was set correctly. I would recommend running gpupdate & dcdiag on the server, to be sure things are right, before you install W2k3 Svr SP1.)

Unfortunately the above fix didn't restore access to the SYSVOL & NETLOGON shares. I needed to remove & reinstall the DC role on the server before those were fixed.
0
carl_legereCommented:
*I realize this is solved*

You can receive this error due to a conflict with windows mapping VS scripted or net use mapping.  The credentials you enter, beleive it or not are stored differently in your local cache, and they don't always know about each other.  

If you have ever attempted to map via either method and received the error that there is already a connection to this server using different credentials, you'll understand that there are problems that can arrise with the credential storage.  My logon scripts process a net use /delete first before each net use, to help avoid this error.

it makes no sense to me why such a credential conflict can occur.  Why should windows care if I'm using \\server\share as joe and then want to map as fred.  Or I am using \\server\share as joe and want to use \\server\share2 as fred that will cause problems also.
0
pjtcbCommented:
I've had the same issue for months, and finally decided to tackle it...the comment from kemis fixed my probem instantly:  Disable:  Local Security Policy/Local Policy/Security Options -  "Network access: Do not allow anonymous enumeration of SAM accounts and shares"
0
dominicbentleyCommented:
Hi All
I've followed the suggestions through on this post - still getting the issue.  

Have x2 laptops (A & B) and one desktop (C), all running xp sp2, Mcafee firewall / av etc.

A can access C's shares and vice versa
B can access C's shares but not vice versa
B can access A's shares but not vice versa.

Therefore I suspect issue is with B.  However,  when checking throught the security policy settings mentioned above for A & B there is no difference??  Neither A nor B have active Guest accounts.

Have tried removing and re-establishing the share on B but to no avail.

I've confirmed that all can ping each other and as the Netgear router was making a pig's ear of DNS have setup host files on all.

Help me please - this is v frustrating....
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Analysis

From novice to tech pro — start learning today.