troubleshooting Question

cpio compatibility between linux and aix

Avatar of nescioii
nescioii asked on
Unix OS
6 Comments2 Solutions1392 ViewsLast Modified:
We have some DDS3 tapes containing cpio archives; these were made on a linux system (don't know which flavour). Now we want to extract them on an AIX system (version 4.2.1.0), but constantly get the 'out of phase' error.
The original command to put them on tape (according to the person who did it): cpio- ovcB <FILENAME> >/dev/rmt0.
The command with which we try to extract: cpio -icvB </dev/rmt0, comes up with the abovementioned error. We tried changng the blocksize to different sizes and to a variable size, but to no success. We tried a diskdump (dd if=/dev/rmt0 bs=128k of=<FILENAME>.cpio) which indeed put the file on the aix system; however, the cpio on that file resulted again in 'out of phase'.
My question: are there known compatibility issues regarding the cpio command between linux and aix, and if so, how to solve it?

Regards,
Henk de Jong (not very much into unix)
ASKER CERTIFIED SOLUTION
Gns

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 2 Answers and 6 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 2 Answers and 6 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros