Avatar of martynhills
martynhills
 asked on

6509 Vlan trinking

I have a Cisco 6509 connected to netgear 7300 POE switches via Gigabit ports

I need to configure the cisco end such that it can interoperate with the Netgear.

The netgear has two Vlans and all ports are members of both vlans.  The vlans are Vlan 10 which is untagged and vlan 30 which is tagged.

At the Cisco end I need to associate an IP addres to each vlan and provide an IP helper so that dhcp requests from either vlan are passed to a dhcp sever.

The netgear config is below - can anyone help with how I should configure the 6509

Thanks



! configure switch management and management vlan
en
network protocol none
network params 192.168.0.254 255.255.255.0 0.0.0.0
network mgmt_vlan 30

! create vlan 10 for IP Phone, vlan 30 for PC
vlan database
vlan  10
vlan name 10 IP_Phone_VLAN
vlan  30
vlan name 30 PC_VLAN
exit

! config mode
config

! Include all ports in vlan 10 and 30, exclude all ports from default vlan 1
vlan participation all include 10
vlan participation all include 30
vlan participation all exclude 1
! Enable tagging for all port for vlan 10
vlan port tagging all 10
! Assign PVID 30 for all ports
vlan port pvid all 30

! Create diffserv class for dscp ef
class-map match-all Diffserv_Class_ef-46
match ip dscp ef
exit
! Create policy and attach class, mark packet with ip-dscp ef
policy-map DiffServ_Policy_ef-46 in
class Diffserv_Class_ef-46
mark ip-dscp ef
exit
exit

! Attach diffserv policy to each interface, tag uplink port 26 with vlan 10
interface 0/1
service-policy in DiffServ_Policy_ef-46
exit
interface 0/2
service-policy in DiffServ_Policy_ef-46
exit
interface 0/3
service-policy in DiffServ_Policy_ef-46
exit
interface 0/4
service-policy in DiffServ_Policy_ef-46
exit
interface 0/5
service-policy in DiffServ_Policy_ef-46
exit
interface 0/6
service-policy in DiffServ_Policy_ef-46
exit
interface 0/7
service-policy in DiffServ_Policy_ef-46
exit
interface 0/8
service-policy in DiffServ_Policy_ef-46
exit
interface 0/9
service-policy in DiffServ_Policy_ef-46
exit
interface 0/10
service-policy in DiffServ_Policy_ef-46
exit
interface 0/11
service-policy in DiffServ_Policy_ef-46
exit
interface 0/12
service-policy in DiffServ_Policy_ef-46
exit
interface 0/13
service-policy in DiffServ_Policy_ef-46
exit
interface 0/14
service-policy in DiffServ_Policy_ef-46
exit
interface 0/15
service-policy in DiffServ_Policy_ef-46
exit
interface 0/16
service-policy in DiffServ_Policy_ef-46
exit
interface 0/17
service-policy in DiffServ_Policy_ef-46
exit
interface 0/18
service-policy in DiffServ_Policy_ef-46
exit
interface 0/19
service-policy in DiffServ_Policy_ef-46
exit
interface 0/20
service-policy in DiffServ_Policy_ef-46
exit
interface 0/21
service-policy in DiffServ_Policy_ef-46
exit
interface 0/22
service-policy in DiffServ_Policy_ef-46
exit
interface 0/23
service-policy in DiffServ_Policy_ef-46
exit
interface 0/24
service-policy in DiffServ_Policy_ef-46
exit
interface 0/25
service-policy in DiffServ_Policy_ef-46
exit
interface 0/26
service-policy in DiffServ_Policy_ef-46
vlan tagging 10
exit
! save running config into nvram
copy system:running-config nvram:startup-config

Routers

Avatar of undefined
Last Comment
harbor235

8/22/2022 - Mon
Don Johnston

Is the 6509 IOS or COS?

Are you trunking between the Netgear and the 6509? If so, what trunking protocol?

Is the 6509 going to be providing routing to the Netgear?

-Don
harbor235

The 6509 only supports ISL or 802.1Q, ISL is Cisco's proprietary trunking protocol, I doubt that the netgear supports that.
So your netgear must do 802.1Q? You just need to trunk the vlans(tag) to the 6509 that need layer 3 interfaces. Then if you are in hybrid mode or IOS just create the interface. It is a virtual interface in either case, now it would be a little different if it was a point to point link

in config mode:
    interface vlanA
   ip address xx.xx.xx.xx
   no shut

harbor235

I assume you have at least SUP with a MSFC for the layer 3 component. All vlans are by default trunked to the MSFC so when you create the interface (in either mode) there will be layer to connectivity to th erouter interface, unless someone went in and manually cleared vlans off the virtual trunk to the MSFC.

harbor235
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
mikebernhardt

All addressing and interfaces are for example only, you'll have to change to suit your situation. these both assume that routing is taken care of in your 6509, one way or another. Either way, this will create a trunk port running 802.1q with your vlans on it, and provide IPs and dhcp forwarding:

If the 6509 is native mode:
config t
vlan 10
vlan 30

interface vlan 10
 ip address 192.168.10.1 255.255.255.0
 ip helper-address [dhcp server address]
 no shutdown
interface vlan 30
 ip address 192.168.30.1 255.255.255.0
 ip helper-address [dhcp server address]
 no shutdown
interface G1/1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10 [not sure what your native vlan is, you'll have to determine what this should be]
 switchport trunk allowed vlan 10,30
 switchport mode trunk
 no shutdown


If in hybrid mode:
in Cat OS:
set vlan 10
set vlan 30
set vlan [native vlan] 1/1
set trunk 1/1 on dot1q
clear trunk 1/1 1-9,11-29,31-1005

in router:
config t
interface vlan 10
 ip address 192.168.10.1 255.255.255.0
 ip helper-address [dhcp server address]
 no shutdown
interface vlan 30
 ip address 192.168.30.1 255.255.255.0
 ip helper-address [dhcp server address]
 no shutdown


 
ASKER CERTIFIED SOLUTION
harbor235

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.