Question Title: Unable to start debugging on the web server. Could not start ASP.NET or ATL Server debugging. Verify that ASP.NET or ATL Server is correctly installed on the server.

xersoft
xersoft used Ask the Experts™
on
I get the following error when I try to run my ASP.NET app:

Error while trying to run project: Unable to start debugging on the web server. Could not start ASP.NET or ATL Server debugging. Verify that ASP.NET or ATL Server is correctly installed on the server.

Here’s some info that may be of interest:

1) I do have an ASP.NET application that I can run and it works while debugging! It seems that only my most recent app and ALL new ones are suffering from this problem.

2) When I try to start the app without debugging I get an error that says the aspx file that is trying to be loaded can not be found, here’s the exact error:

Server Error in '/WebSiteTestApp' Application.
--------------------------------------------------------------------------------

The resource cannot be found.
Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested Url: /WebSiteTestApp/WebForm1.aspx

--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET Version:1.1.4322.2032

3) If I close visual studio and open IE and type in the following URL I also get the above error message: http://localhost/WebSiteTestApp/WebForm1.aspx

4) If I create a normal .html file, TEST.HTML, and place it in the same directory as WebForm1.aspx and then go to http://localhost/WebSiteTestApp/TEST.HTML the test.html file will come up.

5) The weirdest thing about the entire situation is that I CAN open some asp.net web sites on my computer and work with them as I always have. It only seems to be New ones and my most recent one. (I have been working on the most recent one for a few months now and this problem only happen recently)

6) I tried aspnet_regiis -ua followed by aspnet_regiis -i and it had no effect
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Can you check following things?

How about your web.config file, is it welformed?
Do you have debug=true in your web.config file.....
<compilation defaultLanguage="vb" debug="true" />

How about your permission settings?
Are you member of VS Developers as well as Debugger Users, so is the ASPNET account.=20

Try restarting IIS with iisreset at command prompt and go to your framework directory and run aspnet_regiis -i

REgards.
MaulikCE
One last thing to check for is,

Application configured as virtual directory in IIS? if not configure it and then restart IISAdmin service from AdminTools>Services..





Author

Commented:



Config file line: <compilation defaultLanguage="vb" debug="true" />

The config file was generated by VS.NET and I have not made any changes yet.

This is a new project with a single web form named WebForm1.aspx

ASPNET and Myself are part of VS Developers
ASPNET and Myself are part of Debugger Users

Tried to use the command iisreset.exe: said it was attempting stop... successfully stopped Attempting start... Successfully restarted

Ran C:\Windows\Microsoft.net\framework\v1.1.4322\aspnet_regiis.exe

After doing all of that creating a new project or using my old one still gives the same error. And here’s the best part! I can still get some asp.net projects to work normally. It's only new ones and a few older projects that appear not to work. I'd say it must be the web.config file except that I can create a brand new web project and it still does not work.

Thank you for the ideas though.
Bootstrap 4: Exploring New Features

Learn how to use and navigate the new features included in Bootstrap 4, the most popular HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites.

Author

Commented:
Well you know thats very intresting, when I look at the web site that does work under iis I see the normal Virtual Directory tab and the local path is set to the actual folder. The sites that do not work (including the ones I create with VS.net as new projects) have a tab called directory and the Local Path is a share of some sort like \website. What is this all about? (I hope it's the problem!)

Author

Commented:
That was the problem! I guess I did not see this as a possibility because I had problems even creating new projects with VS.NET. I though it would set up this stuff for me. Further, I'm not sure how this virtual directory was turned off of some of my sites, thus causing them not to work until I set up a virtual directory. Thank you for your help! If you have any ideas on why the virtual directorys went away or why VS.NET will not correctly create one for a new web project I'm all ears.

Commented:
Hullo, I had same problem in delphi - its when IIS is installed after .net framework, see:
http://www.experts-exchange.com/Programming/Programming_Languages/Dot_Net/ASP_DOT_NET/Q_21309471.html
:) P

Commented:
oops sorry - going bonkers & pasted wrong link - its actually:
http://bdn.borland.com/article/0,1410,33279,00.html
long day sorry, P

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial