ExMerge "Error encountered getting mailbox information..." Error message

Hi,
 
We have a Exchange 2003 server. We are trying to use ExMerge v6.5.7408.1. I
always get this error message:
Error encountered getting mailbox information from the private information
store database(s) on server 'SERVERNAME'. Make sure you have adequate
permissions on the Information Store object. Please refer to the 'C:\Program
Files\ExMerge\ExMerge.log' log file for more information.


I applied the following KB articles and still the same error:
KB292509 and KB867503.

Any other ideas?

Thank you

vkatonaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Insane_ProCommented:
Hello,

The account that you are logged in to run ExMerge should have Send As and Receive As permissions on the Store level.

If the account is a part of Administrators, Domain Admins, Enterprise Admins, Exchange Domain Servers, they would have Explicit Deny Permissions. And Deny permissions always overrides Allow.

So the best possible way you can make sure that you have the permissions straight is:

1. Create a new user account in AD.
2. On the Exchange System Manager, on the properties of the server, add the account in the security tab and provide Send As and Receive As permissions for that acocunt. Make sure that there are no Explicit Deny permissions.
3. Make sure that the security settings have propagated to the Storage Group level and also the Store level. If they have not, they add the account at these levels and provide the Send As and Receive As permissions.
4. Also make sure that you are logged in using the account while running ExMerge.

Hope this helps in resolving your issue.

Thanks,
=Insane_Pro=
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vkatonaAuthor Commented:
Thank you for the reply. I have modified the original Domain Admin group Deny settings on both level by unchecked and copied the inherit settings in the security setting.  So these accounts/groups should not have this setting. I will try your suggestion too.

Thank you,


0
_ruudsje_Commented:
Try this: Full Mailbox Access ->
------------------
1. Right click on <organization name> (Exchange)
2. Click properties
3. Click Security
NO Tab Security – Start Regedt32 -> Go to:
Hkey_Current_User->Software->Microsoft->Exchange->ExAdmin
create a Dword Value ‘ShowSecurityPage’ with Value data = ‘1’
4.Click on Administrator, and all other domain admins, etc
5.Deselect: Deny - Receive As
6.Deselect: Deny – Send As
------------------

And check security setting on folders below are set to allow inhirit....and check if it also changed the security settings (sometimes it will set the permissions on highest level good and the folders below doesn't take them over)
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Insane_ProCommented:
Hello,

I hope my previous post was of some use!

Well, if there was anything that was not clear, please do post your comment in this thread again.

Try to have a seperate account to run exmerge as modifying default permissions on the built in groups would not be advisable as those permissions are there for a purpose and to avoid any kind of Security issues.

Thanks,
=Insane_Pro=
0
vkatonaAuthor Commented:
Hi,

Thank you for the direction. It was very clear. After I made all the changes it is still not working. I event try another account but I having the same issue.
Here is the log from ExMerge:

****************************************************************
Microsoft Exchange Mailbox Merge Program, v6.5.7408.1
Start Logging:February 23, 2005   11:48:45
****************************************************************
[11:48:45] Logging Level: Medium
[11:48:45] Reading settings from file 'C:\Program Files\ExMerge\EXMERGE.INI'.
[11:48:51] Error 8007203a opening an LDAP connection. ('LDAP://raymail:389/rootDSE')  (CADRoutines::GetNamingContextData)
[11:48:51] Default Naming Context: 'DC=Company,DC=Company,DC=COM'
[11:48:51] Accessing Domain Controller 'CompanyDC'
[11:48:51] 'mailsrv' is running Exchange Server 2000 or later
[11:48:51] Source server read from settings file is ' mailsrv'.
[11:48:51] Invalid LDAP Port number entered in INI file (''). Ignoring this setting.
[11:48:51] Reading list of subjects for messages to be selected from file ''
[11:48:51] Reading list of attachment names for messages to be selected from file ''
[11:48:51] List of folders to be ignored has been read. 0 folders in the list.
[11:48:51] Current machine locale ID is 0x409
[11:48:51] Command line received:
[11:48:51] Processor architecture: Intel
[11:48:51] Operating System Version 5.1 (Build 2600)
[11:51:13] Error 8007203a opening an LDAP connection. ('LDAP://MAILSRV/rootDSE')  (CADRoutines::GetNamingContextData)
[11:51:13] Default Naming Context: 'DC=Company,DC=Company,DC=COM'
[11:51:13] Accessing Domain Controller 'DC'
[11:51:13] 'MAILSRV' is running Exchange Server 2000 or later
[11:51:17] Mailbox '/O=Company/OU=CompanyOrg/cn=Configuration/cn=Servers/cn=MAILSRV/cn=Microsoft System Attendant' will be

ignored as its DN contains strings in the ignore list
[11:51:17] Mailbox '/O=Company/OU=CompanyOrg/cn=Configuration/cn=Connections/cn=SMTP

(MAILSRV)/cn={AF4640D2-03E3-4738-8320-8AA04E9C8304}' will be ignored as its DN contains strings in the ignore list
[11:51:17] Mailbox '/O=Company/OU=CompanyOrg/cn=Configuration/cn=Servers/cn=MAILSRV/cn=Microsoft DSA' will be ignored as its DN

contains strings in the ignore list
[11:51:17] Found 124 mailbox(es) homed on database 'FIRST STORAGE GROUP/MAILBOX STORE (MAILSRV)'.
[11:51:17] Ignored 3 mailbox(es) homed on database 'FIRST STORAGE GROUP/MAILBOX STORE (MAILSRV)'.
[11:51:17] Found 124 mailbox(es) homed on the specified databases.
[11:51:17] Ignored 3 mailbox(es) homed on the specified databases.
[11:51:17] Successfully initialized MAPI.
[11:51:17] MAPI Logon successful.
[11:51:17] Getting list of mailboxes on the server.
[11:51:17] Error opening message store (EMS). Verify that the Microsoft Exchange Information Store service is running and that

you have the correct permissions to log on. - 0x8004011d ( (CMapiSession::GetMailboxesOnServer))
[11:51:17] Error getting list of mailboxes on server 'MAILSRV'
[11:51:17] Finished getting list of mailboxes.
[11:51:17] Error encountered getting mailbox information from the private information store database(s) on server 'MAILSRV'.

Make sure you have adequate permissions on the Information Store object. Please refer to the 'C:\Program

Files\ExMerge\ExMerge.log' log file for more information.

(Please note the name are altered in the log)

It is any more things to try or troubleshoot this?

Thank you for your help.
0
_ruudsje_Commented:
Realy shure you have full access to mail box store, go there via ESM and check to see u have full allow rights plus send as and recieve as rights on the mailbox store. (as pointed above)

Or try this document: http://support.microsoft.com/default.aspx?kbid=262054

error 0x8004011d realy refers to permissions on mail boxes...
0
vkatonaAuthor Commented:
I checked and I did some changes on the membership of the Exchange Services group. I added my account this group. All deny has been removed all level, verified and switched to enable. I will check it tomorrow. I think it takes time the replication in the domain and the Exchange server caches certain things, which need to be update. Thanks for continues support and I will post my result tomorrow.

0
vkatonaAuthor Commented:
I have the same error after many try. I am running out idea to check.
0
Insane_ProCommented:
Hello,

Is the Exmerge account a part of the local Administrators group on the Exchange Server (If Exchange is a Member Server)? If it is not, then add the account to the Local Administrators group and try.

Thanks,
=Insane_Pro=

0
vkatonaAuthor Commented:
Thank you for this other suggestion. I have added the account what I am using to the local administrator group. It is also part of the domain administrator group, which was already was part of this group. Result is the same. Does not work with the same error message. MS should have some diagnostic tools for this tool. Any more suggestion?
0
drum15IT ManagerCommented:
have you got a copy of mapi32.dll in the same folder?
0
smellystudentCommented:
I've run into the same issue - it seems to be caused by mailbox sizes >2Gb. I've resorted to using Outlook on those instead.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.