?
Solved

Cannot access desktop through XP Remote Desktop

Posted on 2005-02-24
60
Medium Priority
?
10,560 Views
Last Modified: 2013-11-21
Hi,

I have a Connexant ADSL USB Modem, I have opened up the 3389 port for the P.C. (10.0.0.8)

When I try to connect to the office computer - using http://x.x.x.x./tsweb

It says

Server Error: 501 Not Implemented
________________________________________
No RPM for this combination of URL and method
________________________________________

/tsweb



Any ideas

Thanks

Ranj

0
Comment
Question by:Secureconcepts
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 22
  • 20
  • 18
60 Comments
 
LVL 32

Expert Comment

by:LucF
ID: 13391362
Hi Secureconcepts,

Have you opened Port 80 also (to be able to get to the connection page?)
Do you get a connection when you use the RDP client from:
http://www.microsoft.com/downloads/details.aspx?FamilyID=80111f21-d48d-426e-96c2-08aa2bd23a49&DisplayLang=en

Greetings,

LucF
0
 

Author Comment

by:Secureconcepts
ID: 13391443
I have opened up port 80.

But still no joy - also I am using XP Pro so the client has allready been installed
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13391493
can you telnet into port 3389?
what OS is the RDC host?
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 
LVL 32

Expert Comment

by:LucF
ID: 13391513
Btw, Server Error: 501 Not Implemented is a Mozilla error.
You can't use Mozilla or Firefox to connect with the tsweb function, you need to use IE as you need to install an ActiveX component for this to work.

Also, you are using the WAN IP address instead of the internal 10.0.0.8 addres?

LucF
0
 

Author Comment

by:Secureconcepts
ID: 13391566
When I use Internet Explorer - across the top it says http 501 not implemented

When I telnet 0.0.0.0:3389 - IT SAYS CANNOT OPEN CONNECTION ON PORT 23 - connection failed

0.0.0.0 is the WAN address

I though I need to connect throughj the WAN address

Thanks

Ranj
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13391611
here is the command and the results I get
C:\Documents and Settings\Me>telnet 0.0.0.0 3389
Connecting To 0.0.0.0 ...Could not open connection to the host, on port 3389
: Connect failed
should just get a blinking cursor

>> I have opened up the 3389 port for the P.C. (10.0.0.8)

did you forward the port to 10.0.0.8
just opening with out an ip won't work
0
 
LVL 32

Expert Comment

by:LucF
ID: 13391645
Strange but ok...
Let's forget about the ActiveX component at the moment and just try using the Remote Desktop Client. That'll make troubleshooting a bit easier.

Are there any firewalls installed anywhere? (both the winXP build-in one and any others?)
Or, maybe the computer you're using at the moment is filtered by a proxy or such?

LucF

0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13391653
again, what is the host OS?
w2k3, XP pro?
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13391665
also see here
http://www.petri.co.il/install_remote_desktp_web_connection_on_windows_xp.htm
scroll down to the related articles
0
 

Author Comment

by:Secureconcepts
ID: 13391739

I have disabled

The Host OS is XP Pro

The Laptop I am trying to connect through is also XP Pro

No firewall software is installed on either PC - I have disabled
0
 

Author Comment

by:Secureconcepts
ID: 13391758
no firewalls are set on the computer - but n the ADSL router their is a firewall page, I have seti it  to allow all incoming and outgoing connections

Menu for firewall section:

Configuration | Firewall

      Conexant Firewall Version: 3.2.1

Conexant firewall allows users to configure various databases/firewall options and Inbound/Outbound policies for controlling Inbound/Outbound traffic.

Advanced Options:
The following firewall options are configurable for advanced firewall feature:
- Protection Policy
- Hacker Log
- Service Filtering

Firewall Databases:
The following databases are configurable for setting inbound/outbound policies:
- IP Group
- Service Group
- Time Window

Inbound/Outbound Policies:
The following policies are configurable for controlling traffic:
- Inbound Policy
- Outbound Policy
0
 

Author Comment

by:Secureconcepts
ID: 13391770
For this

did you forward the port to 10.0.0.8
just opening with out an ip won't wor



I did this

Virtual Server Configuration

ID       Public Port - Start       Public Port - End       Private Port       Port Type       Host IP Address
1       8081       8081       8081       TCP       10.0.0.8       
2       8083       8083       8083       TCP       10.0.0.8       
3       8085       8085       8085       TCP       10.0.0.8       
4       8087       8087       8087       TCP       10.0.0.8       
5       3389       3389       3389       TCP       10.0.0.8       
6       3389       3389       3389       UDP       10.0.0.8       
7       80       80       80       TCP       10.0.0.8       
8       80       80       80       UDP       10.0.0.8       
9       8080       8080       8080       TCP       10.0.0.8       
                        TCP
UDP             
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13391800
OK, are you inside the LAN now? (on the same local network as the host?) If so, then you must use the local ip (10.0.0.8)
0
 

Author Comment

by:Secureconcepts
ID: 13391858
Hi

I am on the same Lan as the host,

I thought I can connect through http://0.0.0.0/tsweb as if I was on the internet anywhere


I have connected through my phone - GPRS and get the same problem.

Any more ideas

Thanks

0
 
LVL 32

Expert Comment

by:LucF
ID: 13391895
>>I thought I can connect through http://0.0.0.0/tsweb as if I was on the internet anywhere<<
I'm seeing I'm accessing the router instead of your computer.
For this implementation to work, you also have to forward port 80 to this computer.

LucF
0
 
LVL 32

Expert Comment

by:LucF
ID: 13391924
Btw, for your own security. Get rid of the remote administration function of your modem.
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13391955
Hmmmm, I can't get there at all
from that machine go to www.grc.com and run shieldsup
use the custom port 3389
0
 

Author Comment

by:Secureconcepts
ID: 13391965

When you say forward port 80 to this computer

Do you mean on the Virtual server page


forward to my Laptop (Client i am trying to connect with)

My desktop - (the host I am trying to connect to - done)

The password is defauklt at the moment - can you logon

U/N - admin

Password =  conexant

I will change details once this is working.
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13391982
I can't get there at all, but can tracert to it
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13391983
maybe Luc can get there
0
 
LVL 32

Expert Comment

by:LucF
ID: 13392019
Wierd, it worked before, now I'm getting "Page cannot be displayed" as in, you turned off the remote configuration of your modem.
But please, change the password now. These pages are indexed by google and you surely wouldn't like anyone else on your system.
(in fact, it might be best if you ask http:/Community_Support/ to remove your WAN IP from this question)

Yes, you should forward port 3389 in the "Virtual server" page to setup port forwarding for Remote Desktop
You should also forward port 80 there in case you prefer to use the web-based RD client.


LucF
0
 
LVL 32

Expert Comment

by:LucF
ID: 13392091
So, the rules posted at http:#13391770 are indeed the correct ones.
One thing I'm wondering about is that you have a USB modem?
How are you connected to it as you say you have more than one computer on the internal network... Does your modem also have a UTP connector which you can connect this computer on which you want to run RD?

LucF
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13392136
Luc, as an aside
how do you post the link like
>>So, the rules posted at http:#13391770 are indeed the correct ones
instead of the whole link?
0
 
LVL 32

Expert Comment

by:LucF
ID: 13392159
Steven,

As I'm a CV I can see comment-ID's just above the comment. Your last one just sais:
------
Comment from stevenlewis
Date: 02/24/2005 02:19PM CET
ID: 13392136
------
Then, I just add http:# in front of it and I'm done :)
Alternatively, check out no.4 in Xxavier's profile (http:M_1241389.html) to get the comment-ID

Luc
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13392293
LOL, it's beyond me, I;ll just keep posting the whole link *grin*
0
 

Author Comment

by:Secureconcepts
ID: 13394128
I have one ADSL Router (Connection from ADSL router to access point is through Ethernet Cable)

Connected to WAP54G Linksys Wireless Access point, all client devices are connected to the access point


For the desktop (10.0.0.8) - on the router page I have setup virtual server to forward to port 80 and 3389 still no joy.

Would like to get this working - any other ideas
0
 
LVL 32

Expert Comment

by:LucF
ID: 13394212
>> I have one ADSL Router (Connection from ADSL router to access point is through Ethernet Cable)<<
So if I get it right, your setup is something like:

Internet => ADSL Router => Access point => your computer (10.0.0.8)
If so, you need to setup a little different kind of port forwarding.

On the ADSL router, you'll need to forward to the Access point, and then from the Access point you'll need to forward to you computer.
This as most likely the connection from the router to the access point has a different IP-range than the connection from AP to your computer.

LucF
0
 

Author Comment

by:Secureconcepts
ID: 13397537
all ips that we pick up from AP are on the same subnet 10,0,0,x

I cannot seem to log onto the access point

Will try with network card in desktop directly connected to ADSL router tmrw

Thanks
0
 
LVL 32

Expert Comment

by:LucF
ID: 13397603
Ok, let's see then what IP you're getting from the ADSL router (most likely it's a different IP-address, in a different range)
You'll have to adjust the port-forwarding settings accordingly.

LucF
0
 

Author Comment

by:Secureconcepts
ID: 13402582
I have configured some more

ADSL Router is set to 192.168.1.1.

0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13402603
good so far, now follow Luc's instructions and forward to the AP address, and then on the AP forward to the computer
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13402607
>> forward to the AP address
meaning the WAN side of the AP
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13402640
should look something like this
internet -----<wan port>router<lan port 192.168.1.1>-------<wan port 192.168.1.2>AP<LAN port>----PC<10.0.0.8>
so on the router forward to 192.168.1.2 and then on the AP forward to 10.0.0.8
adjust to fit your ip's
0
 

Author Comment

by:Secureconcepts
ID: 13402704
Access Point is configured to 192.168.1.254

All clients get a 192.168.1.x ip address


The desktop (The host - for RDC - is connected directly to the ADSL router through standard network cable) ip is set to 192.168.1.2  - below are the virtual server settings from the ADSL router.

Virtual Server Configuration
 ID  Public Port - Start  Public Port - End  Private Port  Port Type  Host IP Address  
1 80 80 80 TCP  192.168.1.2  
2 3389 3389 3389 TCP  192.168.1.2  
3 8081 8081 8081 TCP  192.168.1.2  
4 8083 8083 8083 TCP  192.168.1.2  
5 8085 8085 8085 TCP  192.168.1.2  
6 8087 8087 8087 TCP  192.168.1.2  



Below is my WAN AND lan CONFIGURATION FOR ADSL

WAN

IP Address Subnet Mask MAC Address
x.x.x.x 255.0.0.0 <MAC removed>




--------------------------------------------------------------------------------

LAN

IP Address Subnet Mask MAC Address

192.168.1.1 255.255.255.0 00:06:4F:18:63:D5


aFTER ALL THIS i STILL GET THE SAME PROBLEM WHEN LOGGING IN USING ie

HTTP  501 NOT IMPLEMENTED

Any more ideas

Thanks
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13402723
could you draw a diagram of the physical connections (like I did above)
0
 
LVL 32

Expert Comment

by:LucF
ID: 13402788
Yes, that would make it a lot easier to figure out what's happening :)
0
 

Author Comment

by:Secureconcepts
ID: 13402799
I cannot see a diagram above -

One ADSL Router - to AP and Desktop

One AP - to two laptop clients

What do you mean physical connections


For The ADSL their is only 2 Connections - 1 is the ADSL BT Line and the other is the Ethernet cable going to the Desktop.

I am trying remote desktop directly through The desktop.

Thanks
0
 
LVL 32

Expert Comment

by:LucF
ID: 13402877
Does something like this setup look like your network?

Internet => Router (IP range?) === AP (IP range?) ==== clients

If so, may I ask why you've (according to http:#13402704) got everything on the same subnet?
Please use different ranges for the connection from the router to the AP and the AP to the clients.

That to make sure that the router knows what to route where :)

LucF



0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13402977
my thoughts exactly Luc, I think they are trying to route to the same ip range (and confusing the router, need to be different ip ranges so the router can route)
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13402998
this is the diagram I wrotre

internet -----<wan port>router<lan port 192.168.1.1>-------<wan port 192.168.1.2>AP<LAN port>----PC<10.0.0.8>
0
 

Author Comment

by:Secureconcepts
ID: 13403081

internet -----<x.x.x.x wan port>router<lan port 192.168.1.1>-------<wan port 192.168.1.245>AP<LAN port> (ADSL Handles all IP Addresses through DHCP - AP Does not need to assign.


Why would I need to

Please use different ranges for the connection from the router to the AP and the AP to the clients.


Can the adsl router not issues IP addresse through DHCP and the AP just pass through traffic

Forget the access point and concentrate on the Internet --> ADSL Router --> Desktop.

I try and connect to http://x.x.x.x/tsweb in Internet Explorer and it says HTTP  501 NOT IMPLEMENTED

Any more advice would be good.

Thanks

0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13403186
OK, if you have it setup like this (take the AP out of the mix for now)
Internet --> ADSL Router --> Desktop
and you have port 3389 and 80 forwarded to the desktop ip
then if on that desktop go to www.grc.com and run shieldsup and use the custom ports and check ports 3389 and 80
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13403241
>>ADSL Handles all IP Addresses through DHCP - AP Does not need to assign.

is the AP setup in bridge mode?
If not, then it is probably handing out ip's in the same range as the router, and there's the rub, can't route between the same network
it can not be
<wan port 192.168.1.x>AP<lan port 192.168.1.y>
it will not route if it is that way
0
 
LVL 32

Expert Comment

by:LucF
ID: 13403246
Secureconcepts,

Hold it, I don't know ATM what you changed, but Remote desktop IS working!

LucF
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13403267
Ah, they must be trying it from insode the LAN, and the router doesn't support lan loopback
0
 
LVL 41

Assisted Solution

by:stevenlewis
stevenlewis earned 1000 total points
ID: 13403283
Yep, RDC is working, but the tsweb is not (at least from my end
0
 
LVL 32

Accepted Solution

by:
LucF earned 1000 total points
ID: 13403292
Port 80 probably still isn't forwarded.

LucF
0
 
LVL 32

Expert Comment

by:LucF
ID: 13408200
Glad to help, but for what I see the ActiveX client still isn't working. So, do you still need help with getting that to run?

LucF
0
 

Author Comment

by:Secureconcepts
ID: 13409568
I do if possible - I have forwarded the correct port - but I cannot login through web page

Thanks
0
 
LVL 32

Expert Comment

by:LucF
ID: 13409660
Ok, did you setup IIS on XP allready?
Also, did you allready install the Web connection software?
http://www.microsoft.com/windowsxp/downloads/tools/rdwebconn.mspx

LucF
0
 

Author Comment

by:Secureconcepts
ID: 13410659
i have installed everything for IIS on the desktop

I have the web connection software now installed

But know I cannot connect to remote desktop anymore

From within the LAN like I was doing yesterday - any ideas - can you still connect to remote desktop

I have got this working on Broadband before very easily - now we have ADSL, we have a fixed IP and new Conexant router - that I have never used (Usually use Linksys no problem)

Any more help would be good

Thanks

0
 
LVL 32

Expert Comment

by:LucF
ID: 13410890
At this moment both the ActiveX client and Remote desktop client works without any problems for me.

So, from my end all looks perfectly fine :)

LucF
0
 

Author Comment

by:Secureconcepts
ID: 13418542
Remote desktop now works, but I cannot use TSWEB function.

I have opened up certain ports - but when I try to connect it says the connection was refused.

Also I cannot log onto the firewall feature any more.

Thanks

Ranj.
0
 
LVL 32

Expert Comment

by:LucF
ID: 13418573
The tsweb function works for me, what server-IP are you using?
You should also use the WAN IP there.

LucF
0
 

Author Comment

by:Secureconcepts
ID: 13419443
Sorry iit does work if we are not connected through the LAN - from home I can connect - Thanks.

Any ideas why the ports are blocked -

 I am going to try and get another ADSL router - any suggestions
0
 
LVL 32

Expert Comment

by:LucF
ID: 13419467
>>iit does work if we are not connected through the LAN <<
What lan? You mean the internal network?
If so, try filling in the LAN IP in the box at that time.

Same for the web address, try http://<internal IP>/tsweb/default.htm

It all depends on which side of the router you're accessing.

LucF
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13419538
a lot of routers don't support LAN loopback (going from the inside to the outside and back in again)
0
 

Author Comment

by:Secureconcepts
ID: 13420257
Hi

 >>iit does work if we are not connected through the LAN <<
What lan? You mean the internal network? = Yes

Thankyou - below now works

http://<internal IP>/tsweb/default.htm



If I am on the internal network I can log onto a camera at 192.168.1.3:80:80

But when I log on from the WAN side internally or at home 84.xx.xx.xx:8080 it says connection was refused


0
 
LVL 32

Expert Comment

by:LucF
ID: 13420315
>>But when I log on from the WAN side internally or at home 84.xx.xx.xx:8080 it says connection was refused<<
Yes, that's like Steven said at http:#13419538 the problem with loads of routers, only a few will support LAN loopback.
Nothing you can do about this except for getting yourself another router, but I think that's not the way to go for just this minor annoyance.
But now I'm at a loss... I can't reach the tsweb page anymore, did you move it to a different port or such?

LucF
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13420469
:80:80
is not :8080
it is also not port 80
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When it comes to security, there are always trade-offs between security and convenience/ease of administration. This article examines some of the main pros and cons of using key authentication vs password authentication for hosting an SFTP server.
Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question