Link to home
Create AccountLog in
Avatar of Grass-hopper
Grass-hopper

asked on

Solaris 10 Java Desktop System - Keyboard not working

Hi,

I Installed Solaris 10 on a Sun Fire v240 to have a play about with it.

On connecting to the Java desktop System using Exceeds Hummingbird everything works fine using the pointy clicky method. However as soon as I go to type in any text anywhere the cursor just blinks on the spot each time you hit a key - with no ouput at all.

When I log on using the CDE however - all normality is resumed, so I presume this is a JDS problem??

I am using the Beta release as far as I know (5.10 s10_72) but I noticed on the Sun Support forums there are people with the same problems even though they have the latest release.

Any Ideas??

Cheers.
Avatar of wesly_chen
wesly_chen
Flag of United States of America image

Hi,

   Solaris 10 is officially released. You might want to try the offical version.

   Besides, you might want to contact Hummingbird technical support for some information since you use Exceed (v10 ?).

Regards,

Wesly
Avatar of yuzh
yuzh

You can get the official releases from:
    http://www.sun.com/software/solaris/binaries_program.xml
Avatar of Grass-hopper

ASKER

I plan to try the latest release (just waiting on it to download), but as I said, there are people with the latest official release who are also experiencing the problem so I can't see it being the solution. You never know but!

Cheers.
OK,

Installed latest release (03/05) - still getting same problem. Spoke to Exceed support, they acknowledged it as a bug which there R&D department are working with Sun to fix. Apparently, It is also happening with cygwin and VNC users as well. Will keep thread open for archive puposes and post fix/link to patch when it is released.

I noticed this in Solaris 10 beta - build 72, but interestingly it didn't happen in build 69, all worked fine.
I have also logged it as a bug in the Solaris express program. It doesn't seem to happen if you have a Sun keyboard and monitor locally (i.e. as the console), only when you connect with products like Exceed etc remotely.

John
ASKER CERTIFIED SOLUTION
Avatar of Grass-hopper
Grass-hopper

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
sorry - path should read:

$HOME/.gconf/apps/gnome_settings_daemon/keybindings/%gconf.xml
Hi Grass-hoper,

   From your solution, you are using Gnome, not CDE (original post). That will delude the people here to the wrong direction.

   Anyway, glad to hear your problem resolved.

Wesly
yuzh - please PAQ and refund - cheers.

Wesley:

I thought I had explained it pretty well...........

I definately logged in through CDE. Everything works as normal (the way CDE normally does). The problem with the keyboard not functioning does NOT occur when choosing CDE session from login only when i chose Java desktop session. I take it gnome must be tied in with the JDS but if editing that solves the keyboard problem in JDS???

(Although little note here) although it solves the problem initially - when someone else then logs in as the same account from a different exceed session using JDS, they then get some wnck-gnome error - but the keyboard still works!!!

Strange!!!

Cheers.
Hi again
I have had an email back from Sun about this problem.
The workaround given by Sun is to do the following:
Log in so you can use the terminal (say by using CDE)
Run gconf-editor
Remove the key bindings. In a standard setup after installation, I only had to remove mappings for
the following key entries:
Help
Volume_down
Volume_mute
Volume_up

Quit and logout.
Then login remotely using whatever remote X server you are using (Exceed, KEA!X etc) and
select JDS to use gnome.
Terminal should now work OK.

I tried this with 3 different user accounts and after applying this, it worked on all 3.
Sun also said that a proper fix is in progress (will put a patch out I guess).

Good luck

John