?
Solved

Unable to send mail with attachments larger than 2 Mb

Posted on 2005-02-24
6
Medium Priority
?
2,139 Views
Last Modified: 2008-02-01
I am running SBS 2003 with Exchange Server 2003 built-in. I have read the MS KB article at http://support.microsoft.com/kb/322679 and so I have checked every possible place in Exchange where a mail size limit can be set and I have no limits anywhere. I am sending mail to an external test account which has a statuatory mail limit of 3.5 Mb. I have just checked with my business broadband provider and they have a mail limit of 50 Mb so as far as I can see there should be no problems.

The test attachment I am sending is a 2.5 Mb Autocad drawing file and when sending it I receive the standard delivery failure notification message

This message is larger than the current system limit or the recipient's mailbox is full.  Create a shorter message body or remove attachments and try sending it again.
            <#5.2.3 smtp;450 5.2.3 Msg Size greater than allowed by Remote Host>

If I send a message with a 1.9 Mb attachment it goes no problem and when I look at the external mail account it shows the total size of the message as 2665K.

Any ideas? Is there a hidden limit on attachment sizes somewhere? I have a firewall but as far as I can see it is not set to block attachments of any kind or size.

Rob
0
Comment
Question by:robspot
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 9

Expert Comment

by:jjoseph_x
ID: 13393339
I think that the key is "allowed by REMOTE host".   The problem is the receiving mail server, which means that nothing that you configure on your will change that.

When a binary attachment is encoded into a UUencode or, more commonly, base64 mime format it grows in size due to the overhead of the encoding (because you're taking a binary file and sending it in a 7-bit text format).  So your 2.5MB autocard drawing might well end-up growing to more than 3.5MB when it's base64 encoded.

Autocard drawings are pretty compressible though, so you could just zip it and send it.
0
 

Author Comment

by:robspot
ID: 13393945
I've tried sending it as a zip file of 2.28 Mb but it still won't go. Does that file size increase as well?

I know that the remote host bit indicates that it's a problem at the receivers end but the reason this came about is because one of my workers is having trouble sending drawings to someone (in another company) who swears that there are no mail restrictions at their end. It does seem that they may be fibbing doesn't it.
0
 
LVL 9

Accepted Solution

by:
jjoseph_x earned 2000 total points
ID: 13397772
Any binary (including zips) that you send will increase in size (though I couldn't say by how much... it depends on the file).  And yeah, since the message is coming from their server they are definately limited the attachment size in either their 'mail' mail server or on their SMTP gateway (if any).

One possible solution would be to break the file into multiple, smaller parts.   Usually I use rar for that and I'd set the max size of each part to something like 1mb.

0
Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Comment

by:robspot
ID: 13427457
Thanks for your help but that wasn't the answer.

It turns out that the delivery failure message was coming from MY server and was being generated because the mail was blocked by my firewall. There was a 3 Mb limit on the incoming SMTP proxy which for some reason was limiting the size of outgoing message. I increased the limit to 10 Mb and now the mail goes no problem.
0
 

Expert Comment

by:ahrimann
ID: 15015831
pardon me for beating this dead horse, but robspot did you find the 3mb limit in your front-end exchange server? or are you running a different proxy? and also, was the firewall a separate firewall, or part of the proxy? i am having the identical problem.

thanx
0
 

Author Comment

by:robspot
ID: 15019835
Hi ahrimann

I have a Watchguard hardware firewall and it was on the SMTP proxy setting for this unit that the 3MB limit appeared. There are limits set in various places on Exchange but nonoe of these were set restrictively on my server. If you haven't already you might want to check the following locations

Open Exchange system manager and go to the connectors folder. right-click SMTP connector and go to properties. See if the allowed sizes box is checked.

Still in exchange system manager go to the Global Settings folder and right-click Message Delivery and go to properties. Click the default tab and check the incoming and outgoing sizes.

Apart from that I'm afraid I can't help you any further. Good luck.
0

Featured Post

Want to be a Web Developer? Get Certified Today!

Enroll in the Certified Web Development Professional course package to learn HTML, Javascript, and PHP. Build a solid foundation to work toward your dream job!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
There are times when we need to generate a report on the inbox rules, where users have set up forwarding externally in their mailbox. In this article, I will be sharing a script I wrote to generate the report in CSV format.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
Suggested Courses

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question