?
Solved

Cannot telnet to new FreeBSD install as root

Posted on 2005-02-24
4
Medium Priority
?
2,293 Views
Last Modified: 2013-11-22
I have a new install of FreeBSD. I can telnet into it as a user but not as root. I get a "login incorrect" message. I can log in locally using the same id/password fine. Obviously I am new to FreeBSD and this is probably very simple. Thanks in advance for your help.
0
Comment
Question by:dnagmour
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 9

Expert Comment

by:David Piniella
ID: 13395624
freebsd doesn't allow telnet as root in by default, which is generally a good idea. I would suggest you SSH in if at all possible. Verify that root can ssh in by checking your sshd.conf (should have a line that says something like "allow root logins = YES")
0
 
LVL 9

Accepted Solution

by:
David Piniella earned 2000 total points
ID: 13395710
to expand on the previous: it's a security feature; since telnet is cleartext, your password can be sniffed. no root logins on telnet means that someone would have to get two passwords; a regular user and then the root password. if you MUST use telnet, telnet as the regular user and then su to root. if you want to login directly as root, use ssh and make sure you configure sshd to allow root logins.
0
 
LVL 9

Expert Comment

by:David Piniella
ID: 13395738
oh, the ssh file you have to change is /etc/ssh/sshd_config

you need to change the line that says
#PermitRootLogin no
to
PermitRootLogin yes

and then restart sshd (note that if you do this over the network while you're ssh'd in, you'll kill your connection :) )
0
 

Author Comment

by:dnagmour
ID: 13396333
Thanks for your help. I had tried earlier to su to root but was unsuccessful because I was not a member of the wheel group. Thanks again.
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello fellow BSD lovers, I've created a patch process for patching openjdk6 for BSD (FreeBSD specifically), although I tried to keep all BSD versions in mind when creating my patch. Welcome to OpenJDK6 on BSD First let me start with a little …
Let's say you need to move the data of a file system from one partition to another. This generally involves dismounting the file system, backing it up to tapes, and restoring it to a new partition. You may also copy the file system from one place to…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question