• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 426
  • Last Modified:

subinacl.exe will not update registry permission settings

We are using SMS 2003 and many of our systems are blocking the client install.  This is due to them being upgraded from W2k to windows XP Professional.  This causes the machines to be missing permissions on key:

HKLM\system\currentcontrolset\control\securepipeservers\winreg

The permission that needs to be applied is "local service"

We created a batch file that has this entry:

\\medusa\agashared\BatchF~1\Registry\subinacl /keyreg /klm\system\currentcontrolset\control\securepipeservers\winreg /grant="local service"=r

The batch runs but says that nothing has been modified, no syntax errors and nothing has failed.

Checking the registry reveals no change to the key.  We have too many computers to manually modify the registry so this batch is imperative.  Please guide us on a way to do this that will complete this procedure.  Thank you.
0
gbisker
Asked:
gbisker
1 Solution
 
oBdACommented:
Duplicate question, see here: http:Q_21328149.html
You might want to post in Community Support for a refund of your points and deletion of this question; one per TA should be enough ...
0

Featured Post

[Webinar] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now