subinacl.exe not working on registry

We are using SMS 2003 and many of our systems are blocking the client install.  This is due to them being upgraded from W2k to windows XP Professional.  This causes the machines to be missing permissions on key:


The permission that needs to be applied is "local service"

We created a batch file that has this entry:

\\medusa\agashared\BatchF~1\Registry\subinacl /keyreg /klm\system\currentcontrolset\control\securepipeservers\winreg /grant="local service"=r

The batch runs but says that nothing has been modified, no syntax errors and nothing has failed.

Checking the registry reveals no change to the key.  We have too many computers to manually modify the registry so this batch is imperative.  Please guide us on a way to do this that will complete this procedure.  Thank you.
Who is Participating?
oBdAConnect With a Mentor Commented:
If the line was a copy and paste, your error is a typo; make the /keyreg argument HKEY_LOCAL_MACHINE instead of /klm
\\medusa\agashared\BatchF~1\Registry\subinacl /keyreg /klm\system\currentcontrolset\control\securepipeservers\winreg /grant="local service"=r

If you're using the subinacl version from the Server 2003 Resource Kit Tools, that's buggy; an updated version is here:
SubInACL (SubInACL.exe)
Asta CuCommented:
More than one language involved?
Asta CuCommented:
Hit submit too soon, this is why I asked ... google result
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.