• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1110
  • Last Modified:

Sound card installs and configures, but no sound plays! Help!

I got my sound card to install just fine using alsaconf, but I have no sound. When I try to open the volume control in X11, it says there are no valid mixing devices installed.

I get this error on boot:

ALSA Mixer Error
/usr/sbin/alsactl restore
/usr/sbin/alsactl: set_control:1025: bad control.3.value type

Any thoughts?

I have another unusual occurance, too...

When trying to play an MP3 in X11, (using any sound app), it acts as if it's playing, but it always pretends to play the first 15 seconds of the song, and then stops.  Sometimes it starts over from the beginning, and resets at 15seconds again.  It's always at exactly 15 seconds, too. There is still no sound heard whatsoever.

I'm running KDE on Slackware 10.1, with Linux 2.6.9.

I'd appreciate any insight!!  



Here's the some information that may or may not be relevant...

cat /proc/pci
(only the sound card information pasted)
Bus 0, device 10, function 0:
Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 7).
IRQ 18.
Master Capable. Latency=32. Min Gnt=12.Max Lat=128.
I/O at 0xd400 [0xd43f].


cat /etc/modprobe.conf
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.8 ---
alias snd-card-0 snd-ens1371
alias sound-slot-0 snd-ens1371
# --- END: Generated by ALSACONF, do not edit. ---


cat /proc/modules
snd_pcm_oss 48072 - - Live 0xce90c000
snd_mixer_oss 17288 - - Live 0xce8dd000
natsemi 25152 - - Live 0xce8d5000
snd_ens1371 18696 - - Live 0xce8b2000
snd_rawmidi 19908 - - Live 0xce891000
snd_seq_device 6192 - - Live 0xce88e000
snd_pcm 84100 - - Live 0xce8e6000
snd_timer 20652 - - Live 0xce8a4000
snd_page_alloc 7312 - - Live 0xce88b000
snd_ac97_codec 68912 - - Live 0xce8ba000
snd 46276 - - Live 0xce897000


ls -L -l /dev/dsp*
crw-rw--w- 1 root audio 14, 3 2005-02-24 00:17 /dev/dsp  
0
magitek
Asked:
magitek
  • 7
  • 5
1 Solution
 
sjohnstone1234Commented:
Not sure but one obvious thought: are you either logged in as root, or a user that's in group audio?
0
 
magitekAuthor Commented:
I don't recall if I've tried it logged in as root or not... but my user account for myself is in the group "users" I believe, and I know I've tried it logged in as me.  Is this incorrect?
0
 
sjohnstone1234Commented:
I was going to say yes but then noticed /dev/dsp was world writable anyway, so that shouldn't stop you from playing audio...

Can you try:

ls -l /dev/mixer*

just to make sure all the OSS mixer devices are accessible too? ALSA problems are often caused by mixer settings, which are all set to zero by default (although I doubt this is causing the 15 second problem).

To find out what groups you are in, try:

id

On debian (and I'm assuming Slackware from what you've posted, although I've not used it in a few years) all the audio devices are accessible by root and users in the audio group, so it might be worth adding yourself to that just to see if it makes a difference (login as root, edit /etc/group, find the line that starts with "audio", the field after last the colon should be a comma separated list of users in that group - so for instance mine is audio:x:29:phunf - obviously your group ID number might be different and username won't be "phunf"). You might need to log out and back in again before you appear in the group.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
magitekAuthor Commented:
root@magiteck:/home/jared# ls -l /dev/mixer*
lrwxrwxrwx  1 root root 11 2005-02-24 00:17 /dev/mixer -> sound/mixer
0
 
magitekAuthor Commented:
Alsa, edited the group file so that it now shows:
audio::17:jared

Is this accurate, even though it does not have the small x in between :: like yours posted above?  Nothing in my group file had an x like that, so I left it out...
0
 
sjohnstone1234Commented:
The x doesn't matter, it's supposed to be a password field so users can join the group if they specify the password. If it contains "x" then users can't join the group (they have to be added by root); if it is blank like yours then users could join the audio group temporarily using the "newgrp" utility.

Ok your /dev/mixer is just a link, can you type the following and see what happens:

ls -l /dev/sound/mixer*
0
 
magitekAuthor Commented:
jared@magiteck:~$ ls -l /dev/sound/mixer*
crw-rw--w-  1 root audio 14, 0 2005-02-24 00:17 /dev/sound/mixer
0
 
sjohnstone1234Commented:
This is a strange one alright...

I assume you still can't access the mixer, and audio files reset after 15 seconds?

If the file exists, does your card appear in: cat /proc/asound/cards

and are there any other cards in there?
0
 
magitekAuthor Commented:
cat /proc/asound/cards
0 [AudioPCI       ]: ENS1371 - Ensoniq AudioPCI
                     Ensoniq AudioPCI ENS1371 at 0xd400, irq 18

That's the right card...and the only one at that.

Do you have any clue as to the error on boot, the:

ALSA Mixer Error
/usr/sbin/alsactl restore
/usr/sbin/alsactl: set_control:1025: bad control.3.value type

??
And I agree...this is definately bizarre and somewhat frustrating!
0
 
sjohnstone1234Commented:
control.3.value refers to an entry in the alsactl configuration file - to find that, run "alsactl --help" as root.

'alsactl restore' just loads the settings from the aforementioned config file into ALSA, this is stuff like mixer settings and so on. I suppose you could try creating the file from scratch - rename it (just in case something breaks, so you can put it back) then run "alsactl store" as root.

Apart from that, not sure I can be of much more help I'm afraid...
0
 
magitekAuthor Commented:
Alright,

I solved the "No sound" problem.  It actually turned out to be a defective sound card, by my best estimation!  I put the card in a working Windows machine, and I had similar problems with it... it made no sound whatsoever, although it was detected find by Windows.  Go figure!

I played around more with the onboard sound card, and managed to get that one working with ALSA - so that solves the hardware problem!

More on the "15 second" problem, though...

It seems now to be localized to MP3 Files.

I can play audio CD's fine, and WAV files fine... but when I attempt to play an MP3, it pretends to play for 15 seconds, then starts over, never making any sound.  Know of anything special I have to do in Slackware to enable MP3 support?  I know with RH there's something that has to be added, but I haven't heard of any such thing with Slackware.  Any thoughts?  I'm glad to have some sound though!
0
 
magitekAuthor Commented:
Nevermind the 15-second mp3 problem!

Silly me, I only tried playing one mp3 file, and it was simply a bad file.

All problems solved.

sjohnstone1234, thanks for all the help!  Had it not been a hardware problem, I'm sure your solutions would have worked :)  Thanks again!
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now