?
Solved

Serv U FTP server not working

Posted on 2005-02-25
21
Medium Priority
?
2,441 Views
Last Modified: 2008-01-09
I'm running an FTP server on my XP Pro, SP2 box.  It's been running fine for years but stopped accepting connections recently.  The two things that changed were:

1. I installed XP SP2
2. I installed NAV 2005

I dont have SP2's FW enabled so that should eliminate SP2.
I've disabled NAV services and even uninstalled NAV 2005 completely but FTP still doesn't work.

I have a Linksys router acting as a FW and it allows port 21 through to my PC's internal IP.
When someone tries to connect, it doesn't seem to make it to the FTP software - the FTP server never shows anyone having attempted to connect so I suspect some software is blocking the activity.

I am able to FTP to the server using another PC within my network and from the FTP PC itself so FTP server software seems to be running ok.

I also ran Spyware to clean up & a/v scans.  I am current on all Windows patches/hot fixes.

I've also installed Cerulean(?) FTP server software to test it...same results.

Any ideas?

Thanks!
0
Comment
Question by:drodey
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 5
  • 5
21 Comments
 
LVL 41

Accepted Solution

by:
stevenlewis earned 375 total points
ID: 13404551
Well, if you can reach the ftp server from inside the LAN, that would appear to eliminate the software firewalls
from the server machine go to www.grc.com and run shieldsup and check your ports
also make sure the linksys is forwarding port 21 to the correct ip
and you may  want to reset the router
0
 

Author Comment

by:drodey
ID: 13404606
I will try your test tonight.  
I've reset the router many times. I also opened extra ports (20-21 and 2000-2010 for passive FTP).

One thing I didn't try is testing w/o the Linksys completely... I will try that as well.
0
 
LVL 12

Assisted Solution

by:kneH
kneH earned 375 total points
ID: 13418082
Open the dosprompt.
Type this
net start serv-u

what error do you get?

Also get fport
http://freedom.dicea.unifi.it/ftp/pub/nt/fport.exe

Is something already running on port 21?
0
Does Your Cloud Backup Use Blockchain Technology?

Blockchain technology has already revolutionized finance thanks to Bitcoin. Now it's disrupting other areas, including the realm of data protection. Learn how blockchain is now being used to authenticate backup files and keep them safe from hackers.

 

Author Comment

by:drodey
ID: 13419749
Problem resolved but not sure how/why.  Here's what I did.

Removed linksys and connected my PC directly to the cable modem.  I got a new IP address and adjusted the FTP server config accordingly.  FTP then worked.  This confirmed at least that my PC wasn't blocking it (via NAV or some other software firewall).

Then, I reconnected my Linksys into the picture.  Rebooted everything.  Got my original IP re-assigned by ISP.  Adjusted my FTP server back to previous IP configuration.  FTP continues to work now.

I only have port 21 forwarding on my Linksys (I previously had 20-21 and 2000-2010 open for passive).

I have even changed my FTP server config to use a different port, adjust Linksys config and FTP still works.  That's where I've left it...working and a little more secure.

So...somethinig in there resolved the problem.

Thanks for all your comments.  I'll split the points.
0
 
LVL 12

Expert Comment

by:kneH
ID: 13419835
Well keep in mind serv-u uses more ports than just the one for filesharing.

Fport will point this out.
port 5555 (if I remember correctly) and some port in in the range of 40000.
0
 

Author Comment

by:drodey
ID: 13419915
BTW, I dont get any error starting Serv-U.  It's always running (launches at startup).
I've unchecked the passive FTP support so that would eliminate ports 2000-2010.
Not sure if port 20 is required but FTP functionality (get & put) is working fine with just 21.
I will run Fport tonight just to double-check.
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13420109
Thanks, glad  you got it working :-)
0
 

Author Comment

by:drodey
ID: 13425129
Unfortunately, the FTP STOPPED working totally on it's own.

FPort reports the following (6999 was the port for the FTP):

2336  SERVUD~1       ->  2000  TCP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  2001  TCP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  2002  TCP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  2003  TCP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  2004  TCP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  2005  TCP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  2006  TCP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  2007  TCP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  2008  TCP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  2009  TCP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  2010  TCP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  6999  TCP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  43958 TCP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
472   ServUAdmin     ->  2173  TCP   C:\Program Files\Serv-U\ServUAdmin.exe
2336  SERVUD~1       ->  1026  UDP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  1038  UDP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  1039  UDP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  1060  UDP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  1061  UDP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  1078  UDP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  1371  UDP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  1381  UDP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  1397  UDP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  1595  UDP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE
2336  SERVUD~1       ->  4500  UDP   C:\PROGRA~1\Serv-U\SERVUD~1.EXE

I switched back to port 21 only and it's working again.  Not sure what's up...

0
 
LVL 12

Expert Comment

by:kneH
ID: 13427093
Well if it's always running it should give the error "the service already started"
when you do net start serv-u

Also port 43958 is the one I meant. Required too.
And apparently port 5555 has changed with newer versions to 4500.
Try to open those.

And could you have someone connect to it from outside.
What error do you get?
Connection refused?
And if you connect with telnet or netcat?
0
 

Author Comment

by:drodey
ID: 13435138
Yes, it gives the "the service already started" when running net start serv-u.

Allowing ports 43958, 4500 and 20 on top of the custom port (6999) doesn't work.  It produces a LIST error from the FTP client:


220 Serv-U FTP Server v5.0 for WinSock ready...
USER xxx
331 User name okay, need password.
PASS (hidden)
230 User logged in, proceed.
SYST
215 UNIX Type: L8
PWD
257 "/" is current directory.
TYPE A
200 Type set to A.
PORT 192,168,2,50,4,24
200 PORT Command successful.
LIST
150 Opening ASCII mode data connection for /bin/ls.
426 Data connection closed, transfer aborted.
List Error
QUIT
221 Goodbye!


Telnetting using port 6999 results in this line:

220 Serv-U FTP Server v5.0 for WinSock ready...

Switching everything back to port 21 goes back to working normally.  Now, even Serv-U's tech support told me to only open port 20...but that failed as well.

0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13435188
why do you have so many ports listening?
what are you trying to do here?
see here for passove vs active ftp
http://slacksite.com/other/ftp.html

0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13435195
BTW, I use serve-u, and have only opened port 21, and told serve-u to allow passive, and have no problems
0
 

Author Comment

by:drodey
ID: 13435233
Serv-U is configured to only use port 21. I have no idea why FPort is reporting all those other ports open.  Linksys is only allowing port 21 in.  This scenario works.

It's when I change Serv-U to use another port (such as 6999) that everything breaks down.  That's what I'm trying to get working.
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13435347
on this machine with serve-u running, go to a prompt and type
netstat -an
post here please
0
 

Author Comment

by:drodey
ID: 13436033
Active Connections

  Proto  Local Address          Foreign Address        State
  TCP    0.0.0.0:135            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:445            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2000           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2001           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2002           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2003           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2004           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2005           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2006           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2007           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2008           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2009           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2010           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING
  TCP    127.0.0.1:1025         0.0.0.0:0              LISTENING
  TCP    127.0.0.1:1025         127.0.0.1:4025         TIME_WAIT
  TCP    127.0.0.1:1025         127.0.0.1:4027         TIME_WAIT
  TCP    127.0.0.1:1025         127.0.0.1:4029         TIME_WAIT
  TCP    127.0.0.1:1025         127.0.0.1:4031         TIME_WAIT
  TCP    127.0.0.1:1025         127.0.0.1:4033         TIME_WAIT
  TCP    127.0.0.1:1076         0.0.0.0:0              LISTENING
  TCP    127.0.0.1:3141         127.0.0.1:43958        ESTABLISHED
  TCP    127.0.0.1:4023         127.0.0.1:1025         TIME_WAIT
  TCP    127.0.0.1:4664         0.0.0.0:0              LISTENING
  TCP    127.0.0.1:43958        0.0.0.0:0              LISTENING
  TCP    127.0.0.1:43958        127.0.0.1:3141         ESTABLISHED
  TCP    192.168.3.250:21       0.0.0.0:0              LISTENING
  TCP    192.168.3.250:139      0.0.0.0:0              LISTENING
  TCP    192.168.3.250:1033     216.155.193.137:5050   ESTABLISHED
  TCP    192.168.3.250:1592     205.188.1.240:5190     ESTABLISHED
  TCP    192.168.3.250:1597     205.188.248.144:5190   ESTABLISHED
  TCP    192.168.3.250:2673     207.46.107.101:1863    ESTABLISHED
  TCP    192.168.3.250:4024     207.172.4.95:110       TIME_WAIT
  TCP    192.168.3.250:4028     66.78.27.17:110        TIME_WAIT
  TCP    192.168.3.250:4030     66.78.27.12:110        TIME_WAIT
  TCP    192.168.3.250:4032     207.172.4.95:110       TIME_WAIT
  TCP    192.168.3.250:4034     207.172.4.95:110       TIME_WAIT
  TCP    192.168.3.250:4042     69.9.175.159:80        CLOSE_WAIT
  UDP    0.0.0.0:445            *:*
  UDP    0.0.0.0:500            *:*
  UDP    0.0.0.0:1026           *:*
  UDP    0.0.0.0:1381           *:*
  UDP    0.0.0.0:1397           *:*
  UDP    0.0.0.0:4500           *:*
  UDP    127.0.0.1:1038         *:*
  UDP    127.0.0.1:1039         *:*
  UDP    127.0.0.1:1078         *:*
  UDP    127.0.0.1:1371         *:*
  UDP    127.0.0.1:1595         *:*
  UDP    127.0.0.1:1596         *:*
  UDP    127.0.0.1:1603         *:*
  UDP    127.0.0.1:1604         *:*
  UDP    127.0.0.1:1817         *:*
  UDP    127.0.0.1:1900         *:*
  UDP    127.0.0.1:2676         *:*
  UDP    127.0.0.1:2677         *:*
  UDP    127.0.0.1:3851         *:*
  UDP    192.168.3.250:137      *:*
  UDP    192.168.3.250:138      *:*
  UDP    192.168.3.250:1900     *:*
0
 
LVL 12

Expert Comment

by:kneH
ID: 13436874
>>>150 Opening ASCII mode data connection for /bin/ls.
>>>426 Data connection closed, transfer aborted.
>>>List Error

That's not not connecting... that's not retrieving the list.
Have you disabled passive mode?
And try the "bypass proxy" option on your ftp client too.

0
 

Author Comment

by:drodey
ID: 13439295
Yup.  Passive mode is disabled.  Bypass proxy is checked on client as they have no proxy.
0
 

Author Comment

by:drodey
ID: 13439687
FYI, Tech Support's suggestion:

Since all connections will need a data port you will need to add this when changing to a different port. For example, if you want to use port 2999 than 2998 must be open also if you want to use 6999 than 6998 must be open.

I'll try tonight.
0
 

Author Comment

by:drodey
ID: 13446595
Of course, Tech Support's suggestion did NOT work.  I even opened ports 10 - 40,000 briefly to test and still got the same LIST ERROR!   So weird I have to laugh...  :)

If nothing else, I'll remain on good old port 21.
0
 
LVL 12

Expert Comment

by:kneH
ID: 13447234
There you have it then.

It's not the router causing the probs
As you have proven above the server does function correctly
>>220 Serv-U FTP Server v5.0 for WinSock ready...

So basically it's just the listing function being a POS.
Could you have a go at transferring a file by command line to test if the ftp actually will work (not the listing just transferring).

Also that big list fport spat out is new to me btw. I always seen 3 or 4 entries made by servu. 1 or 2 for the connection, and the 4500 and the 43958. Maybe you could tell them techsupport blokes that... (if you still want to try them)
0
 

Author Comment

by:drodey
ID: 13456231
OK. Finally, I got it to work by but only after enabling PASSIVE MODE.  
I had to define a range of 10 ports for passive mode + the FTP port + data port (decrement FTP port by one).  I opened all these ports on Linksys and voila!
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Let’s list some of the technologies that enable smooth teleworking. 
This month, Experts Exchange’s free Course of the Month is focused on CompTIA IT Fundamentals.
This video will demonstrate how to find the puppet warp tool from the edit menu and where to put the points to edit.
Using Adobe Premiere Pro, the viewer will learn how to set up a sequence with proper settings, importing pictures, rendering, and exporting the finished product.
Suggested Courses

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question