?
Solved

I really need a "dumb country boy" explanation of how I can enable remote access via PCAnywhere via PIX 501.

Posted on 2005-02-25
5
Medium Priority
?
256 Views
Last Modified: 2010-04-08
Don't ask me how, but I've got 2 tunnels created between my main office and two remote sites and it's working great. I need to give one of our software vendors some temporary access via PCAW so they can do some maintenance and then I'll

I'm in management so I'm not very smart, and my experience with the PIX has been through the GUI, not the command line, so other answers with command line settings make me nervous.

I'm hoping someone can provide me simple instructions to get this setup. If the easiest way is command line then I can find the command line interface via the GUI but that's about it. Please don't assume I can do any more without specific instructions. For what it's worth, I take instructions pretty good (at least according to my wife).

Since this seems to help you folks smart enough to understand it, here's the printout from the PIX. (BTW, since we live in the rural midwest, I can't find any local CISCO folks to help or I would have done that already.)

Building configuration...
: Saved
:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ******* encrypted
passwd *********encrypted
hostname pixfirewall
domain-name reliable
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.3.0 Kirksville
name 172.16.92.0 Kir
name 192.168.4.0 Iowa
name 192.168.1.10 GenoLatitude
access-list outside_access_in remark rdp access through firewall
access-list outside_access_in permit tcp any host *.*.*.* eq 3389
access-list outside_access_in permit icmp any any
access-list temp1_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 any
access-list temp1_splitTunnelAcl permit ip Kirksville 255.255.255.0 any
access-list inside_outbound_nat0_acl permit ip any 192.168.2.0 255.255.255.0
access-list inside_outbound_nat0_acl permit ip any Kirksville 255.255.255.0
access-list inside_outbound_nat0_acl permit ip any Iowa 255.255.255.0
access-list outside_cryptomap_dyn_30 permit ip any 192.168.2.0 255.255.255.0
access-list outside_cryptomap_20 permit ip any Kirksville 255.255.255.0
access-list outside_cryptomap_21 remark iowa
access-list outside_cryptomap_21 permit ip any Iowa 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ClientVPNPool 192.168.2.2-192.168.2.150 mask 255.255.255.0
pdm location GenoLatitude 255.255.255.255 inside
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.0.0 255.255.0.0 inside
pdm location 192.168.2.0 255.255.255.0 outside
pdm location Kirksville 255.255.255.0 outside
pdm location Kirksville 255.255.255.0 inside
pdm location 192.168.1.0 255.255.255.0 outside
pdm location Kir 255.255.255.0 outside
pdm location 192.168.2.192 255.255.255.192 outside
pdm location 192.168.2.0 255.255.255.0 inside
pdm location Iowa 255.255.255.0 outside
pdm location Iowa 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) *.*.*.* GenoLatitude netmask 255.255.255.255 0 0
static (inside,outside) Kirksville Kirksville netmask 255.255.255.0 0 0
static (inside,outside) Iowa Iowa netmask 255.255.255.0 0 0
access-group outside_access_in in interface outside
rip outside passive version 1
rip inside passive version 1
route outside Kirksville 255.255.255.0 *.*.*.* 1
route outside Iowa 255.255.255.0 *.*.*.* 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.2.0 255.255.255.0 outside
http 192.168.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 30 match address outside_cryptomap_dyn_30
crypto dynamic-map outside_dyn_map 30 set transform-set ESP-3DES-MD5
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer *.*.*.*
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 21 ipsec-isakmp
crypto map outside_map 21 match address outside_cryptomap_21
crypto map outside_map 21 set peer *.*.*.*
crypto map outside_map 21 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address *.*.*.* netmask 255.255.255.255
isakmp key ******** address *.*.*.* netmask 255.255.255.255
isakmp nat-traversal 10
isakmp policy 30 authentication pre-share
isakmp policy 30 encryption 3des
isakmp policy 30 hash md5
isakmp policy 30 group 2
isakmp policy 30 lifetime 86400
isakmp policy 50 authentication pre-share
isakmp policy 50 encryption 3des
isakmp policy 50 hash md5
isakmp policy 50 group 1
isakmp policy 50 lifetime 3600
vpngroup temp1 address-pool ClientVPNPool
vpngroup temp1 dns-server 192.168.1.2
vpngroup temp1 default-domain reliable
vpngroup temp1 split-tunnel temp1_splitTunnelAcl
vpngroup temp1 split-dns reliable
vpngroup temp1 idle-time 1800
vpngroup temp1 password ********
telnet 192.168.0.0 255.255.0.0 inside
telnet timeout 5
ssh timeout 5
management-access outside
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname *********
vpdn group pppoe_group ppp authentication pap
vpdn username ******** password *********
dhcpd address 192.168.1.2-192.168.1.129 inside
dhcpd lease 3600
dhcpd ping_timeout 750
vpnclient server *.*.*.* *.*.*.*
vpnclient mode client-mode
vpnclient vpngroup ********password ********
vpnclient username *******password ********
terminal width 80
Cryptochecksum:*****************************
: end
[OK]

Thanks in advance for your help.

Devon
0
Comment
Question by:pavehawk
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 800 total points
ID: 13408041
What is the IP address of the host that is the PCA host?
192.168.1.?

You can edit, then cut/paste this into the GUI, Command line, Multiple Command line window

static (inside,outside) tcp interface 5631 192.168.1.? 5631 netmask 255.255.255.255
static (inside,outside) udp interface 5632 192.168.1.? 5632 netmask 255.255.255.255
access-list outside_access_in remark Permit PCAnywhere access through firewall
access-list outside_access_in permit tcp any interface outside eq 5631
access-list outside_access_in permit udp any interface outside eq 5632
access-group outside_access_in in interface outside

Done. The remote PCA user will connect using the PIX outside interface IP address.


0
 
LVL 16

Expert Comment

by:samccarthy
ID: 13408779
lmoore has it
0
 

Author Comment

by:pavehawk
ID: 13421187
Thank you sir. I've applied this change and we're testing it today. Stand by.
0
 

Author Comment

by:pavehawk
ID: 13423048
Thanks lrmoore.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13424100
Glad to help!

- Cheers!
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Wikipedia defines 'Script Kiddies' in this informal way: "In hacker culture, a script kiddie, occasionally script bunny, skiddie, script kitty, script-running juvenile (SRJ), or similar, is a derogatory term used to describe those who use scripts or…
The DROP (Spamhaus Don't Route Or Peer List) is a small list of IP address ranges that have been stolen or hijacked from their rightful owners. The DROP list is not a DNS based list.  It is designed to be downloaded as a file, with primary intention…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
Suggested Courses
Course of the Month13 days, 10 hours left to enroll

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question