CD Writer tray won't open after log-in

Hi.  I am having problems with my CD-Writer not opening after log-in.  I have determined that it is not the power or the tray mechanism as it opens and closes fine during boot up.  Also, it reads and writes great.  I am running XP and have tried a couple of writers and get the same problem.  I have uninstalled the drivers and the Windows XP automatically installs the drivers it chooses when I re-boot.  I can't think of any other solutions.

Any thoughts?

Who is Participating?
sciwriterConnect With a Mentor Commented:
Roxio does lock the device and stops windows from popping up the message when a blank CD is inserted.  You have to look deeper for it, even right click on the CD/DVD drive in Explorer (or properties in device manager) and go through all those menus and all of Roxio's (CD/DVD properties) until you find it, it's almost certainly the problem.

Only other choice if you don't find it, is to uninstall Roxio, rebuild the windows registry by purging all the CD/DVD entires and start all over again.  Why go through all this hassle, when it is likely just one setting?
remove the drive from Device Manager, also Remove the IDE Channel that is hosting the device, now when you reboot, enter the BIOS, disable the IDE Channel that the drive is on, let windows boot to remove all information pertaining to either device from the registry, now reboot again, and get back into the BIOS, re-enable the IDE Channel, and boot to windows again, Windows should detect both devices, and you should be OK.
XP or your burn program (most probably) is keeping it "locked", as a safty feature. There should be an eject option when you right click the drive letter.
You need to look for a setting to get it to stop "hogging" the drive.
WEBINAR: GDPR Implemented - Tips & Lessons Learned

Join the WatchGuard team on Thursday, March 29th as we recount some valuable lessons learned in weighing the needs of a business against the new regulatory environment, look ahead at the two months left before implementation, and help you understand the steps you can take today!

It is not windows hardware or drivers that do this -- it is some CD burning program, as coral mentioned.  Windows XP NEVER locks a CD, not even when installing windows.  So you need to look at all the CD writing programs you have, like CloneCD, or that type of program -- in the setting of one will be the check box -- "Lock device" -- that is where your problem is.  Looking at the windows system for this is a waste of time, unless you have a totally corrupt XP install.  Doesn't sound like it, from what you say.  So check all CD burning programs and their settings.
If you are using NERO, some XP setups require that you have Administator rights in order to burn.
Nero Burning Rights will fix the problem.
If you are not using NERO, the log in account must be one with Administrator rights. Log in as Administrator, log in with an account with Administrator rights, or have an Administrator change your accounts rights.
veganmanAuthor Commented:
Wow - thanks for all the responses.  I have questions for some of you, so I will list them -

onedeej - how do I remove the IDE Channel?  Do you mean the cable?

coral47 and sciwriter - I am using Roxio and don't see a Lock CD feature.

tmj883 - I am using Roxio, not Nero.

Thanks everyone - I have hope now!
Nope, you dont actually need to touch the cable, right click on My Computer>Properties, now click the Hardware Tab, then click Device Manager, now if your Drive is on the secondary channel (Most are) then click the little plus symbol next to IDE\Atapi controllers, now right click on secondary IDE Channel, if it is on the Primary channel, then you have to turn off the computer, moce the drive to the other channel, then do the above.

As for Roxio, they dont have anything listed on their site pertaining to this issue, have you tried updating the software?
methinks thedudy is stating the obvious, which iwould have already been tried :(
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.