Approach 9.8 is very slow opening a database file

I recently installed Lotus Approach 9.8 (was using 9.5) on two different PCs. These PCs share a database. When I bring up the database for the first time it takes 3 minutes. On 9.5 it took 5 seconds. After the database comes up, if I make a change and save the .apr file, the next load will take 5 seconds.  BUT, now the second PC will take 3 minutes to load. Whoever saved the database last gets reasonable load time. The other PC gets a three minute wait. I don't really want to go back to 9.5.
HenryWilfredAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
suesloanConnect With a Mentor Commented:
Just a note or two.

1) You cannot move the .ADX index files to each local PC. They must stay in the same location as the .DBF files.

2) Copying the .APR files to each PC will save time only when an APR is first loaded into memory on each local PC. After that, the .APR on the server is not accessed again until you reload it.

Another forum has suggested that Norton Antivirus may be causing the delay. You could try disabling that software as a test, if you have it running.

Sue Sloan
0
 
VolleyTomConnect With a Mentor Commented:
First, make sure the system clocks on both PC's (and the server if that's where your data is) are synchronized. Otherwise, they'll reindex everything constantly. There are freeware utilities that will do this. Where are the APR files and data located?
0
 
HenryWilfredAuthor Commented:
Thank You -- I'll look at that. The apr file and databases are on the secretary's pc. Three other PCs have access to the database  via a network drive. All of us are on a small peer to peer network. We use windows XP. Do we need freeware to synchronize time? We are currently synchronizing time (or I thought we were - I will double check) by using the Internet Time tab inside  Date and Time in Control Panel.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
VolleyTomConnect With a Mentor Commented:
No, Internet Time is good enough. You probably want to copy the APRs and indexes to each local PC and have the databases themselves only on one unique PC. That way you won't be fighting over them.

You should download this file and review it for optimization techniques, compression and other stuff...

http://jabrown.customer.netspace.net.au/approach/auml-faq.txt

Also, check for any OYZ files that Approach may have created. It's a sign that something is not quite right with the database.
0
 
CRAKCommented:
This question has been classified abandoned. I will make a recommendation to the moderators on its resolution in a week or two. I appreciate any comments that would help me to make a recommendation.

Unless it is clear to me that the question has been answered I will recommend delete. It is possible that a Grade less than A will be given if no expert makes a case for an A grade. It is assumed that any participant not responding to this request is no longer interested in its final disposition.

If the user does not know how to close the question, the options are here:
http://www.experts-exchange.com/help.jsp#hs5

CRAK
EE Cleanup Volunteer
0
 
HenryWilfredAuthor Commented:
Thanks for the ideas. They were helpful. But the problem turned out to be a faulty use of a Toshiba copier as a network printer. A Toshiba tehcnician told me to create a new port for the Toshiba -- because I was having other printing problems. When I made this change (to all PCs on the network) the problem went away.

Sorry for my tardiness in closing this out.
0
 
CRAKCommented:
Better late than never!  ;-)
Thanks!

CRAK
0
All Courses

From novice to tech pro — start learning today.