Not able to print from DOS to Epson printer

Posted on 2005-02-26
Medium Priority
Last Modified: 2008-01-09
I have a computer that is running a DOS program.  The LPT port seems to be flacky, so I installed a PCI I/O card in the machine, it prints fine from Windows but refuses to print from DOS.
I tried installing the DOS driver (NMDOSIN.EXE) for the NETMOS NM9805 but it still didn't work.

Any idea how I could get the second LPT port to send printjobs from DOS to my Epson LQ-2180 printer?
Question by:William_Cacho
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
LVL 14

Expert Comment

ID: 13410784
Which LPT port is the card installed as (LPT1 or something else)?  Can you select which port to print to from your DOS program or does it just default to LPT1?  If your card is setup to be LPT2, change it to LPT1.  If thats not possible, try "mode lpt1: = lpt2" from a command prompt, without the quotes of course.

Expert Comment

ID: 13410844
make sure the I/O address for the printer port is set to 378h if your dos program is set to use lpt1, 278h if it is set to use lpt2.  You may have to set this up in your bios.

Accepted Solution

jwitt98 earned 2000 total points
ID: 13410879
Nevermind, I see you are using an add in lpt card.  You If your onboard lpt card is set as lpt 1 and your dos program uses lpt1, then you will have to either change the address for lpt one in your bios to free up address 378h or disable the onboard lpt port in the bios and then set the add in lpt card to use 378h in windows.  If your ad in card uses jumpers, you may have to set the jumpers to configure the card to use the address 378h.  
LVL 23

Expert Comment

ID: 13412908
Get the manual with the add-on card, and jumper the port to 3BC hex by changing jumpers on the card -- IRQ is ALWAY 7 for lpt1 - 3BC hex is the true LPT1 for DOS -- must be done with the system off.  When you reboot, your on-board port normally defaults to 378, so it will become LPT2, and you should be able to now print directly to LPT1 -- but check the BIOS port setting to make sure it is either 278 or 278, and you will be fine.
LVL 23

Expert Comment

ID: 13412913
BTW -- windows may not PnP detect this card, so you will ahve to run an install hardware wizard if it does not.  This will be important to do, even for DOS, if you shut windows down to a "dos prompt", as it affects port assignments.

Featured Post

New benefit for Premium Members - Upgrade now!

Ready to get started with anonymous questions today? It's easy! Learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many people don't really know what the difference is between memory and storage. And most regular users don't understand the relationship between any of those fancy words printed on the front of their new computer. Of course, it's perfectly fine -- …
Article by: Firmin
The 5 R's 1. Repair 2. Restore 3. Reinstall 4. Remote admin 5. Run away OK so I'm not the most skilled engineer around but I definitely have an abundance of experience: electronic repairs since I was 13 and PC and computer hardware repair…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question