• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3618
  • Last Modified:

Firefox Problem - The browser you're using refuses to sign in. (cookies rejected)

The browser you're using refuses to sign in. (cookies rejected)

When I updated to the new Firefox 1.0.1 this is what I got trying to open my Yahoo Start Page. I deletd the old version of Firefox and saved my profile. Everthing eles works great since updateing Firefox except I can no longer get to my start page on Yahoo, which is my favorite page. HELP !!!!!!!!!
_________________
Take Care, Lester40

Dell Dimension XPS
3.2 GHz Pentium 4 @ 800MHz FSB
2048MB 400Mhz Dual-Channel DDR RAM
250 GB Serial ATA @ 7200RPM
256MB DDR ATi Radeon 9800 XT
Soundblaster Audigy 2
16 Max DVD-ROM Drive
4xDVD+RW/+R Drive w/CD-RW
Logitech Cordless Elite Keyboard
Logitech MX 700 Cordless Optical Mouse
Sony Trinitron 19-inch Monitor
Cambridge SoundWorks Speaker System
Epson Stylus Color 440 Printer
NOD32 Antivirus System
eTrust EZ Firewall
Mozilla Firefox 1.0.1
Mozilla Thunderbird 1.0
0
Lester_and_Julie
Asked:
Lester_and_Julie
  • 3
  • 3
1 Solution
 
fiboCommented:
Which options have you selected for cookies-handling in Firefox?
Also, check if some XP update has not changed the settings of your firewall, and of course check the options in your EZ firewall.
0
 
rocketTendonCommented:
First, lets make sure that Firefox didn't decide to change the default settings.

Goto:

Tools / Options / Privacy

Expand the "Cookies" options and verify that the "Allow sites to set cookies" option is checked, and that there are no websites in the "Exceptions" module.
0
 
Lester_and_JulieAuthor Commented:
Yahoo now works. The only problem I have now is going to amazon.com. The only way it lets me on the site is to put a exception in firefox to allow cookies in amazon.com, even though I have checked to allow all sites to allow cookies. Does that sound right?

Take Care, Lester40

Dell Dimension XPS
3.2 GHz Pentium 4 @ 800MHz FSB
2048MB 400Mhz Dual-Channel DDR RAM
250 GB Serial ATA @ 7200RPM
256MB DDR ATi Radeon 9800 XT
Soundblaster Audigy 2
16 Max DVD-ROM Drive
4xDVD+RW/+R Drive w/CD-RW
Logitech Cordless Elite Keyboard
Logitech MX 700 Cordless Optical Mouse
Sony Trinitron 19-inch Monitor
Cambridge SoundWorks Speaker System
Epson Stylus Color 440 Printer
NOD32 Antivirus System
eTrust EZ Firewall
Mozilla Firefox 1.0.1
Mozilla Thunderbird 1.0
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
fiboCommented:
So now we know that:
- Firefox seems to block more cookies than you asked it to,
- including for Amazon, where you succeded by forcing firefox to accept cookies for this site.

Following RocketTendon's advices, what is your current "cookies setting" in Firefox? in EZ firewall?
0
 
Lester_and_JulieAuthor Commented:
In eTrust EZ Firewall I have it set to allow all cookies by default. In Firefox under options, privacy, cookies, I have checked "Allow sites to set cookies". After doing this in order to get into amazon.com I had to put amazon.com in the allow list. Theres no problem after I do this. But if I take the exception rule out it  says "The browser you're using refuses to sign in. (cookies rejected) on firefox".This in it self is not a problem if more and more sites do not do this. I just wanted to know if this was typical or did I have something set-up wrong. Thanks.

Take Care, Lester40

Dell Dimension XPS
3.2 GHz Pentium 4 @ 800MHz FSB
2048MB 400Mhz Dual-Channel DDR RAM
250 GB Serial ATA @ 7200RPM
256MB DDR ATi Radeon 9800 XT
Soundblaster Audigy 2
16 Max DVD-ROM Drive
4xDVD+RW/+R Drive w/CD-RW
Logitech Cordless Elite Keyboard
Logitech MX 700 Cordless Optical Mouse
Sony Trinitron 19-inch Monitor
Cambridge SoundWorks Speaker System
Epson Stylus Color 440 Printer
NOD32 Antivirus System
eTrust EZ Firewall
Mozilla Firefox 1.0.1
Mozilla Thunderbird 1.0
0
 
Lester_and_JulieAuthor Commented:
I will try one more time. I have had good success with expert exchange so far. If this is a dumb or silly question please let me know. Other wise, I will just need to reevaluate my status as an expert exchange paying member. Is there anybody out there that will care to either answer my question or at least try to get me to understand it? Thanks for all your help and patience.

Take Care, Lester40

0
 
fiboCommented:
Lester,
Under firefox's option for cookies is another where you can decide if cookies are allowed only for the site which created them or if you allow cross-sites cookies.
What is you current setting?
I did a check with Amazon.fr: it seems that amazon is certainly not firefox-friendly (or is Firefix not being Amazon-friendly): most images do not display, even after refresshing the page. The buttons do not display either, but they are there, clickable (if you happen to know they should be there).
This seems related to JAVASCRIPT...
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now