Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

GD Shared Library

Posted on 2005-02-27
5
Medium Priority
?
322 Views
Last Modified: 2013-12-16
Dear All,

Can anyone give me a brief howto on removing the GD shared libs on a Redhat 9.0 box. I'm trying to setup MRTG which I've done a few times before on older RH's without any probs at all. However, when './configure' ..ing, an error message appears which indicates that I need to remove the GD shared libs. I have tried removing all the libgd.so.* linked lib files in /usr/lib but MRTG still won't configure.

Please tell me that I dont need to recompile GD and re-install, as removing the GD rpm is a bitch because it has so many other dependants.

Yours hopefully,

A.
0
Comment
Question by:arakis
  • 2
  • 2
5 Comments
 
LVL 7

Accepted Solution

by:
surya_prabhakar earned 1000 total points
ID: 13413907
Why cant  you compile older working GD to some other directory ( with prefix) and give that as gd library path ?

Btw way caan you paste the exact error your getting .

thx.
surya.
0
 

Author Comment

by:arakis
ID: 13414017
And that is exactly what I'm going to try next...(Guess I should have thought of that myself...!)

Error message below -

...
checking gd.h usability... yes
checking gd.h presence... yes
checking for gd.h... yes

** Ooops, one of many bad things happened:

   a)  You don't have the GD library installed.
       Get it from http://www.boutell.com, compile it and
       use either --with-gd-lib=DIR and --with-gd-inc=DIR to specify
       its location. You might also have to use --with-z-inc,
             --with-z-lib and --with-png-inc, --with-png-lib for gd
             versions 1.6 and higher.  Check config.log for more
       information on the problem.

   b)  You have the GD library installed, but not the gd.h
       header file.  Download the source (see above) and use
       --with-gd-inc=DIR to specify where the file can be found.

   c)  You have the library and the header file installed, but
       you also have a shared GD library in the same directory.
       Remove the shared library files and/or links (e.g.
       libgd.so.2.0.0, libgd.so and libgd.so.2).  This is especially
             likely if you're using a recent (post 1.8.4) version of GD
       and didn't configure it with --disable-shared.

   d)  You have gd library installed and also it's headers, but you are
       missing libpng (and headers) or freetype (and headers)
       (mrtg does not use freetype, but if your copy of gd is precompiled
       against it, you have to install it ...

Thanks for the pointer. Will get back to you shortly.

A.
0
 
LVL 7

Expert Comment

by:surya_prabhakar
ID: 13414084
when configuring GD ( do it with a -disable-shared _) and see.....

surya.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 13415508
The mrtg build is probably complaining about not being able to find the GD header files, which will happen if you don't have the gd-devel package installed. Mrtg will work perfectly with the version of GD found on a RedHat 9 system.

At this point my recommendation is to re-install the GD package to fix where you futzed with it and to also install the matching gd-devel package. Then you'll be able to configure/build GD, or at least get a bit further. There could be other *-devel packages that you haven't added to the system, but you see the error in the configure output.

0
 

Author Comment

by:arakis
ID: 13422917
Thanks Surya. I now have a working MRTG.

I had already installed the gd-devel packages req. and the problem was solely down to the Shared Libs.

A.

0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
Often times it's very very easy to extend a volume on a Linux instance in AWS, but impossible to shrink it. I wanted to contribute to the experts-exchange community a way of providing a procedure that works on an AWS instance. It can also be used on…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month11 days, 16 hours left to enroll

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question