Slow response MySql administrator and MySQL Browser on Windows 2000 server and workstation

Hello Experts,

I just installed MySQL 4.1.10 on a Win 2K server SP4. Using the MySQL Administrator and MySQL Query Browsers on the server works well and response is nearly instantaneous.

Using the same utilities from a workstation is very different. The results take 15-20 sec to appear.

I think the problem has to do with communication between the workstation and the server.  Running a simple query on the workstation's Query Browser will return results in about 15-20 sec however the server reports "3 rows fetched in 0.0136s (0.0016s)" . This would indicate that the query was very fast  once the client communicated with the server.

The time to login suffers similar delays. Very fast on server, same 15-20 sec delay at the workstation. Something appears to be timming out somewhere.

A server host IP (not server name) is used to login.

The w2k server and w2k workstations are on a test network so any mis-setting is possible.

New at MySQL so not  sure of where to start or what tools to use to troubleshoot this one. Probably not a simple problem.

Thanks in advance,

Eric
dbworker1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bernard S.CTOCommented:
Check what is the real size of the data transmitted over the network...
In a similar situation (instant results display local, noticeable display time ove the local network), I just found that the page was over 700K (!) which of course did explain the delay.
If this is the explanation AND if this is going to be apermanent problem, you might consider looking at "html compression" to lower the volume transmitted (ie, you'll enable gzip compression from your server, and gzip-enabled browser will be able to use this compression, while with non-enabled browsers the server will not compress) [over regular text this might divide the volume by 2 to 3, or by 3 to 8 for utf8].
0
dbworker1Author Commented:
Thanks for the reply, fibo.

The data transmitted is tiny, just the reply from MySQL of 3 items in a data set. Don't know how to check the exact size of the file since it is the MySQL admin query to MySQL, no web pages involved. Pure client server.
I am beginning to think that the problem may be caused by an AD or DNS setup problem.

Thanks for the information about gzip, might come in handy later.

0
Bernard S.CTOCommented:
DNS seems not to be the cause, since you mentionned that you address the servers dirctly by their IP address. Right?

Open a DOS box and try the usual "ping xx.xx.xx.xx" and "tracert xx.xx.xx.xx" to see what is happening. I would test first from th station towards the server, then the reverse.

Now the "security" track:
is there any firewall active? Is there any proxy active (even if this is "just" for outside access)

Now to the AD track:
From the station what gives a "net view \\xx.xx.xx.xx"?
Is your station in the same domain than the server? Is your station PART OF THE DOMAIN? As a user on your station, you may be part of the domain while the station itself is not... or you might not be part of the domain without some kind of logging on...

0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

dbworker1Author Commented:
Hi fibo,

The server is addressed directly by IP.
The test network is "flat" just a bunch of PC connected to a switch.
Being a test network it often has all sorts of setup / corruption problems. There is one W2K domain controller. There are several other W2K / Linux servers and a bunch of different workstations. The test server running MySQL is a W2K server and not a domain controller. The network hosts both Win and NetWare servers.

Ping xx.xx.xx.xx is <10ms as expected, no loss
tracert returns is just one hop as this is a "flat" test network with just  a switch betweens the servers and workstations

The Net view is odd :
net view \\xx.xx.xx.xx returns :
System error 35  / The network path was not found

net view \\computername returns the same error. Same error testing from the server or the workstation.

net view
returns no entries in the list.

Yet as far as I can tell (but obviously wrong) the computers are members of teh domain.

The computers are listed in "Domains Computers Properties" members
My login is listed under "Domain User Properties" members

However I went to the db server to system|network ID and the computer was not a member of the domain (defauled to WORKGROUP). I made it member of the domain (why was it listed as a member in the DC lists?) .

Net view //dcname  now works from the db server. net view //dcname also works from the workstation. However net view //databaseserver still does not work. Same problem from several workstations. No change in the slow MySQL response time.

net view
now returns just one entry, the domain controller, not the database server.

net view from the only domain controller displays only itself even though there are a bunch of PC listed in its member list. Something wrong here.

Does this make sense?

Again thanks for your input






0
Bernard S.CTOCommented:
There are funny things in this "domain business", and adding netware on top of that certainly does not make things easier.

I think you need input from real network people that will be more competent than I am.
Put a 20 points question in http://www.experts-exchange.com/Networking/Microsoft_Network/ directing experts to the question here at http://www.experts-exchange.com/Databases/Mysql/Q_21330882.html 
I'm sure they'll find the answer easily
0
dbworker1Author Commented:
Solution:

Stamatis (myth0z ) posted a suggestion that helped me find the solution. See:

http://www.experts-exchange.com/Networking/Microsoft_Network/Q_21338986.html

The computer hosting MySQL had a correct primary DNS entry and an incorrect (unreachable) secondary DNS entry. Not sure why this affected MySQL but deleting the secondary DNS entry on the Windows computer hosting MySQL cured the problem.



0
Bernard S.CTOCommented:
dbworker1
You now need to allocat the 500 points to Stamatis.
The easiest way would be for you to ask him in http://www.experts-exchange.com/Networking/Microsoft_Network/Q_21338986.html to come here to make any post refering to his answer there, and then you would be able to allocate him the 500 ponts waiting here.
Another route woud be to go to the community support at http://www.experts-exchange.com/Community_Support/ to ask for an administrator to solve the issue... but since there is an easy to do solution this should be the preferred route!
0
myth0zCommented:
Hi again Eric.

As posted in the second thread about this problem in Microsoft Networking  (http://www.experts-exchange.com/Networking/Microsoft_Network/Q_21338986.html)
I recomended to check IP settings (DNS, DHCP, G/W) for all pc (servers/workstations) consisting the test domain.

So you found that databaseserver had for Secondary DNS the IP of your ISP's DNS. By correcting this you solved the problem.

- Stamatis
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.