Automagicly firing up my wireless card on FC3

Every reboot, I need to do the following and it's a real pain in the butt. How can I make it auto start?

-------------------------------------------
[dallasray@dallasraymobile ~]$ su
Password:
[root@dallasraymobile dallasray]# /sbin/ifconfig wlan0 up
[root@dallasraymobile dallasray]# /sbin/dhclient wlan0
Internet Systems Consortium DHCP Client V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

/sbin/dhclient-script: configuration for wlan0 not found. Continuing with defaults.
/etc/sysconfig/network-scripts/network-functions: line 47: wlan0: No such file or directory
Listening on LPF/wlan0/00:11:f5:2a:af:e3
Sending on   LPF/wlan0/00:11:f5:2a:af:e3
Sending on   Socket/fallback
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15
DHCPOFFER from 192.168.1.1
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
/sbin/dhclient-script: configuration for wlan0 not found. Continuing with defaults.
/etc/sysconfig/network-scripts/network-functions: line 47: wlan0: No such file or directory
bound to 192.168.1.101 -- renewal in 123952 seconds.
[root@dallasraymobile dallasray]#
LVL 2
smetterdAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

harbor235Commented:
Write a script, add to your login profile so it is executed every time you login, or
every time you manually start the script.

harbor235
0
smetterdAuthor Commented:
I am experienced in writing batch files for windows, but not sure how to do this on Linux
0
LnxOneCommented:
You can put all your command lines in the rc.local file so that it'll automatically start the service at boot time.  You can use "vi" editor to modify the rc.local file.   After all command lines are put in there then restart your Linux box to see if those command lines are executed.  This should work...
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

LnxOneCommented:
The rc.local file should locate under /etc/init.d/rc.local...  This would depend on the version of Linux you are running. If you are not sure where the "rc.local" located then you can use the "whereis rc.local" command line to find out the path to it ...

Best of luck
0
smetterdAuthor Commented:
RedHat Enterprise 4

[dallasray@drstravel ~]$ whereis rc.local
rc: /etc/rc.local /etc/rc1.d /etc/rc.sysinit /etc/rc3.d /etc/rc4.d /etc/rc2.d /etc/rc5.d /etc/rc0.d /etc/rc.d /etc/rc6.d /etc/rc
0
LnxOneCommented:
It should be /etc/rc.local <- Add your command lines here.
0
smetterdAuthor Commented:
Here's how I have modified it. Doesn't work. Wrong syntax? do i need the command "touch" at the beginning of each line?

------------
#!/bin/sh
#
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.

touch /var/lock/subsys/local
/sbin/iwconfig wlan0 essid dallasray.com
/sbin/modprobe ndiswrapper
/sbin/ifconfig wlan0 up
/sbin/dhclient wlan0
0
LnxOneCommented:
You do not need to put the command "touch" at the beginning of each line.  Try to remove the /bin/ and only put the command line there...
0
LnxOneCommented:
Should look like this:

touch /var/lock/subsys/local
iwconfig wlan0 essid dallasray.com
modprobe ndiswrapper
ifconfig wlan0 up
dhclient wlan0
0
smetterdAuthor Commented:
Did that, and things just got worse. Now I can't even fire it up manually.
---------------------
[root@dallasraymobile dallasray]# /sbin/iwconfig wlan0 essid dallasray.com
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wlan0 ; No such device.
[root@dallasraymobile dallasray]#
0
LnxOneCommented:
Is this a PCMCIA card? What is the name and series?  

If it is a PCMCIA card then remove it and reboot your system.  Once you can boot up your system then logon as "root" or supper user. Follow these steps:

1. # cd /etc/
2. # vi rc.local
3. Remove this:
    iwconfig wlan0 essid dallasray.com
    modprobe ndiswrapper
    ifconfig wlan0 up
    dhclient wlan0
4. Only put the command lines here which will fire up your wireless card. It seem like you only need to put these two command lines according to your very first question:

touch /var/lock/subsys/local
ifconfig wlan0 up
dhclient wlan0

5. Restart your system with the card in utilizing the following command: shutdown -r now
 
0
smetterdAuthor Commented:
This is an onboard card in a Toshiba Satelline A75 notebook. Could upgrading my kernel killed it?
0
LnxOneCommented:
Yes,  That would do it.  You must reconfigure your NIC again on the new kernel that your just upgrated.  Once you're done with the NIC reconfiguration then just apply to the procedure above then your  NIC card will automatically turn on as you're expecting it.
0
smetterdAuthor Commented:
Will do when return to office. So... I will have to do this after all kernel upgrades?
0
smetterdAuthor Commented:
Recompiled and still no go!

When I get to the modprobe step, I get...

[root@dallasraymobile ndiswrapper-1.1]# /sbin/modprobe /usr/sbin/ndiswrapper
FATAL: Module /usr/sbin/ndiswrapper not found.
[root@dallasraymobile ndiswrapper-1.1]#
0
LnxOneCommented:
Recompile your kernel is not going to help resolve the problem. You will need to reinstall the NIC driver once again. After you reinstall it then you must reconfigure your Wireless Network again.

If you still have your ndiswrapper.tar.gz then refer to this link for detail instruction on how to procede the installation: http://linuxweblog.com/node/189
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
smetterdAuthor Commented:
Currently out of town, will continue when return. Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.