?
Solved

VNI-2015 error re backup and recovery on EOM

Posted on 2005-03-01
6
Medium Priority
?
429 Views
Last Modified: 2007-12-19
I' am trying to execute a backup using OEM. Pretty straightforward stuff. Everything goes OK but on checking the backup in the 'Jobs' I find it has failed and I get this error...

'VNI-2015 : The Node preferred credentials for the target node are either invalid or do not have sufficient privileges to complete the operation.
On Windows platforms, the Node credentials specified for the Windows target should have the "Logon as a batch job" privilege.'

Pretty standard stuff I'm sure. Relates to Adminstrator passwords possibly? Anyway, if someone could offer an explanationa nd fix it would be appreciated.
0
Comment
Question by:rl_marton
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 1

Expert Comment

by:salilc
ID: 13440115
hi,

The VNI-2015 error occurs when the Intelligent Agent cannot logon locally
to the Windows 2000 system.There is a privilege called....
a)Logon as a Batch Job
b)Deny Logon as a Batch Job(new to win2000) .

Check whether these two privileges are assigned to the same OS user.
If Deny Logon as a Batch Job privilege is assigned to the same user it will override the
Logon as a Batch Job privilege

rgds


0
 

Author Comment

by:rl_marton
ID: 13441265
'Check whether these two privileges are assigned to the same OS user'..How do I do this please?
0
 
LVL 1

Expert Comment

by:salilc
ID: 13446939
hi marton

Remove the Intelligent Agent's OS user from the list of users who are
assigned the privilege "Deny Logon as a Batch Job".

try this.........

1. Click on START => Programs => Administrative Tools => Local Security Policy

in the local policies folder select the User Rights Assignment folder.
there you can see a scroll bar.scroll it down util you see
"DenyLogon as Batch Job" privilege.double click on the privilege.
you can see the list of users who are assigned this privilege.
locate win 2000 user who is specified in the Enterprise Manager Console's Preferred Credentials setting for that node.
you can see a checkbox to the right of the user name.uncheck it.
click OK to save the changes.

i hope this will resolve the problem you are facing........

rgds
0
Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

 

Author Comment

by:rl_marton
ID: 13456608
Hi,

Been to that box and nothing there unfortunately. Empty box.

RL
0
 
LVL 1

Accepted Solution

by:
salilc earned 450 total points
ID: 13464804
hi marton,

i dought that you had'nt assigned the 'logon as a batch job ' privilege to the OS user

try setting that privilege first.....

1. go to START => Programs => Administrative Tools => Local Security Policy

2.under Local Policies on the left, select User Rights Assignment folder

3.at the right side of the window you can see a scroll bar.scroll it down to the "Logon as Batch Job" privilege and select it.

4.right-click on the "Logon as a Batch Job" privilege then Security.

5.select the Add button which evokes a Select Users/Groups box.

6.from the "Look In" field, select the local workstation/server

7.select the User that will be used as the OEM OS user.

8.select Add then OK

9.check whether the "Local Policy Setting" checkbox has been selected

10.logon to the OEM

11.click on system => Preferred Credentials

set PREFERRED CREDENTIALS for the NODE called DEFAULT.This will set the logon credentials for all discovered nodes.

OR

set individual PREFERRED CREDENTIALS for each NODE

NB:Option B must be used if the accounts and passwords are not unique across the  servers

rgds  
0
 

Author Comment

by:rl_marton
ID: 13464977
I think part of the problem here is I'm running 9i on XP and the set-up is slightly different. Transposing your ideas a little I can get quite a good way down your list. Re point 6 the local workstation/server is already selected but there is no "Local Policy Setting" checkbox to check.

I had a look at steps 10> OK with that. Its obviosuly something in and around step 6+ thats fouling things up for me.

Thanks for your effort on this anyway.
0

Featured Post

Enroll in August's Course of the Month

August's CompTIA IT Fundamentals course includes 19 hours of basic computer principle modules and prepares you for the certification exam. It's free for Premium Members, Team Accounts, and Qualified Experts!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Why doesn't the Oracle optimizer use my index? Querying too much data Most Oracle developers know that an index is useful when you can use it to restrict your result set to a small number of the total rows in a table. So, the obvious sideā€¦
Shell script to create broker configuration file using current broker Configuration, solely for purpose of backup on Linux. Script may need to be modified depending on OS-installation. Please deploy and verify the script in a test environment.
This video explains at a high level with the mandatory Oracle Memory processes are as well as touching on some of the more common optional ones.
This video explains at a high level about the four available data types in Oracle and how dates can be manipulated by the user to get data into and out of the database.
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question