Pocket PC Synchronization Cannot Be Completed

I have an iPaq 3635 running Pocket PC 2000 that I synchronize with both my laptop computer at work and my desktop PC at home. I have been using this iPaq now for three years and up until 3 weeks ago the system was working fine. Three weeks ago I got a new laptop at work. My new laptop has Windows XP SP2. My old one ran Windows 2000 Pro SP4, and my desktop at home still runs Windows 2000.

When I installed ActiveSync on the new laptop and set up a relationship with the iPaq, everything worked fine. But when I got home that evening and plugged the iPaq into my desktop, after the intial synchronization it showed "1 File Item unresolved". Each time you try to re-synch and resolve that item you get a popup message that says: "Synchronization cannot be completed because a file cannot be synchronized with your mobile device. Close all programs on your mobile device and this computer and synchronize again."

Since then I have emptied the Pocket_PC folder on my desktop and laptop and tried to synch with no files to move. I have also reset the iPaq. Nothing fixes the problem. I get a good synch at work on the Windows XP laptop, but I get the above error whenever I synch at home.

Any thoughts and ideas would be appreciated. Thanks.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Check the logfiles for Activesync located at:
%homepath%\Local Settings\Temp\wcesmgr.log

There are a few other log files in that directory that all start with WC*.log
thphoenixAuthor Commented:
Thanks for the reply.

I checked the wcesmgr.log. Below is the portion of the log that is obviously describing the error I am getting, but I don't know enough about what is being logged to understand which file cannot be synchronized.

2005-02-28 21:27:31 0000053C - **** Starting synchronization of all out-of-date items
2005-02-28 21:27:31 0000053C - Scanning desktop SSP for 'File'
2005-02-28 21:27:31 0000053C - Done scanning 'File' [0 creates, 0 modifys, 0 deletes]
2005-02-28 21:27:31 0000053C - Synchronizing 1 items
2005-02-28 21:27:31 0000053C - ERROR returned in function CReplEntry::Synchronize. hr: 0x80145041
2005-02-28 21:27:31 0000053C - ERROR: unable to sync type 2 of [File, 0, 0xB0].
2005-02-28 21:27:31 0000053C - One File item [Vol: 0, Oid: 0x000000B0] flagged, SyncType: REMOTE_DEL
2005-02-28 21:27:36 0000053C - **** Completed synchronization

What do I look for next? Thanks again.

Do you know what file it is unable to sync?  Maybe a problem with different programs being install on your work computer vs home?
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

thphoenixAuthor Commented:
No, I don't know what file is the culprit. In fact, I have deleted all the files in the Pocket_PC sync folder and I still get the error message, even when no files appear to be there.

The programs running on my work computer and home computer are different, but they are the same as they were when all this worked before. Again, the only difference is I have upgraded my work laptop to Windows XP SP4.

thphoenixAuthor Commented:
I fixed it.

Since I was never able to sync without getting the same errrors, and since I never found a solution to the problem, I decided to "wipe out" my Pocket PC by installing a ROM upgrade. (I had not done that before now because everything was working fine, and I didn't want to re-install all my programs). After installing the ROM upgrade and re-establishing the relationships on each desktop computer, everything syncs just fine now.

I guess this problem is now considered closed.
Closed, 250 points refunded.

Community Support Moderator
Experts Exchange

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.