?
Solved

Mouse Touchpad issues with SuSE 9.2

Posted on 2005-03-02
7
Medium Priority
?
789 Views
Last Modified: 2012-05-05
I just installed SuSE Linux 9.2, and am having problems with the mouse. I have a Toshiba Satellite A45-S250, which has a mouse touchpad. In SuSE 9.2, everytime I click on something by tapping on the mousepad, there is a small delay - only about a second, but enough to be noticeable and annoying - before it is actually clicked on. This also makes it impossible to double-click anything by tapping the touchpad. This delay does not happen when I use the buttons directly below the touchpad. I never had this problem in 9.1.

(As a side note, tapping the touchpad simply didn't work at all in 9.2 until I went into KDE Control Center and selected the specific mousepad that I have - this made the installation process take a while, so I ended up plugging in a USB mouse. Again, I never had to do this in 9.1 - the touchpad functioned flawlessly even in 9.1 installation, even when the mouse selected was just a generic "PS/2 mouse")

Also - perhaps this should be a different question but I think it's related enough to also be asked here - SuSE 9.2 allows the touchpad to emulate a "scroll wheel" when I move my finger on a certain small area on the right or bottom side of the touchpad, a feature I enjoyed when I 1st got my laptop a year ago, when it came with Windows, and no longer had after installing SuSE 9.1. It's a great feature, but I can't find anywhere to configure or disable it - I looked in YaST and KDE Control Center and can't find anything.
0
Comment
Question by:beaker67
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
7 Comments
 
LVL 12

Accepted Solution

by:
mburdick earned 1000 total points
ID: 13464022
I just tweaked my mouse in Pro 9.2 today... If it's a Synaptics, SuSE has a 9.1-specific document that is a good start.

Replace the Mouse information in your /etc/X11/XF86Config file with the following:

Section "InputDevice"
  Driver       "synaptics"
  Identifier   "Mouse[0]"
  Option       "AccelFactor" "0.0010"
  Option       "BottomEdge" "4000"
  Option       "Device" "/dev/psaux"
  Option       "Edges" "1900 5400 1800 3900"
  Option       "Emulate3Buttons" "on"
  Option       "Finger" "25 30"
  Option       "FingerHigh" "30"
  Option       "FingerLow" "25"
  Option       "InputFashion" "Mouse"
  Option       "LeftEdge" "1900"
  Option       "MaxSpeed" "0.18"
  Option       "MaxTapMove" "220"
  Option       "MaxTapTime" "180"
  Option       "MinSpeed" "0.02"
  Option       "Name" "Synaptics;Touchpad"
  Option       "RightEdge" "5400"
  Option       "SHMConfig" "on"
  Option       "TopEdge" "1900"
  Option       "VertScrollDelta" "100"
  Option       "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[3]"
  Option       "Device" "/dev/input/mice"
  Option       "Emulate3Buttons" "on"
  Option       "Emulate3Timeout" "50"
  Option       "InputFashion" "Mouse"
  Option       "Protocol" "imps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
  Option       "SendCoreEvents" "yes"
EndSection

Then, replace the following section as well:


Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[0]" "CorePointer"
  InputDevice  "Mouse[3]" "SendCoreEvents"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Restart "X", and you should be all set.
0
 
LVL 2

Author Comment

by:beaker67
ID: 13565528
Tried that, but that just made the tapping on the touch pad impossible again. Then I went into SaX2, tried to change the settings back, but after doing that it froze and when I restarted I got a bunch of errors about "mingetty" and it wouldn't start. Yesterday I brought my computer to be serviced (unrelated issues) and it won't be back for at least a week - after it gets back I'll try 9.2 again.
0
 
LVL 2

Author Comment

by:beaker67
ID: 13880134
Sorry for taking so long, I got my computer back a couple weeks ago but practically forgot about this, and I was busy experimenting with other stuff (mainly Linux from Scratch). I just tried changing a few settings - I didn't copy-and-paste the entire text you provided (because that created more problems before) - I just changed several individual settings that seemed to have something to do with this problem (in particular MaxTapMove in MaxTapTime) but nothing happened.
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
LVL 12

Expert Comment

by:mburdick
ID: 13881720
FWIW: I'm now running SuSE Pro 9.3, and it's the same. I suspect that there's either something not quite right with the driver, or the settings need to be tweaked a little more than what I have so far.
0
 
LVL 2

Author Comment

by:beaker67
ID: 13882550
Apparently it's not just SuSE...

I'm trying to get linux from scratch working and upgraded the lfs 5.1.1 kernel (2.4) to the latest stable 2.6 kernel. When I installed gpm I noticed that tapping the touch pad doesn't do anything, when (surprise...) it had worked fine with 2.4.
0
 
LVL 2

Author Comment

by:beaker67
ID: 14332383
I found the "synaptics" driver and installed it -
0
 
LVL 2

Author Comment

by:beaker67
ID: 14332388
Err meant to have more text there...

I installed the Synaptics driver - I still have some tweaking to do, but it seems it works pretty well now.
0

Featured Post

CHALLENGE LAB: Troubleshooting Connectivity Issues

Goal: Fix the connectivity issue in the lab's AWS environment so that you can SSH into the provided EC2 instance.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Suggested Courses
Course of the Month9 days, 9 hours left to enroll

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question