No Such File or Directory - Solaris 8 Remote Mounting

Hi,

I am trying to remote-mount the Oracle 10g Home directory for a system to correct an Oracle 9.2.0.4 problem on another system.

I get the following:

# mount -F ufs dph-ap002:/dev/dsk/c1t5d1s2 /u103
mount: dph-ap002:/dev/dsk/c1t5d1s2 or /u103, no such file or directory

and also:

# mount -F ufs dph-ap002:/u03 /u103
mount: dph-ap002:/u03 or /u103, no such file or directory

I have made the target directory shareable, but with FS=nfs (share does not like ufs)

If I use FS=nfs for the mount command:
# mount -F nfs dph-ap002:/dev/dsk/c1t5d1s2 /u103
nfs mount: dph-ap002: : RPC: Program not registered
nfs mount: retrying: /u103
^C

What should I be doing?

I have tried to find the answer to this problem, but EE will only allow me to see it if I am a premium member.  I appreciate your help.

Bob
LVL 4
BobHBAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PsiCopCommented:
Is the nfs-server running on dph-ap002?
0
BobHBAuthor Commented:
Yes:
ps -ef|grep nfs
    root   249     1  0   Feb 09 ?        0:00 /usr/lib/nfs/lockd
  daemon   250     1  0   Feb 09 ?        0:00 /usr/lib/nfs/statd
    root  5585  5468  0 12:58:28 pts/7    0:00 grep nfs
0
sisiroCommented:
dph-ap002:/dev/dsk/c1t5d1s2  

Are you running it from dph-ap002? I think you are running it from another server.
In that case, on dph-ap002 make sure that /dev/dsk/c1t5d1s2 is mounted to some mount point, say /ora1
Then share this mount point on dph-ap002, check with dfshares command to make sure it is shared.

Then come back to your server and try to mount it at local maching mountpoint /u103 using:
# mount -F nfs dph-ap002:/ora1 /u103

If /u103 already contains some data, that data won't be visible till you unmount it.

HTH,
sisiro
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

BobHBAuthor Commented:
Before I accept the answers and award points, I'd like to say that both of you helped.  Ultimately sisiro helped more, but I also found out that my share was improperly done, and for that sisro's dfshares suggestion was totally invaluable.  Once I set that up properly, everything worked.

Thank you both!
0
PsiCopCommented:
Glad its working. Thanks for the points.
0
sisiroCommented:
Thank you Bob.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.