Roxio - Cant find a writable drive

I have a system running windows 2000 with a new DVD/CDRW combo drive.  Roxio comes bundled with the drive and the organization has no money to spend on extra burning software.

It is Roxio 5.3.4 and when you launch Roxio it loads and coughs a "failed to load something api" error and then finished loading. After loading files for a project and clicking on "burn" a "Roxio cannot find a writable drive" error shows.

I tried uninstalling Roxio and reinstalling - same api error. Tired uninstalling and re installing from CD instead of our network share - Nope - same api error.

It looks like there is a registry entry that won't clear up with a reinstall and keeps getting used. That's my guess.  The drive has been tested in another system with same Roxio version and works fine.

Any suggestions?
LVL 1
zenportafinoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jwleonard1Commented:
Go here and get the latest updates for your product http://www.roxio.com/en/support/software_updates.jhtml this should update the list of supported drives.
0
zenportafinoAuthor Commented:
I already visited that link, downloaded the update for 5.x and when I went to install it - it says you need to upgrade to Platinum - and errors out.  They don't want to spend anymore money.

I really feel that I need to get past the API error that comes up when roxio loads.
0
jwleonard1Commented:
Ok, try this...
http://www.roxio.com/en/jhtml/ftp/filedownload.jhtml?id=570

It is for version six but it might work.
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

jwleonard1Commented:
0
mysticaldanCommented:
Best wud be to uninstall Roxio and load Nero up. The APi problem ur getting is a uncompatibility problem. I am surprised its coming with ur drive since u must have gotten the software bundled with it. You cud optionally also try to upgrade the BIOS of ur DVD drive just in case Roxio has problems with that.

You can get Nero from www.ahead.de and that shud take care of ur problem for good. Its also less intrusive than Roxio which has a tendency to cause more system problems than u can ever imagine not to mention that Nero is way stable than Roxio.

Optionally you can uninstall Roxio after going into Safe Mode, then delete any directories containing the name Roxio on it. Start Regedit and check for any enteries having Roxio in front of it and delete it also. Make sure u backup ur registry b4 doing that. Then restart ur system and reinstall Roxio and see if that fixes ur problem. Also disable any other software running in the tray b4 u fire up Roxio just in case one of them is givin any probs.

Dan
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
zenportafinoAuthor Commented:
Tried deleting all "roxio" references in the registry - Nope. Called Dell and was on hold 1 hour waiting for "software support help" - forget it. Got a copy of Nero and installed. Works great. Roxio help and updates- absolutley pathetic!
0
zenportafinoAuthor Commented:
Note: This is the third time in two weeks that we have ordered a DVD/CDRW drive from dell. They send a Teac and it doesn't work so they send an NEC as a replacement. This is not the only time that we've had trouble with Roxio as well. Heads up to anyone out there struggling with a teac from dell!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.