?
Solved

Crystal Report Error "Unable to find the report in the manifest resources. Please build the project, and try again. "

Posted on 2005-03-02
5
Medium Priority
?
6,105 Views
Last Modified: 2008-01-09
Hello all.  I am having alot of trouble getting this to work.  I am creating my first Crystal report in ASP.Net.  I created the report using my connection information,  I then am using some code to sset the login information because I was getting a "Logon Falied" error.  Now everytime I am getting the Unable to find report in manifest error".  I tried alot of things already, the Build Action is already set to "Embedded Resource".  I tried adding the crystal references manually still no dice.  Any ideas?  It is bombing right at the For Each line in the code when trying to access the report tables.

[AT TOP]
Imports CrystalDecisions.CrystalReports.Engine
Imports CrystalDecisions.Shared


[Under the public class]
  Protected WithEvents CrystalReportsViewer1 As CrystalDecisions.Web.CrystalReportViewer

[In the Page_Load event]

 Dim crpt As CrystalReport1
        Dim myTable As CrystalDecisions.CrystalReports.Engine.Table
        Dim myLogin As CrystalDecisions.Shared.TableLogOnInfo
        Dim strAppUser As String = ConfigurationSettings.AppSettings("AppUser")
        If Not Page.IsPostBack Then

            crpt = New CrystalReport1
           
[Bombs on this line next the for line]
            For Each myTable In crpt.Database.Tables
                myLogin = myTable.LogOnInfo
                myLogin.ConnectionInfo.Password = "test"
                myLogin.ConnectionInfo.UserID = "sa"
            Next

            CrystalReportViewer1.ReportSource = crpt
End Sub


ERROR MESSAGE:

Unable to find the report in the manifest resources. Please build the project, and try again.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: CrystalDecisions.CrystalReports.Engine.InternalException: "Unable to find the report in the manifest resources. Please build the project, and try again.

Source Error:


Line 46:             crpt = New CrystalReport1
Line 47:
Line 48:             For Each myTable In crpt.Database.Tables
Line 49:                 myLogin = myTable.LogOnInfo
Line 50:                 myLogin.ConnectionInfo.Password = Passwords.GetAppUserPassword(strAppUser)
 

Source File: C:\Inetpub\wwwroot\BudgetForecast\BudgetMain.aspx.vb    Line: 48

Stack Trace:


[InternalException: "Unable to find the report in the manifest resources. Please build the project, and try again.]
   .F(String       , EngineExceptionErrorID 
)
   .B(String , Int32 )
   CrystalDecisions.CrystalReports.Engine.ReportClass.Load(String reportName, OpenReportMethod openMethod, Int16 parentJob)
   CrystalDecisions.CrystalReports.Engine.ReportDocument.'()
   CrystalDecisions.CrystalReports.Engine.ReportDocument.get_Database()
   AdminaStar.Budget.BudgetMain.Page_Load(Object sender, EventArgs e) in C:\Inetpub\wwwroot\BudgetForecast\BudgetMain.aspx.vb:48
   System.Web.UI.Control.OnLoad(EventArgs e)
   System.Web.UI.Control.LoadRecursive()
   System.Web.UI.Page.ProcessRequestMain()

 


0
Comment
Question by:sbornstein2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 11

Expert Comment

by:sachiek
ID: 13445745

Remove all the references of Crystal Report  and add again.
While adding  - add from their actual path  and not  from list of .Net components available,, click on browse go to actual location &  give the reference & recompile your application.

Sachi
0
 

Author Comment

by:sbornstein2
ID: 13445896
Did not work I already tried that and found that online as well.
0
 
LVL 11

Accepted Solution

by:
sachiek earned 250 total points
ID: 13446230
0
 

Author Comment

by:sbornstein2
ID: 13451137
None of this is the issue. This is what is happening.  It works fine in new separate solution.  I even totally rebuilt the solution I am having the problem in.  Same problem only in this solution.  I have tried everything.  I am thinking its a namespace issue or something.  Its about 5 projects all within 1 solution.  Any ideas?
0
 

Expert Comment

by:HansHuffman
ID: 14528665
Check your Namespaces - If you copied code from one project to another, check to see that you have the classes under the proper namespaces. Look in the Class Viewer: Are there classes in the wrong Namespaces?

That is the problem.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article discusses the ASP.NET AJAX ModalPopupExtender control. In this article we will show how to use the ModalPopupExtender control, how to display/show/call the ASP.NET AJAX ModalPopupExtender control from javascript, how to show/display/cal…
User art_snob (http://www.experts-exchange.com/M_6114203.html) encountered strange behavior of Android Web browser on his Mobile Web site. It took a while to find the true cause. It happens so, that the Android Web browser (at least up to OS ver. 2.…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Suggested Courses

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question