• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1311
  • Last Modified:

403 Forbidden error - phpmyadmin and phpadsnew

I am running apache on a Linux Red Hat Enterprise AS server.

I have php installed and mysql.  I also installed phpnuke with no problems and it works perfectly.  

When I tried to install phpmyadmin and another module called phpadsnew, I keep getting a 403 forbidden error that reads:

You do not have permissions to access this page.

The configs for each of the prgrams is correct - I checked and double checked.

There must be something else that is causing this problem, but I cannot for the life of me figure out what it is.

The error log simply reads:  permission denied.

Please help!!!
2 Solutions
did you install phpmyadmin while loged in as a different user? or as root?

In your httpd.conf did you define that index.php can be a directory index file?
foreverditaAuthor Commented:

aND YES, INDEX.PHP IS defined as a directory index file.
Without more information its hard for me to troubleshoot, but I'll shoot of a couple more suggestions:

Check directory/index file permissions, chmod 755 <file/directory> if necessary. Make sure group and world have read and execute rights.

Check directory's for .htaccess files that may be configured incorrectly.

Wish I could be more helpful!
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

foreverditaAuthor Commented:
yes, the file permissions are set correctly.  

Group and world have read and execute rights as well.

no htaccess files at all right now in the directories.

apache is set as user in the httpd.conf file.  Should I change the user to root?
If httpd.conf was setup incorrectly in that manner you wouldn't be able to browse phpnuke either, i'd assume...but it wouldn't hurt to much in trying! dont forget to restart httpd if you make changes to the conf.

Out of curiosity: What browser are you using and what are you typing in the URL when you get the error?
Did you install php as CGI or as Apache Module.

PHP-CGI needs different rights when using it with suexec.

When it's an CGI you need to set the file to the same owner who is executing it
(i.e. defining USER Directive in VirtualHost)

it seems to me like you have the CGI Version - please check it

more on suexec:

maybe suphp is also interesting (but i would recommend more experience):
foreverditaAuthor Commented:
Ok, this is totally bizarre, but apparantly, the system did not like how I unpacked the tar files into their directory.  I dragged them with the mouse rather than extracting them to the folder.

When I extracted them correctly, everything worked fine.  Just in case anyone else comes across this strange error and doesn't know why it is caused.  : )

Thanks for the responses!
Bizarre as this is, I just experienced the same thing --- copying via drag and drop gave this 403 error.
removed the directory and unzipped it directly and it works fine.

Reproduced using RHEL 6 Beta and phpMyAdmin 3.3.7

Thanks foreverdita!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now