Hard Drive partition problem

When installing Fedora Core 3 on my box I chose a cutom. I set up a partition to use xfs and it was supposed to be /dev/hda5/video but I don't see that partiton and am not able to mount it can someone help me out? Here is a snapshot of the disk geometry.

[root@myth ~]# parted  /dev/hda/ print
Disk geometry for /dev/hda: 0.000-156334.500 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031    101.975  primary   ext3        boot
2        101.975    611.850  primary   linux-swap
3        611.851  11358.457  primary   ext3
4      11358.457 156327.824  extended              lba
5      11358.488 156327.824  logical   xfs
Information: Don't forget to update /etc/fstab, if necessary.

LVL 8
ampapaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ampapaAuthor Commented:
It should look like this:

Partition        Mount Point        Size        Format
/dev/hda1      /boot      50-100MB      ext3
/dev/hda2      swap      same as RAM (ex: 512MB)      swap
/dev/hda3      /      8-12GB      ext3
/dev/hda5      /video      Everything else      xfs
0
ampapaAuthor Commented:
This is what I see in FDISK:

Disk /dev/hda: 163.9 GB, 163928604672 bytes
255 heads, 63 sectors/track, 19929 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1          13      104391   83  Linux
/dev/hda2              14          78      522112+  82  Linux swap
/dev/hda3              79        1448    11004525   83  Linux
/dev/hda4            1449       19929   148448632+   f  W95 Ext'd (LBA)
/dev/hda5            1449       19929   148448601   83  Linux


This is the error when I try yo mount hda5 -

[root@myth ~]# mount /dev/hda5
mount: can't find /dev/hda5 in /etc/fstab or /etc/mtab
0
jlevieCommented:
What happens if you try 'mount -t xfs /dev/hda5 /video' (the /video directory must already exist)?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

ampapaAuthor Commented:
I get.

[root@myth ~]# mount -t xfs /dev/hda5 /video
mount: mount point /video does not exist

This partition existed before I reinstalled on top of it. I was pretty sure I mirrored what was there before.
0
jlevieCommented:
Execute 'mkdir /video' and retry the mount command.
0
ampapaAuthor Commented:
I'm at the office currently so I'll have to wait until this evening to give this a try. Thanks.

How will mkdir know what partition to create the /video directory in? Won't it want to create that directory in the root partition as opposed to the xfs partition?

I'm still pretty fuzzy on linux. So, i'm trying to get a grip of the in's and out's...
0
jlevieCommented:
Mount was complaining that the directory that would be the mount point didn't exist. I don't know if there's and XFS file system on hda5 or not, the mount didn't get that far.

/video isn't associated with the file system on hda5, but rather with where that FS will appear in the systems name space. You can mount a file system anywhere, providing the mount point exists. For example, if you execute 'mkdir /home/some-user/video-files' you could then execute 'mount /dev/hda5 /home/some-user/video-files' and have that data appear at that point in the file system.
0
ampapaAuthor Commented:
After trying the new dir  'mkdir /video'

[root@myth ~]# mkdir /video
You have new mail in /var/spool/mail/root

I re-ran 'mount -t xfs /dev/hda5 /video' but am unsure how to verify if in fact this worked?


0
jlevieCommented:
If the mount command did not produce an error message and 'df' shows a line for hda5  mounted on /video, then it worked.
0
ampapaAuthor Commented:
Will this process need to be repeated on a reboot or will it remain until unmounted?

0
ampapaAuthor Commented:
jlevie, anyway to make this permanent on reboots?
0
jlevieCommented:
You can modify /etc/fstab to automatically mount the file system at boot, something like:

/dev/hda5         /video      xfs  defaults  1 2
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.