• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 363
  • Last Modified:

msado15.dll stop working after moving to Windows XP SP2

Currently I use this line in my global.asa
<!-- METADATA TYPE="TypeLib" FILE="C:\Program Files\Common Files\system\ado\msado15.dll" -->

My asp codes work perfectly with Windows 2000 Server. After I copied it to my notebook running Windows XP SP2 then it stopped working, it kept giving me the error:

800a01f4
variable is underfined 'adCmdText'

I can work around this error by including the adovbs.inc on every page, but want to know how to make it work with the  METADATA TYPE library method.

I have search everywhere on the net without a real solution. Please give me the working solution if you have experienced the same problem and have found the way to fix it.

Thanks

0
andreni78
Asked:
andreni78
  • 3
  • 3
1 Solution
 
andreni78Author Commented:
FYI: I have PWS installed on my Windows XP SP2.
0
 
coopzzCommented:
<!-- METADATA TYPE="TypeLib" FILE="C:\Program Files\Common Files\system\ado\msador15.dll" -->

try that one.
0
 
andreni78Author Commented:
no, that does not work. i still get the same message. Does any one out there got the same problem whem moving to XP SP2?
my code works fine on Windows 2000 and 2003 Server.

Again my environment on my note book as follow:

-IIS on Windows XP SP2 running Multisite ASAPI
-SQL Server 2000 Desktop Edtion

Thanks
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
coopzzCommented:
ok your original metadata tag worked fine  for me on my xp sp2 puter..

Have you installed the MS MDAC  i think 2.7 or 2.8..
http://www.microsoft.com/downloads/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&displaylang=en

the only other thing is to check to see if that file is sitting where it is pointing too.  if not then it;s most probably not installed or your windows in on another drive..

CooPzZ
0
 
coopzzCommented:
so how'd ya go?
0
 
andreni78Author Commented:
the file is there, all versions and none work. It is strange. I have to include the include file or copy the const i need for it to work

0
 
PAQ_ManCommented:
PAQed with points refunded (500)

PAQ_Man
Community Support Moderator
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now