?
Solved

msado15.dll stop working after moving to Windows XP SP2

Posted on 2005-03-04
8
Medium Priority
?
362 Views
Last Modified: 2008-01-09
Currently I use this line in my global.asa
<!-- METADATA TYPE="TypeLib" FILE="C:\Program Files\Common Files\system\ado\msado15.dll" -->

My asp codes work perfectly with Windows 2000 Server. After I copied it to my notebook running Windows XP SP2 then it stopped working, it kept giving me the error:

800a01f4
variable is underfined 'adCmdText'

I can work around this error by including the adovbs.inc on every page, but want to know how to make it work with the  METADATA TYPE library method.

I have search everywhere on the net without a real solution. Please give me the working solution if you have experienced the same problem and have found the way to fix it.

Thanks

0
Comment
Question by:andreni78
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
8 Comments
 

Author Comment

by:andreni78
ID: 13459158
FYI: I have PWS installed on my Windows XP SP2.
0
 
LVL 11

Expert Comment

by:coopzz
ID: 13459289
<!-- METADATA TYPE="TypeLib" FILE="C:\Program Files\Common Files\system\ado\msador15.dll" -->

try that one.
0
 

Author Comment

by:andreni78
ID: 13472818
no, that does not work. i still get the same message. Does any one out there got the same problem whem moving to XP SP2?
my code works fine on Windows 2000 and 2003 Server.

Again my environment on my note book as follow:

-IIS on Windows XP SP2 running Multisite ASAPI
-SQL Server 2000 Desktop Edtion

Thanks
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 11

Expert Comment

by:coopzz
ID: 13474833
ok your original metadata tag worked fine  for me on my xp sp2 puter..

Have you installed the MS MDAC  i think 2.7 or 2.8..
http://www.microsoft.com/downloads/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&displaylang=en

the only other thing is to check to see if that file is sitting where it is pointing too.  if not then it;s most probably not installed or your windows in on another drive..

CooPzZ
0
 
LVL 11

Expert Comment

by:coopzz
ID: 13494223
so how'd ya go?
0
 

Author Comment

by:andreni78
ID: 14033417
the file is there, all versions and none work. It is strange. I have to include the include file or copy the const i need for it to work

0
 

Accepted Solution

by:
PAQ_Man earned 0 total points
ID: 14922219
PAQed with points refunded (500)

PAQ_Man
Community Support Moderator
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I would like to start this tip/trick by saying Thank You, to all who said that this could not be done, as it forced me to make sure that it could be accomplished. :) To start, I want to make sure everyone understands the importance of utilizing p…
Have you ever needed to get an ASP script to wait for a while? I have, just to let something else happen. Or in my case, to allow other stuff to happen while I was murdering my MySQL database with an update. The Original Issue This was written…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
Suggested Courses

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question