• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 9794
  • Last Modified:

Exchange 2003, External outgoing mail stuck in queue

Hi, just a single server setup, Win2003, Ex2003, and everything used to be working for over a year. Had to upgrade to the latest service pack, as there was a problem with starting ESM, and since then, no mail will leave the local queue when sent to external addresses. Internal mail works just fine, and incoming mail is fine as well - it's solely getting mail to external addresses. I've tried looking around for a few hours, tried some troubleshooting pages around the net, and everything /seems/ fine - but it's not, obviously, hence my post here.  I'm not exactly Mr.Exchange, but I'd appreciate any ideas from those who are (or Mrs., of course :).

Thanks for any help in advance. Any info you need, just let me know.
0
wysardry
Asked:
wysardry
  • 5
  • 4
1 Solution
 
jodypeetCommented:
You've got a spam filter program installed huh. And the jamming is caused by html formatted mail .
Seen exactly this problem on 2003 , using GFI MailEssentials. They report it's due to a "malformed" html message.
If this is the case, uninstall the GFI component. (stopping the service doesn't fix it) .
0
 
ihotdeskCommented:
Hi,

Are you using a smart host to send your mails on?  (i.e. via your ISP's SMTP Server)??
Also are you using an SMTP Connector, or just via the standard SMTP Virtual Server?
Whilst you are it check the DNS Server that your mail server is using, ensure that you can resolve external domain names from this box.  
Do this from a command prompt, esnure you flush the cache to make sure you dont have a stagnant address somewhere.

To be honest my gut instinct is DNS (most likely) or a SmartHost issue.

Are the undelivered mails still in the queue?  If so click on the mail in ESM, and at the bottom of the window in the grey area, it should give you a status message regarding the queue, this may at leats point you in the right direction.

Give us a shout if you have any questions



Tony
0
 
wysardryAuthor Commented:
jodypeet: nope, no spam filtering at all; I'd like to get some of the GFI stuff, but that's reserved for future paychecks :)

jhotdesk: no smart host that I can see, it is using an SMTP connector, which I've tried with and without - it's address settings are SMTP/*/1 - do I actually need any connectors if it's just sending mail out by itself? It's always been in there, but that was one of the things suggested to possibly be the problem on one of the sites I found previously. I tried removing it (does something need to be restarted at that point?), but it still didn't work.

nslookup seems just fine, no errors there

There's a lot of test messages and mail from the past week in the queue; the only status listed for any of it is:
"The remote server did not respond to a connection attempt"

....which really throws me off, since there's no remote servers being used to send mail.

I was able to set up message tracking, though I'm not sure that tells much either; the final step in that sequence is:
04/03/2005  3:15PM  SMTP:Message Routed and Queued for Remote Delivery

...and that's as far as it every gets.

Sorry that I'm not much help - I really haven't used Exchange all that much yet.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
jodypeetCommented:
ok then , it sounds like a dns issue.
are you using isa or proxy ?
can you browse webpages on the server ?
0
 
wysardryAuthor Commented:
Yep, everything seems fine on the server; I use it all the time for looking things up when my other system is busy. No ISA, no proxy, just a Netgear 4-port router that's it's behind - and always has been (only meaning that it's always worked behind the router).

On your prompting though, the DNS log was having errors, the last one being recorded on the 4th;

EvtID: 5504 Source: DNS

The DNS Server has encountered an invalid domain name in a packet from 192.168.2.1. The packet will be rejected. The event data contains the DNS packet.

I can't find /anything/ useful about this error. I'll send some more test messages out, to see if I can correlate this error with the outbound mail.
0
 
jodypeetCommented:
is your domain name domain.local by chance ?
have you set the domain name in exchange to be just "domain.com" without the .local ?
forwarders setup in dns correctly ?
0
 
wysardryAuthor Commented:
domain's not that - it's my actual domain

the exchange FQDN was boxname.domain.com , so I swapped it to domain.com , but it's still not sending out (unless I have to restart something?)

dns itself is set up for the box, and I can use it from another box for lookups... i'm not quite sure what forwarders are specifically, but DNS /seems/ to be functioning just fine, as far as i can tell...?
0
 
jodypeetCommented:
In DNS Manager, right click the server and choose properties.
in the window that pops up you'll see a "forwarders" tab.
there should be an external DNS server ip address in there (your isp's DNS server's address)

this works like this.
i ask your server where mail.experts-exchange.com is , if it doesn't know the answer , it forwards the lookup request to your ISP's DNS server which returns the answer, then i can send email to it.
0
 
jodypeetCommented:
If that doesn't fix it try setting up a smarthost which will send all mail to smtp.yourisp.com
if that fixes it , it may give an indication as to what we need to concentrate on
0
 
wysardryAuthor Commented:
I am an idiot - sorry for the delay in replying. I'm between internet connections right now, as my cablemodem has been sucking for weeks, so I grabbed a DSL line until it's fixed. Our DSL provider (Sympatico, in Canada - lousiest service, customer service, shipping, organization, and user-allowances EVER) doesn't allow mail to be sent or received from their service. I was using port 2525 there for awhile (I've had to use them for quite some time now, long story) but seems tha they actively watch for this stuff, and killed off sending again. Just a complete brainloss moment for me.

Thanks for all the replies!
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now