?
Solved

GZIP and TAR Command will not work

Posted on 2005-03-05
2
Medium Priority
?
1,181 Views
Last Modified: 2011-09-20
I am using trying to use the command gzip as stated below and the error message is stated under the command:
gzip -d binutils-2.15-m68hc1x-20040801.diffs.gz
gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error exit delayed from previous errors

and if I try the command tar xvzf below
tar xvzf binutils-2.15-m68hc1x-20040801.diffs
gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error exit delayed from previous errors

Can someone help me for the proper syntax so that I can proceed to load a GCC compiler on microcontroller from linux. I am running knoppix 3.7. thank
0
Comment
Question by:tupac1979
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 40

Accepted Solution

by:
jlevie earned 2000 total points
ID: 13469103
What does 'file binutils-2.15-m68hc1x-20040801.diffs.gz' say?

It might be that the file isn't actually in compressed format. In which case 'tar xvf binutils-2.15-m68hc1x-20040801.diffs.gz' might work. It could also be that  you have a corrupt file (bad download or corrupt on the download site).
0
 

Author Comment

by:tupac1979
ID: 13469111
thanks for the help I had the wrong file and it works now
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses
Course of the Month9 days, 9 hours left to enroll

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question