?
Solved

Cisco 2611 with slow cable internet

Posted on 2005-03-06
12
Medium Priority
?
1,101 Views
Last Modified: 2008-01-09
Hey everyone...I am having some connectivity issues with my cisco 2611 router... I have a 6meg down connection from my isp... and with my cisco 2611 router i am only dl at 1.5meg... Also... for some strange reason... when there is a big load on the router... for ex... constant speedtests.... the cisco suddenly drops the e0/0 connection... the activity light just stops and the cable modem keeps on going... so i know i'm not losing the signal from my isp... This problem goes away when i reset the cable modem and comes back later. I had a D-link router hooked up to it right before i connected the cisco router and i was getting the 6meg down connection...This is really annoying.. please help.. my configuration is

cable modem--->Cisco 2611 e0/0-->e0/1-------->Cisco 2950 /24 port switch ------>computers

here is my config file from my router... I can also post my config file from my switch if you would like.

Current configuration : 1102 bytes
!
! Last configuration change at 06:13:52 UTC Sun Mar 6 2005
! NVRAM config last updated at 05:54:15 UTC Sun Mar 6 2005
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
enable secret 5 $1$S50P$/pIPjRI1njfn78m4Jh1NG1
!
username billy
ip subnet-zero
ip flow-cache feature-accelerate
ip cef
!
!
no ip dhcp conflict logging
!
!
!
!
interface Ethernet0/0
 description WAN CONNECTION
 ip address dhcp
 ip nat outside
 full-duplex
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 shutdown
 no fair-queue
 frame-relay lmi-type cisco
!
interface Ethernet0/1
 description LAN CONNECTION
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 half-duplex
!
router rip
 version 2
 network 192.168.1.0
!
ip nat inside source list 1 interface Ethernet0/0 overload
ip classless
ip http server
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
line con 0
 exec-timeout 0 0
 password 7 094E4705151C
 logging synchronous
 login
line aux 0
line vty 0 4
 password 7 14151B07001D
 login
line vty 5 15
 login
!
end

AND HERE IS MY SHOW INTERFACE OUTPUT

Ethernet0/0 is up, line protocol is up
  Hardware is AmdP2, address is 0030.1941.fc20 (bia 0030.1941.fc20)
  Description: WAN CONNECTION
  Internet address is 67.162.XXX.73/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:02, output hang never
  Last clearing of "show interface" counters 02:18:46
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 16000 bits/sec, 31 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     256067 packets input, 26001604 bytes, 0 no buffer
     Received 243762 broadcasts, 0 runts, 0 giants, 0 throttles
     394 input errors, 394 CRC, 201 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     11981 packets output, 5946168 bytes, 0 underruns(0/0/0)
     11 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     11 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Serial0/0 is administratively down, line protocol is down
 *****omited serial data since not in use*****

Ethernet0/1 is up, line protocol is up
  Hardware is AmdP2, address is 0030.1941.fc21 (bia 0030.1941.fc21)
  Description: LAN CONNECTION
  Internet address is 192.168.1.1/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:02, output hang never
  Last clearing of "show interface" counters 02:20:36
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     11783 packets input, 5969531 bytes, 0 no buffer
     Received 584 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     13436 packets output, 10887261 bytes, 0 underruns(73/67/0)
     0 output errors, 140 collisions, 0 interface resets
     0 babbles, 0 late collision, 506 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out


0
Comment
Question by:every1isevil
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 3
12 Comments
 
LVL 13

Assisted Solution

by:Dr-IP
Dr-IP earned 1000 total points
ID: 13470260
Ethernet0/0 is up, line protocol is up
394 input errors, <394 CRC>,< 201 frame>, 0 overrun, 0 ignore

Since you are seeing frame, and CRC errors in interface 0/0, that would indicate a possible mismatch with the interface on the modem, issue the following commands.

config t
interface Ethernet0/0
half-duplex
write
clear counters
Acknowledge with yes

Then surf the internet for awhile and do show interfaces again and see if you are still getting a lot of those errors.

0
 
LVL 13

Expert Comment

by:Dr-IP
ID: 13470303
One thing that I have found that make a router more responsive when used like you are doing it, is to figure out the default gateway and hard code it in. The best way is to do a trace from the router and look for the next hop and hard code it in.

USA1>trace www.yahoo.com
Translating "www.yahoo.com"...domain server (201.203.208.9) [OK]

Type escape sequence to abort.
Tracing the route to www.yahoo.akadns.net (68.142.226.34)

  1 10.10.99.49 4 msec
  2 10.10.3.254 4 msec 4 msec 8 msec
3 etc and so on

In this case the next hop was 10.10.99.49, so you would add the route in for this, and remove the old one.

config t
ip route 0.0.0.0 0.0.0.0 10.10.99.49
no ip route 0.0.0.0 0.0.0.0 Ethernet0/0
end
write

The bad part about this is if you end up on another subnet, you will have to revert back to the way it is now, and redo this again. The good part is most times that rarely happens, as most cable operators use only one subnet per cable segment, and rarely change it.  

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 13470455
256067 packets input, 26001604 bytes, 0 no buffer
     Received 243762 broadcasts, 0 runts, 0 giants, 0 throttles

Something that's REALLY interesting is that on the interface coming from the cable modem, 95% of the inbound traffic is broadcast.

I'd be curious what that traffic is.

-Don
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 13

Expert Comment

by:Dr-IP
ID: 13470754
I saw that too, it’s probably some infected computers on the cable segment he is on spewing out trash. One person I know had it get so bad he was getting over a meg of trash coming in before he complained and the cable company blocked the connections of those who were causing the problem.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 13470784
Yeah, that's possible.

If that's it, then it could be contributing to the slow d/l performance.

Maybe a "debug ip packet" for a moment and see what those packets are.

-Don
0
 
LVL 1

Author Comment

by:every1isevil
ID: 13471744
well.... i know it's not my internet connection.... I am currently connected to my dlink router and went to dslreports.com and got the following results.

2005-03-06 15:07:00 EST: 4787 / 708
Your download speed : 4902593 bps, or 4787 kbps.
A 598.4 KB/sec transfer rate.
Your upload speed : 725338 bps, or 708 kbps.

I don't get anywhere near this when I am connected to the router..... If i change all my ports to connected to the router.. will that affect my performance?? or will i not know the difference??
0
 
LVL 1

Author Comment

by:every1isevil
ID: 13472570
UPDATE... I connected the router to the switch instead of the cable modem and changed the settings around so i can still use my Dlink as my gatway to the internet... I connected my laptop directly to the router...my new temp config is like this

cable modem --->Dlink VOIP gateway/router ----->Cisco 2950 switch ---->computers
                                                                         Cisco 2950 switch --->2611 Router ----> Laptop

Now when i do bandwidth tests i get full strength... Anyone know why that would be???
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 1000 total points
ID: 13472593
So this works:

cable modem --->Dlink VOIP gateway/router ----->Cisco 2950 switch ---->computers
                                                                         Cisco 2950 switch --->2611 Router ----> Laptop

And this doesn't:

cable modem --->2611 Router ----->Cisco 2950 switch ---->computers
                                                       Cisco 2950 switch --->Laptop

I'm still thinking that you've got a duplex mismatch between the 2611 and the cable modem.

Have you set the e0/0 interface to half duplex yet?

-Don

0
 
LVL 1

Author Comment

by:every1isevil
ID: 13472642
well i haven't been able to test it since this morning because my sisters are nagging me that they need the internet to do homework... so as soon as i get a chance... I will connect the router back up to being the first device.. I already set the port to half duplex but haven't tested it out.. I will post my results as soon as soon as i get a chance.
0
 
LVL 1

Author Comment

by:every1isevil
ID: 13472802
IT WORKS NOW!!!!! I LOVE YOU GUYS... I DON'T KNOW WHAT I WOULD DO WITHOUT YOU....... I was my duplex problem in e0/0... I wonder why it does that... is there any way i can get everything to work on full-duplex??? is it the IOS i am using?(12.2(3))... Well hopefully this fixes the problem i had with the router dropping my e0/0 connection. If it is ok with you guys... I would like to split the points 50/50 since you both helped me find the solution.... thanks again for all your help. I actually have some more questions if you guys want to earn more points...I will post links to the questions on here after i create them.

Thanks.
0
 
LVL 13

Expert Comment

by:Dr-IP
ID: 13472966
The vast majority of cable and ADSL modems have only 10 Meg half duplex Ethernet ports. Some have 100 Meg half duplex ports, but I have not seen any with full duplex ports. If your modem has a 10-100 Meg port, you might get better performance by running it through a switch so you can have full duplex on the router, and 100 Megs half duplex on the modem, and let the router do the conversion between the two. Since you have a 2950, you can create a VLAN on two of the ports for this, which in effect will make those two ports act like a separate switch.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question