Tosh Tecra S1 various devices fail

Hi all

My Toshiba Tecra S1 laptop (XP Pro) refused to boot, came up with a missing windows\system directory error.  I ran XP recovery console from CD, logged into Windows, browsed the directories, all seemed OK, so before trying any changes I just rebooted the machine and it was fine.

Few days later it happened again, so I did exactly the same thing.

When the machine rebooted (again, with no problems) the trackpad and USB mouse failed to work.  Opened Device Manager to find some new "Unknown" devices listed.  These are the PCI Modem, Alps Pointing Device, and USB Intellipoint mouse.

I tried updating drivers, no joy.  Tried deleting them and restarting windows and letting them install creates "Device Error 10 - device was unable to start."

Toshiba replaced the main board, still no change.  They also found that both the trackpad, USB mouse AND pointy stick thing all work FINE in BIOS.  So gotta be a Windows error, not hardware.

Tried shutting machine down and restarting with a PS/2 mouse connected - now that also appears in Unknown Devices as a Standard PS/2 Port Mouse.

Tried re-installing drivers from the Tosh CD - they install OK but same error.

Left with the option of reinstalling Windows XP but don't have the product recovery CD.  Tosh want £35 for a new disk which is fine - except that it'll take FOUR WEEKS !

I do have an XP Pro installation CD, and I have the product key for the laptop, and the driver CD - but daren't try a fresh installation in case the recovery installation CD is different in some way.

Any advice on:

1) Way to fix at least the mouse - I can live without the modem and sound for four weeks but keyboard XP is driving me bonkers.

2) Installing Windows from a standard MS CD using the proper key for the laptop.  I don't even know if the original OS is OEM one but I suspect it is.

many thanks



Simon
LVL 1
SimonUKAsked:
Who is Participating?
 
SimonUKConnect With a Mentor Author Commented:
I will close this question: in the end a clean installation of the OS using the Toshiba recovery CD (which they sent me - and decided not to charge me for some reason - so a point to them!) fixed the problem.


Simon
0
 
ddrdanCommented:
Is this the driver update for the alps pointing device you used?
If not try it.
http://www.csd.toshiba.com/cgi-bin/tais/su/su_sc_dtlViewDL.jsp?soid=392540&moid=null&BV_SessionID=@@@@0623269109.1110268620@@@@&BV_EngineID=cccfaddedfjhdejcgfkceghdgngdgnj.0&ct=DL

Have u tried plugging the USB mouse in after the computer has started the OS? Try going to device manager and update the USB driver.

0
 
SimonUKAuthor Commented:
Hi, thanks

I downloaded the update you suggested and installed.  First time, it appeared to remove the old drivers so looked promising, but on reboot - no change.

So I removed the alps device from device manager and tried again.  This time an alps tray icon was created but the pad and stick still don't work.

Yes I've tried connecting the USB mouse after the machine is up and running (in fact that's what I normally do).

The USB ports work fine with a USB memory key so I didn't think reloading the USB drivers would help.

The machine still says "The device cannot start: Code 10" if you look at the alps device properties.  It has the device listed as connected to the PS/2 port, which is what I'd expect.

Any more suggestions?

thanks


Simon
0
All Courses

From novice to tech pro — start learning today.