?
Solved

Can't FTP (anymore) into UNIX server... "Retrieve of folder listing failed (0)"

Posted on 2005-03-07
6
Medium Priority
?
2,288 Views
Last Modified: 2013-12-23
I can't access my client's server anymore with FTP and I need your guys help to try and track down the problem.

I'm using WS_FTP to connect (worked before) to an ev1servers (formerly Rackshack) "virtual site"

Address: ftp.theoryi.com
ID: test123
PW: test123

It logins in successfully, when it tries to view the folder contents, I get a "Retrieve of folder listing failed (0)".

When I use Windows's "FTP" command, I get logged in correctly but when I do a "ls" command, I get a "Connection closed by host".

The strange thing is that there is another site that I have a "virtual site" with them and I don't get an errors with that one

Could you guys try it out and see if it works on your end?  Ev1servers was able to make a connection on their end, so I need to know whether it is something on my end.  I'm running Alltel DSL through a wireless network and using Windows XP Home.

Thanks!!
0
Comment
Question by:kirkhilles
  • 4
6 Comments
 
LVL 13

Accepted Solution

by:
gripe earned 1000 total points
ID: 13478967
It sounds like you need to enable passive mode FTP. When you do an ls command the FTP server attempts to make a connection back to an arbitrary port on your host and pass the list that way. Often firewalls/NAT setups get in the way of this. With passive, all of the connections are initiated from your own machine. I'm not sure if windows CLI ftp supports PASV (I'm pretty sure it doesn't) but WS_FTP definitely. It's likely under the proxy configuration. 'Enable PASV' or 'Enable Passive FTP'
0
 

Author Comment

by:kirkhilles
ID: 13479351
I've tried it on WS_FTP with Passive mode turned on and I still can't connect.  Could you give it a try on your machine and let me know if its something on my end or something on the host's end?

connecting to 216.40.242.25:21
Connected to 216.40.242.25 port 21
220 ProFTPD 1.2.5 Server (ProFTPD) [216.40.242.25]
USER test123
331 Password required for test123.
PASS (hidden)
230 User test123 logged in.
CWD /web
250 CWD command successful.
PWD
257 "/web" is current directory.
SYST
215 UNIX Type: L8
Host type (S): UNIX (standard)
PASV
227 Entering Passive Mode (216,40,242,25,15,124).
connecting to 216.40.242.25:3964
- -
connecting to 216.40.242.25:3964
! Connection failed 216.40.242.25 - connection timed out
! connect: error 0
PORT 192,168,1,101,6,128

! Receive error: connection reset

! Failed "port":
! Retrieve of folder listing failed (0)
0
 
LVL 21

Assisted Solution

by:tfewster
tfewster earned 1000 total points
ID: 13481675
I was able to connect to your client from home (WinXP Home command line ftp/ADSL router/ZoneAlarm personal firewall) no problem.
C:\>ftp 216.40.242.25
Connected to 216.40.242.25.
220 ProFTPD 1.2.5 Server (ProFTPD) [216.40.242.25]
User (216.40.242.25:(none)): test123
331 Password required for test123.
Password:
230 User test123 logged in.
ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for file list.
web
226 Transfer complete.
ftp: 5 bytes received in 0.00Seconds 5000.00Kbytes/sec.
ftp> pasv
Invalid command.
ftp> quit
---------------------------------

From your output:
> PASV
> 227 Entering Passive Mode (216,40,242,25,15,124).
> connecting to 216.40.242.25:3964

With Passive mode, the server says "I"ll be listening out on _this_ port for an incoming data connection" (instead of initiating a data connection from Port 20 on the server);  So your local firewall needs to allow your ftp client to connect out using that port (3964 in this case) and the host-end firewall has to allow an incoming connection on 3964.
See http://slacksite.com/other/ftp.html for a good explanation of the connection method(s) and a discussion of Active v. Passive ftp.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:kirkhilles
ID: 13482566
I disabled the Windows XP firewall and don't have another firewall installed.

What I can I do to try to resolve this? Is it likely Alltel that has blocked a port? Is there a way to test whether Windows is somehow blocking it (I tried it on 2 systems and neither worked, though)?

Thanks
0
 

Author Comment

by:kirkhilles
ID: 13483072
There's a twist....

Okay, I've tracked down the issue.  It works fine when I "dial up" directly with my DSL, but *NOT* when I connect up through my wireless router (Linksys wireless router with signal amplifier) through the wireless connection or by connection up directly to the router (it has a 4 port router built in).

Any ideas on why (or how to change it) the wireless router would do this?

Thanks!!
0
 

Author Comment

by:kirkhilles
ID: 13483393
Somehow I fixed it (I had installed the Alltel software, maybe it changed a setting), but thanks everyone for the help
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Make the most of your online learning experience.
This program is used to assist in finding and resolving common problems with wireless connections.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question