Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 482
  • Last Modified:

prngd dies after 4 minutes ssh

I'm loaded prngd and ssh on my system , I'm running sco 5.0.6., and I followed all the instructions on how to configure ssh to work on it but some how, as soon as I start the process 'prngd' it dies after 4 minutes.

While 'prngd' runs I'm able to ssh in and out , and sftp in and out with no problem whatsoever. But then when prngd dies I get "no connection error" while trying to get it, or PRNGD is not SEEDED.

Why is it getting killed ?

Here's my /usr/local/prngd/prngd.conf file :

"ls -alti /var/adm"             /bin/ls 0.02
"ls -alti /usr/spool/mail"      /bin/ls 0.03
"ls -alti /tmp"                 /bin/ls 0.02
"ls -alti /usr/tmp"             /bin/ls 0.02
"netstat -rn"                   /usr/bin/netstat 0.02
"netstat -ian"                  /usr/bin/netstat 0.05
"netstat -sn"                   /usr/bin/netstat 0.02
"ifconfig -a"                   /etc/ifconfig 0.02
"ps -al"                        /bin/ps 0.03
"ps -efl"                       /bin/ps 0.03
"last"                          /usr/bin/last 0.01
"df"                            /bin/df 0.01
"df -vi"                        /bin/df 0.01
"w"                             /usr/bin/w 0.02
"who -a"                        /bin/who 0.01
"uptime"                        /usr/bin/uptime 0.01
"ipcs -a"                       /bin/ipcs 0.01
"tail -200 /var/adm/syslog"     /bin/tail 0.01


Thanks
0
henry007
Asked:
henry007
  • 2
1 Solution
 
gheistCommented:
prngd random pool is used at connect.
try sco.com/skunkware for newer SSH release ( which may not use prngd )
also check if all commands it uses execute succesfully.

I had this problem, and never solved it since some later sshd on some other OS dhad no need for prngd anymore.
0
 
henry007Author Commented:
yes all commands execute succesfully, If I run the spool using the debug flag all the time it never dies, it can stay working for ever, why in the world does it stop working after it finish doing the entropy ? It looks like as soon as it finishes the list of prngd.conf commands it ends. The debugger keeps the list repeating all over again .
0
 
gheistCommented:
first i read this
ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/INSTALL
then looked at this
ftp://ftp2.sco.com/pub/skunkware/osr5/vols/
after I dug up this
http://www.aet.tu-cottbus.de/personen/jaenicke/postfix_tls/ChangeLog

and came to conclusion that 0.9.23 may exit for non-obvious reasons

look for core dumps in /usr/local/var/prngd , and if this dir is writable by user prngd ???

As I said I had alike problem but never solved it, and I do not have anu installation of PRNGD or EGD around.

OpenSSH uses it via OpenSSL library, so OpenSSL may need some help too

0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now