Diskperf -y flag not sticking?

We use perfmon to monitor diskspace on various servers on our lan, now in order to remotely see disk counters (logical disk) you need to run the command "diskperf -y" from a command line.  However I'm seeing cases where on Windows 2000 server this setting is not permanent and we have to reset it every couple of days. Has anyone else seen this problem or have a solution. The only thing I can think is that we only run SP3 (for a variety o depressing reasons) and at the present time there is no chance of getting the upgrade to SP4 brought forward.
Who is Participating?
Nirmal SharmaConnect With a Mentor Solution ArchitectCommented:
>>>However I'm seeing cases where on Windows 2000 server this setting is not permanent and we have to reset it every couple of days.

You can create a batch file and allow this batch file to run when Windows Server computers are started from the following location in registry: -



from StartUp in Start Menu.
Nirmal SharmaSolution ArchitectCommented:
Are all the computers part of domain controller? if yes then create a batch file > process this batch file using Group Policy so it will keep sticking.
NacMacFeegleAuthor Commented:
We could do this but unfortunately a lot of these servers are missin critical and get reboots only once a week or less often. As the flag ony applies at boot up this means that even if we apply it with a GPO then it will not actually switch the diskperf counters back on until the server gets a reboot. I'll give it a go tho' Cheers - any one else got any ideas or seen it before?
Nirmal SharmaSolution ArchitectCommented:
Yes, It requires a reboot to activate the counter. I am not sure when the counters are initialized at the time of rebooting but you can do one thing you can manually kill explorer.exe and then start it again from Task Manager > New Task. If it is initialized by checking the registry entry then you don't need to reboot because when you kill explorer.exe and run it again it will re-read the registry...if it is initialized by the "Performance Logs and Alerts" service then you need to set service type = "Automatic"..so that when you run the Performance Tool the service will be started automatically and when the service is started it will initilize all the settings or it will load all the counters.

Give it a try and let me know.

Nirmal SharmaSolution ArchitectCommented:
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.