?
Solved

Can't Access Network File Shares

Posted on 2005-03-09
6
Medium Priority
?
226 Views
Last Modified: 2010-04-19
I have a single Windows Server 2003 box set up as the domain controller on our network.  This machine also acts as our fileserver.  Until recently, it has always worked with no problems whatsoever.  However, a couple days ago, one of the users did a hard reset of the server, and corrupted some files in the process.  Because of this, I had to do a repair (in-place) re-install of Windows.  I got everything up and running just fine.  Users are able to log into the domain, and everyone has full access to their Exchange e-mail (also on the same server).  However, we are unable to access any of our network shares.  Whenever I type the name of a network share to access, Windows comes back with a username and password prompt, even though I am logged into my machine as a domain administrator.  I try the usernames/passwords of several different users (other domain admins), and nothing works.  I have checked both the share permissions and NTFS permissions and can't find any problem there (they are the same as when they worked before the re-install).  I am even unable to access the shares while logged in locally to the server.  (I can access the folders through the filesystem, but not through the network share name).  Because of this, group policy is also not able to process, because none of the machines can read the SYSVOL share over the network.  Any help anyone could offer would be greatly appreciated.  
0
Comment
Question by:Cadefassett
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 96

Expert Comment

by:Lee W, MVP
ID: 13498960
Event Log messages?
0
 
LVL 1

Author Comment

by:Cadefassett
ID: 13499182
That's the weird thing.  The security log shows a "Success Audit" for every logon that I try, and no other messages show up in the event log.  So the credentials are being passed to the server, and authenticated successfully in Active Directory, but I am still unable to access the shares.  It just spits the password prompt back at me over and over again.
0
 
LVL 1

Author Comment

by:Cadefassett
ID: 13499209
I also just noticed that I get an "Access Denied" error message whenever I try to access certain administrative features.  I can add users to AD, and change group memberships, etc., but when I try to access the "Dial-in" tab, I get an access denied message.  I also get an acccess denied message whenever I try to administer WINS.
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
LVL 1

Assisted Solution

by:mustbconfused
mustbconfused earned 1000 total points
ID: 13499660
I would run chkdsk on the server. It will probably ask you to restart to run but it sounds like you may still have some corruption in the Fat table of the disk. chkdsk should fix it and repair damaged files. <--I would have recommended this before you rebuilt the server as well. You can also check shares by typing net share at the command prompt.

You can determine if a volume is dirty by using the fsutil dirty query command.
To query the dirty bit on drive C, type:
fsutil dirty query C:
Sample output:
Volume C: is dirty
or
Volume C: is not dirty

Hope this helped
0
 
LVL 1

Author Comment

by:Cadefassett
ID: 13499694
I did a chkdsk when I rebuilt the server.  But just to make sure, I just did an fsutil, and the query came back not dirty.

Another thing I have discovered: I recently tried unjoining the domain, and joining back to the domain, to see if something had gotten messed up with the computer accounts or something.  Now, when I try to join the computer to the domain, I get an access denied error, no matter what username I use to join.
0
 
LVL 1

Accepted Solution

by:
mustbconfused earned 1000 total points
ID: 13500252
Sounds like your SAM is corrupt. When you did the inplace repair did you press F8 when the server started up and choose Active Directory Repair? If not this may be why your SAM is not working correctly.

Another possibility is that your SID is the issue.
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Numerous times I have been asked this questions that what is it that makes my machine log on so slow, there have been cases where computers took 23 minute exactly after taking password and getting to the desktop. Interesting thing was the fact th…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question