?
Solved

VPN setup

Posted on 2005-03-09
5
Medium Priority
?
1,406 Views
Last Modified: 2013-11-16


Hi all,

after setting up vpn through PDM, which i dislike the more i use it, i find myself been able to log in through a vpn client, and not been able to do much. When i log in i cannot browse the inside lan, i cannot connect to the internet which i am not sure why as i thought only traffic going to lan would travel through tunnel, all other trafic go over net from where i made the vpn connection. I can also ping my outside firewall and get a echo reply which i dont want. I am pretty sure it has to do with the routes--split tunnels ??? to why all trafic is going over tunnel, b to do with access-list to why i cannot browse in lan, why outside returns a echo i have no idea. be grateful for any help, below is config. Also the PDM put a load of stuff in there which I am not so sure about, not sure if it is all needed crypto 20, 40, do i need both ???

Pix Noob

sh conf
: Saved
: Written by enable_15 at 23:39:59.404 UTC Tue Mar 8 2005
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password tyPUSvxxxxxx encrypted
passwd tyPUSv2xxxxxx encrypted
hostname 501
domain-name walsh
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outbound permit tcp any any eq 6668
access-list outbound permit udp any any eq 4500
access-list outbound permit udp any any eq isakmp
access-list outbound permit tcp any any eq ftp
access-list outbound permit tcp any any eq ssh
access-list outbound permit tcp any any eq 6881
access-list outbound permit udp any any range 14000 15000
access-list outbound permit udp any any eq 27951
access-list outbound permit udp any any eq 27960
access-list outbound permit udp any any eq 27243
access-list outbound permit tcp any any eq 27243
access-list outbound permit tcp any any eq 3410
access-list outbound permit tcp any any eq smtp
access-list outbound permit tcp any any eq pop3
access-list outbound permit tcp any any eq 5100
access-list outbound permit icmp any any
access-list outbound permit tcp any any eq 8080
access-list outbound permit tcp any any eq pptp
access-list outbound permit tcp any any eq https
access-list outbound permit tcp any any eq www
access-list outbound permit udp any any eq domain
access-list outbound deny ip any any
access-list inbound permit tcp any any eq 6881
access-list inbound permit tcp any any eq 3410
access-list inside_outbound_nat0_acl permit ip any 192.168.1.16 255.255.255.240
access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.16 255.255.255.240
access-list outside_cryptomap_dyn_40 permit ip any 192.168.1.16 255.255.255.240
pager lines 25
logging on
logging timestamp
logging trap debugging
logging queue 0
logging host inside 192.168.1.5
logging host inside 192.168.1.4
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool 192.168.1.20-192.168.1.26
pdm location 192.168.1.0 255.255.255.255 inside
pdm location 192.168.1.3 255.255.255.255 inside
pdm location 217.232.255.104 255.255.255.255 outside
pdm location 217.232.251.225 255.255.255.255 outside
pdm location 192.168.1.4 255.255.255.255 inside
pdm location 192.168.1.5 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group inbound in interface outside
access-group outbound in interface inside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server TACACS+ (inside) host 192.168.1.5 Breathnach timeout 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa-server Security protocol tacacs+
aaa-server Security max-failed-attempts 3
aaa-server Security deadtime 10
aaa-server Security (inside) host 192.168.1.5 Breathnach timeout 10
http server enable
http 192.168.1.1 255.255.255.255 inside
http 192.168.1.0 255.255.255.0 inside
snmp-server host inside 192.168.1.1
snmp-server host inside 192.168.1.4
snmp-server location Germany
snmp-server contact Hugh walsh
snmp-server community public
no snmp-server enable traps
tftp-server inside 192.168.1.5 tftp-root
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup Walsh address-pool vpnpool
vpngroup Walsh idle-time 1800
vpngroup Walsh password ********
telnet timeout 15
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 15
console timeout 0
vpdn group t-online request dialout pppoe
vpdn group t-online localname 000440678200xxxxxxxxxx@t-online.de
vpdn group t-online ppp authentication pap
vpdn username 000440678xxxxxxxxxx@t-online.de password ********
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd dns 194.25.2.129
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
username Hugh password dc9h2g.sxrtt3W7D encrypted privilege 15
terminal width 160
Cryptochecksum:59208b536b837a9b3cc8088129694297
501# sh route
      outside 0.0.0.0 0.0.0.0 217.5.98.172 1 PPPOE static
      inside 192.168.1.0 255.255.255.0 192.168.1.1 1 CONNECT static
      outside 217.232.246.130 255.255.255.255 217.232.246.130 1 CONNECT static
501# exit

 
0
Comment
Question by:huwa
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 13499538
>PDM, which i dislike the more i use it,
LOL! It's a "work in progress" at best...

I'm assuming you mean with the Cisco VPN client, not the Microsoft PPTP VPN client.....

>.When i log in i cannot browse the inside lan,
Let's fix this one by using a totally separate IP subnet for the Cisco VPN clients and clean up some of the other stuff.


no access-list inside_outbound_nat0_acl permit ip any 192.168.1.16 255.255.255.240
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.240
nat (inside) 0 access-list inside_outbound_nat0_acl
no ip local pool vpnpool 192.168.1.20-192.168.1.26
ip local pool CISCO 192.168.2.1 - 192.168.2.14
vpngroup Walsh address-pool CISCO

>i cannot connect to the internet which i am not sure why as i thought only traffic going to lan would travel through tunnel, all other trafic go over net from where i made the vpn connection.
ALL traffic goes through the tunnel by default unless and until you add split-tunneling for the local lan only (this part is easy with the GUI)

Add split-tunneling:
access-list split_tunnel_acl permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.240
vpngroup Walsh split-tunnel split_tunnel_acl

Done!
Happy VPN'ing!
0
 
LVL 2

Author Comment

by:huwa
ID: 13500997
Hi Irmoore,

Ah Microsoft PPTP and a lovely server/client GUI 10 minutes to set and open two ports and VPN I can. But I cant like it that much if i am here trying it with a PIX :-)

Ok I have done as you said above, it makes a connection to the server ( so group name/password working (VPN is Working) But when i try to authenticate user/password it kills connection. When I look in the cisco client 4.6.01.009(microsoft never had so many revision (bit like dont touch a running client :) ) log it reports "inbound connections not allowed" below is new conf. Also I can still ping PIX from outside this scares me more as i thought the pix was fairly locked down.

Thx


: Written by enable_15 at 21:48:17.085 UTC Wed Mar 9 2005
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password tyPUSv2B17vNI4BJ encrypted
passwd tyPUSv2B17vNI4BJ encrypted
hostname 501
domain-name walsh
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outbound permit tcp any any eq 6668
access-list outbound permit udp any any eq 4500
access-list outbound permit udp any any eq isakmp
access-list outbound permit tcp any any eq ftp
access-list outbound permit tcp any any eq ssh
access-list outbound permit tcp any any eq 6881
access-list outbound permit udp any any range 14000 15000
access-list outbound permit udp any any eq 27951
access-list outbound permit udp any any eq 27960
access-list outbound permit udp any any eq 27243
access-list outbound permit tcp any any eq 27243
access-list outbound permit tcp any any eq 3410
access-list outbound permit tcp any any eq smtp
access-list outbound permit tcp any any eq pop3
access-list outbound permit tcp any any eq 5100
access-list outbound permit icmp any any
access-list outbound permit tcp any any eq 8080
access-list outbound permit tcp any any eq pptp
access-list outbound permit tcp any any eq https
access-list outbound permit tcp any any eq www
access-list outbound permit udp any any eq domain
access-list outbound deny ip any any
access-list inbound permit tcp any any eq 6881
access-list inbound permit tcp any any eq 3410
access-list inbound deny icmp interface outside any
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.240
 
access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.16 255.255.255.240
access-list outside_cryptomap_dyn_40 permit ip any 192.168.1.16 255.255.255.240
access-list split_tunnel_acl permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.240
pager lines 50
logging on
logging timestamp
logging trap debugging
logging queue 0
logging host inside 192.168.1.5
logging host inside 192.168.1.4
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool 192.168.2.1-192.168.2.14
pdm location 192.168.1.0 255.255.255.255 inside
pdm location 192.168.1.3 255.255.255.255 inside

pdm location 192.168.1.4 255.255.255.255 inside
pdm location 192.168.1.5 255.255.255.255 inside

pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group inbound in interface outside
access-group outbound in interface inside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server TACACS+ (inside) host 192.168.1.5 Breathnach timeout 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa-server Security protocol tacacs+
aaa-server Security max-failed-attempts 3
aaa-server Security deadtime 10
aaa-server Security (inside) host 192.168.1.5 Breathnach timeout 10
http server enable
http 192.168.1.1 255.255.255.255 inside
http 192.168.1.0 255.255.255.0 inside
snmp-server host inside 192.168.1.1
snmp-server host inside 192.168.1.4
snmp-server location Germany
snmp-server contact Hugh walsh
snmp-server community public
no snmp-server enable traps
tftp-server inside 192.168.1.5 tftp-root
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup Walsh address-pool vpnpool
vpngroup Walsh split-tunnel split_tunnel_acl
vpngroup Walsh idle-time 1800
vpngroup Walsh password ********
telnet timeout 15
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 15
console timeout 0
vpdn group t-online request dialout pppoe
vpdn group t-online localname 000440678200520xxxxxxxxxxxxx@t-online.de
vpdn group t-online ppp authentication pap
vpdn username 00044067820052xxxxxxxxxx@t-online.de password ********
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd dns 194.25.2.129
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
username Hugh password xxxxxxxxxxxxxx encrypted privilege 15
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 1000 total points
ID: 13501358
Getting closer, no?

I think we need to change one more acl..
no access-list outside_cryptomap_dyn_40

no crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
no crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5

no access-list outside_cryptomap_dyn_20
access-list access-list outside_cryptomap_dyn_20 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.240

Use the "icmp" commands to stop the outside IP from responding to ping. It is enabled by default.

0
 
LVL 2

Author Comment

by:huwa
ID: 13501531
Great Work, Irmoore.

Now I really need to take time out and learn more about networking and PIX, and read a manual or two.

Thx again :-)
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13503240
Glad to help!
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question