?
Solved

server xi installation problem

Posted on 2005-03-10
9
Medium Priority
?
875 Views
Last Modified: 2012-06-27
First let me say I already had crystal reports server installed (version 10) - yesterday I installed crystal reports xi (not the server though) - now today NO ONE can login to the crystal web desktop - they get Microsoft JScript runtime error '0x800A01AD'

Automation server can't create object
line: 3271
just going to the page NEVER even to the login page - HOWEVER

The crystal enterprise Management server still logins fine - so I have ONLY the server management as a means for anyone to see reports and I don't want to do that.

THEREFORE I am trying to run the xi server installation and hoping the new version will fix this???  I have NEVER had this problem we were FINE until this morning.  

*I have rebooted the server
*Ensured that the SQLServer is running
*Ensured that I can get in as the admin
*H    E    L   ......................P


I am installing report server xi and at the screen to provide sql authentication mode if I choose windows NT and use my nt administrator account and password (THIS IS on the server and I am the admin) I get :

Cannot get the server roles name - make sure the server is running and the authentication information is correct

I know that I have correct authentication information but can't figure out what server running issue I am facing - Please help!!!

Susan
0
Comment
Question by:NewAttitude
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 2
9 Comments
 
LVL 26

Expert Comment

by:Kurt Reinhardt
ID: 13507679
There is no Crystal Reports Server for Version 10 - it's a new product in the XI line.  Did you have a version of Crystal Enterprise?  If so, what version?

Also, you're generally not allowed to move from Enterprise to Crystal Reports server or vice versa.

Lastly, if you install both Business Objects Enterprise XI or Crystal Reports Server (identical to Enterprise Pro, but with different licensing restrictions) and Crystal Reports XI, you must install the server product first!  This is documented in the various help files.  If you don't, you will have problems.

I wish I had a better answer for you:(  I, too have had some difficulties with Crystal Reports Server and XI.  I was part of the beta test for XI Enteprise and Crystal Reports XI.  They both installed great and worked great.  Unfortunatley, when I uninstalled them they broke something in Visual Studio .net 2003 Enterprise.  Also, I've since downloaded Crystal Reports Server and can only access it via the CMC.  Even when I log out of the CMC, it throws an error.

~Kurt

0
 

Author Comment

by:NewAttitude
ID: 13508088
yes I had Enterprise version 10.0.0.388


I can login to it with admin but NO users

To make it worse I can NOT get the new version to install as per above

I would LOVE to figure out what happened that is not allowing people into the enterprise version :)
0
 

Author Comment

by:NewAttitude
ID: 13508434
The error we get when trying to launch the web 'desktop'

there was an error retrieving data from the server - automation server can't create object

0
On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

 

Author Comment

by:NewAttitude
ID: 13508685
During the Xi Server install for it I can't get it to get past the screen SQL authentication mode  furthermore - to make matters worse I can't even remember HOW to get into settings to lookup users or anything for the MSSQL server that I have installed on my windows 2003 standard edition server???

I am have a B A D day :)
0
 

Author Comment

by:NewAttitude
ID: 13557503
I am installing report server xi and at the screen to provide sql authentication mode if I choose windows NT and use my nt administrator account and password (THIS IS on the server and I am the admin) I get :

Cannot get the server roles name - make sure the server is running and the authentication information is correct

I know that I have correct authentication information but can't figure out what server running issue I am facing - Please help!!!

Susan
 
0
 
LVL 26

Accepted Solution

by:
Kurt Reinhardt earned 2000 total points
ID: 13561511
NewAttitude, I just ran into that problem last night.  I installed CR Server on a clean server and received the exact same error.  I looked in SQL Server and found that my user ID wasn't explicitly listed under the System Administrator's Role.  I am part of two groups, however, that are mapped in SQL Server - each of which is assigned to different roles.  I just went with SA, installed everything fine, and called it a night...

~Kurt
0
 

Author Comment

by:NewAttitude
ID: 13563391
Ok - I got the installation to complete NOW it wants me to "LOGIN" to 'xdb' and I used the login I PROVIDED as Administrator - DOESN"T WORK - ALSO tried sa HELLLLLPPPPP I HAVE to be LIVE in an HOUR - users coming in and will be ScREAMING

Thx as usual,

Susan
0
 

Author Comment

by:NewAttitude
ID: 13563437
Ok to be more specific this is at the end of the installation it states to login to the admin launchpad

http://dedicated:8080/businessobjects/enterprise11/adminlaunch/

I can't successfully LOGIN - I can't believe the problems - prior enterprise servers were SO EASY what is WRONG with ME!

Susan

thanx Kurt for the help - when I get all this resolved I promise NOT to forget to award points :)

0
 

Author Comment

by:NewAttitude
ID: 13563638
NEW update - I went to services and the management service "SET TO AUTOMATIC" starting was NOT running - I manually fired it (after a reboot) and appear to be logging in successfully - THANK YOU - I HOPE I am going to be all set now - I have to go try and get all the users reports back in their folders - I had to uninstall the old version of enterprise and do a new install to get it working - thus I seem to NOT have the ability to bring in all the existing objects - so off I run to the rat race :)  

P.S...... I have a question open on ASP - Crystal - WOULD LOVE some input!!!!!

Susan

eternally grateful as usual to EXPERTS EXCHANGE - MY LIFE saver, salvation, and BEST EVER resource for tech data ;)

WISH that experts exchange would add a "CODE CHARGE" link in the web dev. section as this is the best and easiest asp program I could dream of - I am an Oracle dba (past 18 years) and now am into the 'programming' arena and code charge made MY life so easy

I am rambling - have a GREAT DAY!!!
0

Featured Post

Want to be a Web Developer? Get Certified Today!

Enroll in the Certified Web Development Professional course package to learn HTML, Javascript, and PHP. Build a solid foundation to work toward your dream job!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question