?
Solved

Running Exchange OWA on non standard port, will not work with SSL...  Help!

Posted on 2005-03-10
3
Medium Priority
?
186 Views
Last Modified: 2008-01-16
Hello,

I am running an Exchange 2003 server with OWA running on port 5469 (just to help get away from hackers).

When I connect to this server without SSL, it works fine, no problems.  If I enable SSL (on 443 of course) I get a message that the page cannot be found.  It's not the "you must use https" error page, its just a page cannot be found.  This problem also applies to the default website, so it is not an exchange only issue.  I am using https://servername:5469/exchange as the URL.  At this point I am working on the local lan only.  So there are no firewalls etc causing any problems.

If I set the server back to port 80, everything works just fine with or without SSL.  

So my question is, is there something I have to do when creating my cert or when telling OWA to use SSL that it needs to use this non standard port?  Why would it not work just because the listening port was changed?
0
Comment
Question by:caw01
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 4

Expert Comment

by:neisner
ID: 13516614
I would suggest creating an http site on port 80 that does nothing but redirect to your secure site.  In your IIS manager when setting the redirection to a URL on the Home Directory tab, just enter https://servername:5469/exchange.  So basically you will have this:  http://servername -> https://servername:5469/exchange

I started doing this because I found that it is too much to ask a lot of users to type "https" instead of "http"...  :)
0
 
LVL 104

Accepted Solution

by:
Sembee earned 1500 total points
ID: 13517839
Security via obscurity is not security.
If someone is determined enough to find your site then they will just scan every port.

Personally I would just leave OWA running on standard ports. Block port 80, leave 443 open. I have found that users will quickly learn to type https instead of http.
OWA also doesn't seem to like operating on different ports - I have had no end of problems using it on non standard ports - but put it back and it works correctly.

Simon.
0
 

Author Comment

by:caw01
ID: 13519268
Actually, since I was using SSL, I should have done a :443 instead of a :5469 for SSL.  My slip.  It is working fine now...sort of...

:)

0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Microsoft Outlook provides an easy way to recover permanently deleted items. When you empty the Deleted Items or simply deleted an Outlook data items using shift+Del key then it can be recovered using Registry Key settings.  Caution- Wrong Registry…
The biggest nightmare for any Exchange Server Administrator is to keep the server running without any issue. But the problems often come and they need to be resolved efficiently and timely. Here are important troubleshooting points: Define the Pr…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
Suggested Courses
Course of the Month14 days, 1 hour left to enroll

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question