I have J2 v1.4.2_03 installed; WebTrends 7 page installing Java Plug-In 1.3.1_11 Issue.

Howdy.

I've got J2 1.4.2_03 installed on a  Win2k Pro SP4 system with IE 6.0.2800.1106.  Previous to my accessing the WebTrends 7 site, going to IE/Tools/Internet Options/Advanced/Java Sun showed "Use Java 2 v 1.4.2_03...".  When I went to the WebTrends Web site, I got an error that "Java Plug-in 1.3.1_11 is not installed properly".  I don't have Admin rights on the machine in question; IT spent hours yesterday downloading the 1.3.1_11 Plug-In over and over, with the same resulting error message when I tried to access the WebTrends site, and there was no longer ANY "Use Java...for applet".

Since I've got J2 1.4.2_03 installed (sdk and jre), and I had the "Use Java 2 v 1.4.2_03..." plug-in in IE, I don't follow why any site is requiring an older Java Plugin.  Worse, when I run "java -version" from the command line, I now see:

     java version "1.3.1_01"
     Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1_01)
     Java HotSpot(TM) Client VM (build 1.3.1_01, mixed mode)

I'm confused by this because my Path is:

     PATH=C:\WINNT\MS\SMS\CORE\BIN;C:\ORACLE\ORA92\BIN;C:\WINNT;C:\WINNT\SYSTEM32;C:\
     WINNT\SYSTEM32\WBEM;C:\PROGRAM FILES\ORACLE\JRE\1.3.1\BIN;C:\PROGRAM FILES\ORACL
     E\JRE\1.1.8\BIN;C:\PROGRAM FILES\IBM\IBM CICS UNIVERSAL CLIENT\BIN;C:\PROGRAM FI
     LES\REFLECTION\;C:\Program Files\IBM\Ondemand32;C:\Program Files\Java\j2sdk1.4.2
    _03\bin;

I would think having the pathing to the "j2sdk1.4.2_03\bin" would override the older "bins" earlier in the path.  Anyway, when I set the path manually at the command line to "C:\Program Files\Java\j2sdk1.4.2_03\bin;" and navigate to my IE directory and enter "iexplore.exe" (all from the command line), I'm able to run IE, go to the WebTrends site, get prompted for the 1.3.1_11 plugin--and install it (w/o admin rights)!  As long as I set the path like that and launch IE from the command line, I can browse to the WebTrends site and view all applets via the 1.3.1_11 plugin.  I also see a "Use J2 v 1.3.1_11 for applet" in IE now (where the "Use J2 v 1.4.2_03" went I have no idea...).

I don't understand this, but this problem seems tied to my Path statement?  I'd really rather have my IE use the J2 v1.4.2_03 plugin I know I had before; I doesn't appear anymore in IE although I see it's Java Plug-In Control Panel item in my Control Panel (in addition to a shiny new "Java Plug-in 1.3.1_11" control panel item). What am I not understanding about Java's JVM / IE Plugin that would cause a site to require an older Plug-in?  Plugins aren't backward compatible?

LVL 10
edwardiiiAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
CEHJConnect With a Mentor Commented:
It's conceivable that the site designers have fallen foul of the messy way in which plugins are specified. See:

http://java.sun.com/products/plugin/versions.html
0
 
CEHJCommented:
>>.  Previous to my accessing the WebTrends 7 site

What are the pages in question?
0
 
objectsCommented:
>  don't follow why any site is requiring an older Java Plugin.

sounds like they explicitly specify what version is required

> I would think having the pathing to the "j2sdk1.4.2_03\bin" would override the older "bins" earlier in the path.

C:\WINNT;C:\WINNT\SYSTEM32 comes before it, it is probably getting picked up in there
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
objectsCommented:
Mixing versions with 1.3 has its problems.
Try installing 1.3 and then 1.4.
0
 
objectsCommented:
> Try installing 1.3 and then 1.4.

Sorry thats the wrong way around. You need to ensure you install 1.3 last (which it sounds like you are already doing)
0
 
edwardiiiAuthor Commented:
CEHJ:

I didn't list the URL because it's accessed via a username/password; no one else can see the pages I'm referring to.  They are the detail pages that break down our users' hits to my company's intranet pages.  They are full of Java applets.

objects:

Do you feel if I have IT re-arrange the Path on this machine so that "C:\Program Files\Java\j2sdk1.4.2
    _03\bin;" precedes "C:\WINNT;C:\WINNT\SYSTEM32 ", this will solve the erroneous java -version - 1.3... results?

Am I understanding correctly--it doesn't matter if you've got a later Java Plugin (e.g. 1.4.2...), a site can require an older plugin version?  If that's true, what's the deal with my (now lost) 1.4.2 plugin?  This seems beyond belief because it means we would forever be installing various plugin versions regardless of age (it would make more sense to me to be safe with the latest version at all times).
0
 
objectsConnect With a Mentor Commented:
> -it doesn't matter if you've got a later Java Plugin (e.g. 1.4.2...), a site can require an older plugin version?

correct

> what's the deal with my (now lost) 1.4.2 plugin?

sounds like your registry may have problems.
Perhaps try uninstalling all plugins, then install 1.4 followed by 1.3

> This seems beyond belief because it means we would forever be installing various plugin versions regardless of age

Yes people should at least attempt to have their applet support all versions.
0
 
edwardiiiAuthor Commented:
Ok, you've both enlightened me as to the poor coding the WebTrends site is using to handle the plugin issue.  Per CEHJ's link, in my situation I may be prompted to load Plugin version 1.4..again in the future.  objects, I found that removing "C:\PROGRAM FILES\ORACLE\JRE\1.3.1\BIN;C:\PROGRAM FILES\ORACLE\JRE\1.1.8\BIN;" from my path removes the "Java Plug-in 1.3.1_11 is not installed properly" error when I open IE.

All I'm still wondering is--why would my firing IE from the command line (after I adjusted the path) allow me to install the 1.3.1 plugin?  Per the info below, I may be prompted to load 1.4 plugin again, and I'm trying to avoid calling IT to the desktop to install something that's already there.  It seems odd to me that I don't see either plugin in Add/Remove Programs...

"Question: What happens when an older version of the plug-in is installed on top of a newer version? For instance, some customer sites use automated batch
installation programs that remotely update users' computers over the local network. If 1.3.1 were installed on a computer that already has 1.4, would applets that require 1.4 still work? Would applets that require 1.3.1 work?

Answer: Assuming that version 1.4 was not removed, both applets should still run. However, a problem can occur when an older version of Plug-in is installed after a newer version. Suppose 1.3.1 is installed after 1.4 is installed and both are still present on the system. If the user goes to a page that specifies clsid:8AD ... (dynamic versioning) with a codebase with version 1.4, then Plug-in will prompt the user to install 1.4 again, even though it is installed. This is what is happening in this case: The download services checks the clsid:8AD ... for version and finds it to be 1.3.1 (the last installed version), and it compares this to the version indicated in the codebase, which is 1.4. It decides that the user needs to install 1.4."

0
All Courses

From novice to tech pro — start learning today.