?
Solved

SSI not working

Posted on 2005-03-10
7
Medium Priority
?
271 Views
Last Modified: 2010-03-04
I am running a script on my server, or trying to run it. Here is my problem.

I have a file with a .html extention that is calling a .php file using SSI

The .php file in turn compiles two documents, header.html and footer.html along with some xml feeds.

The footer.html file has a SSI call to a script in my cgi bin that should put internal links on my site. Here is the Include <!--#include virtual="/cgi-bin/random/rotator.cgi?id=links"-->

Everything works fine except for the SSI call to the script in my cgi-bin. When I look at my webpage in a browser the links aren't there. When I check the source code of my page I can see the SSI call to the cgi-bin script.

I have the following in my .htaccess file

AddType text/html .html
AddHandler server-parsed .html
Options Indexes FollowSymLinks Includes

Thanks for any help.
0
Comment
Question by:timshank
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
7 Comments
 
LVL 27

Expert Comment

by:caterham_www
ID: 13516364
One reason might be that AllowOberride in httpd.conf is not set at least to FileInfo.

Open httpd.conf/vhost.conf and search for your Directory container (there are more than one Directory-Containers).

The container might look like

<Directory /path/to/your/docroot>
Options Indexes FollowSymLinks
AllowOverride Options
</Directory>

add FileInfo to the Directive AllowOverride
AllowOverride Options FileInfo
0
 

Author Comment

by:timshank
ID: 13517977
It was set to AllowOverride None and I changed it to AllowOverride Options FileInfo but it still isn't working.
0
 
LVL 27

Accepted Solution

by:
caterham_www earned 252 total points
ID: 13518374

Lets check this in httpd.conf (apache 1.3).

search for

    # To use server-parsed HTML files
    #
    #AddType text/html .shtml
    #AddHandler server-parsed .shtml

uncomment the lines to

AddType text/html .shtml .html
AddHandler server-parsed .shtml .html

and check, if it's working
0
 
LVL 51

Assisted Solution

by:ahoffmann
ahoffmann earned 248 total points
ID: 13524347
you need to enshure that Options contains Includes and does  not contain IncludeNoExec
Some servers need ExecCGI too (but never seen this for apache, just worth a try)
0
 

Author Comment

by:timshank
ID: 13693966
Yes, please go ahead and split the credits.

I couldn't get it to work so I went about it another way.

Thanks,
Tim
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you've heard about htaccess and it sounds like it does what you want, but you're not sure how it works... well, you're in the right place. Read on. Some Basics #1. It's a file and its filename is .htaccess (yes, with a dot in the front). #…
In Solr 4.0 it is possible to atomically (or partially) update individual fields in a document. This article will show the operations possible for atomic updating as well as setting up your Solr instance to be able to perform the actions. One major …
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
Suggested Courses

741 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question