Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 239
  • Last Modified:

Window XP Sharing whole C:\

I just bought a new pc and realise that it kept sharing the entire c: drive.
I have tried to disable the sharing a couple of times but it kept repeating the sharing once I reboot or restart the system.

When I disabled the sharing, there is an alert message notifying that the sharing is for administrative purpose.

Please advise on how to permanently disable this sharing.

Many thanks

0
kogan1802
Asked:
kogan1802
  • 2
  • 2
1 Solution
 
Pete LongConsultantCommented:
Disable Windows hidden shares ($)

Start >Run Type "regedit" {enter}

Navigate to

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters

Modify or create new REG_DWORD Entries shown below


AutoShareServer
AutoShareWks

Set the values as follows

0 = disable shares
1 = enable

WARNING, some programs and services use the hidden share feature I STRONGLY advise
you carry this out either in a test environment OR on your least used server for a trial period
0
 
kogan1802Author Commented:
Hi PeteLong,

I have created the two files (AutoShareServer and AutoShareWks) and have put in 0 for the Value Data field.

Now I am going to reboot my PC and see what it gets...

thanks
0
 
kogan1802Author Commented:
Hi Mate,

Believe it or not, it works. Thank you very much for "sharing" .

cheers
0
 
Pete LongConsultantCommented:
ThanQ
0

Featured Post

[Webinar On Demand] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now