IBM T21 Laptop Won't start

Hello,

I have a T21 Laptop computer that won't start most of the time. The battery is good and the power supply is good. I had the mother board replaced and it worked fine for about a week or so. I then noticed that sometimes I had to push the power button off and on a few times for it to boot. Now, I have to push the power button up to 50 times before it will turn on and boot. The power light comes on and nothing else happens. No beep, no LCD or anything. I've reseated the memory.

I just replaced the hard drive (needed a new one anyway).

I just received and replaced the keyboard hoping that the button was bad. But, it didn't change anything. Any other ideas?

Thanks,
John
LVL 1
jhiebAsked:
Who is Participating?
 
ddrdanConnect With a Mentor Commented:
Step #1 - Here's the service steps for checking power problems. Do this first. http://www-1.ibm.com/support/docview.wss?rs=0&uid=psg1MIGR-4PEJF3&loc=en_US

The location of your cmos battery is behind the battery pack. Here's an exploded view of your unit and the battery (it's #11) location:
http://www-1.ibm.com/support/docview.wss?rs=0&uid=psg1MIGR-4UYKLK&loc=en_US

If all power checks pass:
Reconnect power. Make sure that every connector is connected tightly and correctly. If you still have the problem it means 3 things: BAD DIMM (memory) or BAD System board and an outside chance it's a BAD Power Switch.

If the power switch is sticking after its depressed it will cause a fault in the system. If you had the mobo replaced at a service center they should have checked that switch before installing the new board. Ask if them if they did. If you replaced the board, check the power switch with a meter for continuity across the leads when depressed. Make sure the battery is out and brick is unplugged.

Check all the tips that apply to your problem in this document under "solving problems":
ftp://ftp.software.ibm.com/pc/pccbbs/mobiles_pdf/27p2093.pdf




0
 
rindiConnect With a Mentor Commented:
The CMOS backup battery may be bad. Try replacing that battery (I think it is located between the normal battery and the keyboard.
0
 
nobusConnect With a Mentor Commented:
did you try running it from AC only, or from the battery only?
0
 
jhiebAuthor Commented:
Well, I finally had the gumption to take the laptop apart and check all the connections. I am not sure exactly what solved the problem but it is working, now.

When I took the laptop apart, I checked each connection and they appeared to be fine. But I still removed the connectors and put them back on. I noticed that the connector where the power supply connects was connected fine but the wires themselves appeared to wiggle. So, I wiggled them for awhile and then put the connector back on.

Anyway, it appears to be a loose connection that was causing this problem. I'll divide the points with everyone for your help. Thank you for your suggestions.

Sincerely,
John
0
 
rindiCommented:
thanx
0
All Courses

From novice to tech pro — start learning today.