?
Solved

Sendmail Authenticated Relay Not Working: SASLAUTHD giving errors and SENDMAIL not shutting down

Posted on 2005-03-15
5
Medium Priority
?
1,240 Views
Last Modified: 2013-12-17
Hi all,

I am trying to setup SMTP authentication which allows relaying. I want my users to authenticate when RECEIVING and SENDING email using my mail server.

I am using Red Hat Linux Enterprise 3 WS (Taroon Update 4) as my distro.

I tried to setup the required things for this : 1)Cyrus SASL 2)Open TLS 3)Sendmail

I downloaded and built all of these again.... but when i tried running SASL Authentication Daemon (SASLAUTHD) i run into trouble and also when i run /etc/init.d/sendmail stop ; it fails it and doesn't stop sendmail .

THe following are the outputs I was getting:

[root@myserv]# /etc/init.d/saslauthd start
Starting SASL Authentication Daemon: saslauthd[7186] :main            : could not chdir to: /var/state/saslauthd
saslauthd[7186] :main            : chdir: No such file or directory
saslauthd[7186] :main            : Check to make sure the directory exists and is
saslauthd[7186] :main            : writeable by the user this process runs as.
[root@myserv]# service sendmail restart
Shutting down sendmail:                                    [FAILED]
Shutting down sm-client:                                   [FAILED]
Starting sendmail:                                         [  OK  ]
Starting sm-client: sendmail: fatal: flush queue mode requires no recipient
                                                           [FAILED]
[root@myserv]# /etc/init.d/sendmail stop
Shutting down sendmail:                                    [FAILED]
Shutting down sm-client:                                   [FAILED]

Hoping I get to resolve this issue at the earliest.
Thanks in advance.

PS:Reading thro sendmail.org is a bit difficult to understand and implement.

I would appreciate if a detailed method as to how to set SMTP auth could be provided.
- Arshkit
0
Comment
Question by:ARSHKIT
2 Comments
 
LVL 14

Expert Comment

by:kenfcamp
ID: 13594534
When you compiled (ran ./configure) cyrus-sasl you probably included something like [--with-saslauthd=/var/state/saslauthd]

This should be [--with-saslauthd=/var/state]
0
 
LVL 40

Accepted Solution

by:
jlevie earned 2000 total points
ID: 13608205
Your best bet for getting SMTP AUTH working is to undo your install of 1)Cyrus SASL 2)Open TLS 3)Sendmail  and reinstall the RHEL packages they damaged. Once that's done enable SMTP AUTH for LOGIN & PLAIN only in sendmail.mc and enable the saslauthd service.

Note that SMTP AUTH only affects external users. It will not help in controlling who can send mail from the mail server itself.
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Steps to fix “Unable to mount database. (hr=0x80004005, ec=1108)”.
Stellar Exchange Toolkit: this 5 in 1 toolkit comes loaded with mega-software tool. Here’s an introduction to tools’ usage and advantages:
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Suggested Courses
Course of the Month8 days, 13 hours left to enroll

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question