• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1454
  • Last Modified:

BACKUP issue on Red hat Linux

Hi Experts,
I am using the following simple script for making full dumps of file server running on Red Hat Linux 8.0.
-------------------------
[abc@enterprise backup]$ cat fullback0.sh
#!/bin/sh

#set -x

/etc/init.d/cache stop

/sbin/dump -0uq -b 64 -f /dev/nst0 /
/sbin/dump -0uq -b 64 -f /dev/nst0 /home
/sbin/dump -0uq -b 64 -f /dev/nst0 /usr

/bin/mt -f /dev/nst0 rewind
/bin/mt -f /dev/nst0 offline

/etc/init.d/cache start

#set +x
-----------------------------------
I am using Sony SDT 9000 tape drive and HP DDS2 8GB tapedisk and following is the disk space:

[abc@enterprise backup]$ df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda1             3.8G  2.6G  1.0G  71% /
/dev/hda2             980M  560M  371M  61% /home
none                  125M     0  124M   0% /dev/shm
/dev/hda3             888M  8.2M  834M   1% /stand
/dev/hdb1             5.8G  3.9G  1.6G  71% /usr
------------------------------------------------
The backup procees did dump of two filesystems / and /home and stopped with the message End of Tape deteceted.
Here is the brief extract of log file :
Stopping cache:
  DUMP: Date of this level 0 dump: Wed Mar 16 00:01:10 2005
  DUMP: Dumping /dev/hda1 (/) to /dev/nst0
  DUMP: Added inode 7 to exclude list (resize inode)
  DUMP: Label: /
  DUMP: mapping (Pass I) [regular files]
  DUMP: mapping (Pass II) [directories]
  DUMP: estimated 2716240 tape blocks.
  DUMP: Volume 1 started with block 1 at: Wed Mar 16 00:01:18 2005
  DUMP: dumping (Pass III) [directories]
  DUMP: dumping (Pass IV) [regular files]
  DUMP: 3.99% done at 361 kB/s, finished in 2:00
  DUMP: 8.17% done at 369 kB/s, finished in 1:52
  DUMP: 12.34% done at 372 kB/s, finished in 1:46
  DUMP: 16.49% done at 373 kB/s, finished in 1:41
  -----
  DUMP: 95.63% done at 376 kB/s, finished in 0:05
  DUMP: 99.80% done at 376 kB/s, finished in 0:00
  DUMP: Closing /dev/nst0
  DUMP: Volume 1 completed at: Wed Mar 16 02:02:31 2005
  DUMP: Volume 1 2735936 tape blocks (2671.81MB)
  DUMP: Volume 1 took 2:01:13
  DUMP: Volume 1 transfer rate: 376 kB/s
  DUMP: 2735936 tape blocks (2671.81MB) on 1 volume(s)
  DUMP: finished in 7267 seconds, throughput 376 kBytes/sec
  DUMP: Date of this level 0 dump: Wed Mar 16 00:01:10 2005
  DUMP: Date this dump completed:  Wed Mar 16 02:02:31 2005
  DUMP: Average transfer rate: 376 kB/s
  DUMP: DUMP IS DONE
  DUMP: Date of this level 0 dump: Wed Mar 16 02:02:32 2005
  DUMP: Dumping /dev/hda2 (/home) to /dev/nst0
  DUMP: Added inode 7 to exclude list (resize inode)
  DUMP: Label: /home
  DUMP: mapping (Pass I) [regular files]
  DUMP: mapping (Pass II) [directories]
  DUMP: estimated 571832 tape blocks.
  DUMP: Volume 1 started with block 1 at: Wed Mar 16 02:02:35 2005
  DUMP: dumping (Pass III) [directories]
  DUMP: dumping (Pass IV) [regular files]
  DUMP: 19.98% done at 380 kB/s, finished in 0:20
  DUMP: 39.80% done at 379 kB/s, finished in 0:15
  DUMP: 59.49% done at 377 kB/s, finished in 0:10
  DUMP: 79.31% done at 377 kB/s, finished in 0:05
  DUMP: 99.14% done at 377 kB/s, finished in 0:00
  DUMP: Closing /dev/nst0
  DUMP: Volume 1 completed at: Wed Mar 16 02:28:00 2005
  DUMP: Volume 1 574208 tape blocks (560.75MB)
  DUMP: Volume 1 took 0:25:25
  DUMP: Volume 1 transfer rate: 376 kB/s
  DUMP: 574208 tape blocks (560.75MB) on 1 volume(s)
  DUMP: finished in 1519 seconds, throughput 378 kBytes/sec
  DUMP: Date of this level 0 dump: Wed Mar 16 02:02:32 2005
  DUMP: Date this dump completed:  Wed Mar 16 02:28:00 2005
  DUMP: Average transfer rate: 376 kB/s
  DUMP: DUMP IS DONE
  DUMP: Date of this level 0 dump: Wed Mar 16 02:28:00 2005
  DUMP: Dumping /dev/hdb1 (/usr) to /dev/nst0
  DUMP: Added inode 7 to exclude list (resize inode)
  DUMP: Label: /usr
  DUMP: mapping (Pass I) [regular files]
  DUMP: mapping (Pass II) [directories]
  DUMP: estimated 3933295 tape blocks.
  DUMP: Volume 1 started with block 1 at: Wed Mar 16 02:28:14 2005
  DUMP: dumping (Pass III) [directories]
  DUMP: dumping (Pass IV) [regular files]
  DUMP: 2.85% done at 373 kB/s, finished in 2:50
  DUMP: 5.73% done at 375 kB/s, finished in 2:44
  DUMP: 8.61% done at 376 kB/s, finished in 2:39
  DUMP: 11.47% done at 376 kB/s, finished in 2:34
  DUMP: 13.95% done at 365 kB/s, finished in 2:34
  DUMP: End of tape detected
  DUMP: Closing /dev/nst0
  DUMP: Volume 1 completed at: Wed Mar 16 02:56:32 2005
  DUMP: Volume 1 620544 tape blocks (606.00MB)
  DUMP: Volume 1 took 0:28:18
  DUMP: Volume 1 transfer rate: 365 kB/s
  DUMP: Change Volumes: Mount volume #2
  DUMP: Is the new volume mounted and ready to go? - forced abort
  DUMP: The ENTIRE dump is aborted.
---------------------
Moreover, I got the following enteries in the /etc/dumpdates :
[abc@enterprise /etc]$ cat dumpdates
/dev/hda1 0 Wed Mar 16 00:01:10 2005
/dev/hda2 0 Wed Mar 16 02:02:32 2005
------------------
As I am using a sufficient big tape cassette of 8GB, I couldn't understand as why end of tape was detected.

Secondly, when I used Restore program to check for all that is stored, I could only find the contents of first filesystem  / and when I changed to second file system /home, it was empty and has nothing in it .
[root@enterprise home]# /sbin/restore -i -b 64 -f /dev/nst0
/sbin/restore > cd /home
/sbin/restore > ls
./home:

---------------------------------------------

Can anyone explain as what went wrong ?
Thnaks in advance for your cooperation.





0
mn210
Asked:
mn210
  • 18
  • 6
1 Solution
 
mn210Author Commented:
Still looking for help ....
0
 
mn210Author Commented:
I tried the same script with different tape cassette and got the same log file and only the contents of first filesystem / and nothing for the second filesystem /home. Even though the tape cassette is of 8GB , how can I increase the Logical-End-of-Tape which dump detects and set it to Physical-End-of-Tape
Still in a fix ....
looking for help ...
0
 
mn210Author Commented:
looking for help ...
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
mn210Author Commented:
Any help please .....
0
 
wesly_chenCommented:
Hi,

1.  Use /dev/hda1 instead of "/" since / includes every filesytem.
/sbin/dump -0uq -b 64 -f /dev/nst0 /dev/hda1

2.  Try to use -a (auto-size, bypass all tape length calculation) for dump and run it from command line first.
/sbin/dump -0auq -b 64 -f /dev/nst0 /dev/hda1

Regards,

Wesly
0
 
mn210Author Commented:
Hi Wesly,
I made the changes as you mentioned but still get the same log file with nothing in /home filesystem and abrupt stop in the /usr filesystem. What else should I check for ?
Thanks
0
 
wesly_chenCommented:
Did you test your tape drive in command line instead of script first.

/sbin/dump -0auq -b 64 -f /dev/nst0 /dev/hda1
/sbin/dump -0auq -b 64 -f /dev/nst0 /dev/dha2
/sbin/dump -0auq -b 64 -f /dev/nst0 /dev/hdb1
0
 
mn210Author Commented:
As the cache server is supposed to be running all day thro' , is there any way out how can I run these commands from command line during day time as the back up usually starts at midnight.
0
 
wesly_chenCommented:
Pick the small partitions for testing without shuting down cashe server.
/stand and /home are smaller. Run the following commands during the day time (NO /etc/init.d/cache stop)

/sbin/dump -0auq -b 64 -f /dev/nst0 /dev/dha3
/sbin/dump -0auq -b 64 -f /dev/nst0 /dev/dha2
0
 
mn210Author Commented:
With the same tape cassette in the tapedrive, I got this message :

[root@enterprise etc]# /sbin/dump -0auq -b 64 -f /dev/nst0 /dev/dha3
  DUMP: You can't update the dumpdates file when dumping a subdirectory
  DUMP: The ENTIRE dump is aborted.
[root@enterprise etc]# /sbin/dump -0auq -b 64 -f /dev/nst0 /dev/dha2
  DUMP: You can't update the dumpdates file when dumping a subdirectory
  DUMP: The ENTIRE dump is aborted.
0
 
mn210Author Commented:
Hi Wesly,
Is it like that I need to erase all data from tape cassette as it assumes /home and /stand as subdirectory which are already dumped earlier when I used the script file with command : /sbin/dump -0uq -b 64 -f /dev/nst0 / instead of
/sbin/dump -0uq -b 64 -f /dev/nst0 /dev/hda1.
Thanks
0
 
wesly_chenCommented:
Good point. Please erase the previous content or replace a new tape to test.
0
 
mn210Author Commented:
Secondly, I want to run hostdump.sh ( free script provided  by storage mountain ) at the following link http://www.backupcentral.com/hostdump.html
Can I use it fot Red Hat Linux 8.0 ?
If so, do I need to just use the following command in crontab or add something else:
/usr/local/backup/hostdump.sh 0 /dev/nst0  logfile enterprise
Lastly, How can I stop and start the cache server in this script ?
0
 
mn210Author Commented:
One thing more , the hostdump.tar file also extracts localpath.sh and rempath.sh . Are these files also need to be used ?
0
 
mn210Author Commented:

Hi Wesly,
I erased the previous content as well  replaced a new tape to test but got the following  message for the same script:
-----------------------
Stopping cache:
  DUMP: SIGSEGV: ABORTING!
-----------------------
What could be the reason ? Can you please clarify.
Thanks for being so supportive.
0
 
mn210Author Commented:
still looking for help ....
0
 
wesly_chenCommented:
>  DUMP: SIGSEGV: ABORTING!
  It seems something wrong (corrupted) with command file "dump" itself or the associated libraries.
Please do
shutdown -rF
to reboot and run fsck at boot.
Or
touch /forcefsck
then schedule to reboot.
0
 
mn210Author Commented:
sorry for the long delay ... Actually, I was out of town .
I tried and run fsck at boot but still got the same mesage :
---------------------------------------
DUMP: SIGSEGV: ABORTING!
Segmentation fault (core dumped)
----------------------------------------
What else can I try ?
0
 
mn210Author Commented:
still looking for help ...
0
 
mn210Author Commented:
still looking for help .....
0
 
mn210Author Commented:
I tried different options as said above but still am getting the same message :
------------------------------------------------------
[root@enterprise backup]# ./fullback0.sh
+ /etc/init.d/cache stop
Stopping cache:
+ /sbin/dump -0auq -b 64 -f /dev/nst0 /dev/hda1
  DUMP: SIGSEGV: ABORTING!
Segmentation fault (core dumped)
-------------------------------------------------------
Thanks in advance for your help ...
0
 
mn210Author Commented:
Still waiting for different ideas ...
0
 
mn210Author Commented:
looking for help ...
0
 
wesly_chenCommented:
Sorry, did you try to re-install dump.
rpm -e dump
rpm -ivh dump-0.4b28-4.i386.rpm

0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 18
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now